• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Search the Community

Showing results for tags 'Turbo'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Visit Owners Club Insurance Page
    • Opie Oils
    • Advertise Here
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Calendars

  • Community Calendar

Categories

  • Articles

Found 101 results

  1. Hi. I have an 08 reg Ford Focus TDCi. Recently when driving on mortorway and aceleeating (roughly about 2500 rpm) the car shudders then cuts out. It’s as if the fuel cuts out or the mixture is wrong. Could it be an issue with turbo? It’s a little unnerving. Luckily I have been able to drift to the hats shoulder. Any ideas?
  2. Hi, I bough a used Fiesta with 125bhp Ecoboost couple of months ago. Since I'm aware that the engine can get destroyed in a case of coolant loss I decided to have a closer look at it today. I noticed that the coolant hose that is going from turbo to the radiator has been worn out a bit by the heat shield that is protecting it. The head shield has bitten 1-2 mm into the hose and I see that it might potentially cause a slow coolant leak. For now I haven't lost any coolant but since these engines seem to need a proper cooling all the time I'm a bit worried of these kind of small imperfections in the cooling system. Im going to get my hose changed asap. Below is a picture of the hose and the heat shield.
  3. Hi guys First off let me introduce myself, you won't have met me yet....I'm the new boy 😊 I have a background as a semi skilled mechanic, semi, as I don' yet know it all!! So, I'm about to start retrofitting the GTC1244VZ VNT turbo from a 2015 1.6tdci Focus 115bhp, Ford could have saved me a job and just released the Fiesta with the correct power output but they didn't!! 😏 (that should give you some idea as to what comes next!) I'm lead to believe the current turbo is a wastegated TD025 however I've inspected the plate on the compressor housing, it wasn't all that revealing 😒 The current turbo appears to be ECU controlled by vacuum via a N75 type 'pressure converter valve' fed by the brake pump. My first consideration is the action of a wastegate being either open or closed, generally speaking at least; VNT has many increments between rest and full travel. Secondly, the wastegate is normally closed at rest, providing max boost; provided it has spooled up. Whereas the VNT setup (usually) the vanes are fully open at rest which obviously results in no boost at low rpm. This effectively means, although both engines are identical. The boost control is controlled in an opposite fashion. So, flash the ECU with the correct software to operate a VNT Turbo?? The map from the Focus 115 should do? Actually no, the 115 and the 105 use the Siemens ECU so the only option would be the old 110 hdi/tdci maps, they operated on an older Bosch ECU so it's not guaranteed to work either. My ECU is a EDC17C10 with the latest tricore and password protection, I'm sure it could be done, but it could go horribly wrong and cost thousands for a new ecu set plus it's keyless 😣 moving on then!! My next consideration is using an electronic controller, it is supplied as a full kit taking some sensor readings from it's own included sensors. T into the vac pump use it's own N75 valve and hey presto we should have VNT on the fizzie. I have ordered the kit 160 all in if it won' work the seller will allow a return for refund so it's a fairly safe gamble. I have a mechanical boost gauge installed anyway so I can shut it down if it goes a little Pete. Any suggestions out there? I know there will be some out there who will start by saying 'buy a bigger car' 'bigger turbo' ECT....if I wanted to drive something bigger I'd jump in the 13l R450 Scania, unit only turn the traction control off and have some real fun. Please, those types of comments are not required or wanted please troll elsewhere. Pics will start as it develops....first, the donor turbo
  4. Hey, I am having a "problem" with my Mk 2.5, EURO 5, Focus 1.6 TDCi 110HP (72k miles). After driving for long time (like an hour or more) at motorway speeds, the check engine light comes on and i get the P0234 Turbo Overboost error. The strange thing is that the car drives absolutely fine when the error occurs. No limp mode, no loss of power. There is no way to know the car is having the error without looking at the dashboard to see the check engine light. I tried to reset the error code, but it keeps reappearing in the above scenario. Tried going full throttle from 1st gear to 3rd changing gears at ~4000rpm and the problem did not occur. It seems to me like it only happens at higher gears/higher speeds. I have to mention I got the EGR mapped out at a local tunner, but I am thinking that the EGR was closed anyway at those speeds, so I doubt this could be the cause. I also have to mention that my DPF Differential Pressure is about 13 kPa ~80mph at full throttle and 0.6-0.9 kPa at idle, which seems a little bit high to me, but no errors logged yet about DPF. I was considering the clogged DPF causing too much pressure hence, the overboosting. Are those values indeed high or am I wrong? Is there any risk driving the car with the overboost code as long as limp mode doesn't occur? Any ideea that can help me diagnose my problem? Thank you!
  5. So I got fiesta 1.4 tdci 2003 130k miles real animal when it comes to work, I got blue ish smoke on acceleration, but nothing when at idle and in neutral, oil seals changed, no ticking noise nothing but got hissing noise from engine bay when accelerating, and oil after turbo in air intake don't know what to do, checked for leaks and found nothing, turbo seems fine any suggestions please. Thanks
  6. Hi So my first car was a mk4 escort and after 4 years of searching i have finally found a car just like mine was. Lets be clear, it´s a hobby car and i don´t want to keep it as original. Now my question is has anyone done an engine swap? What is the easiest fit? What ecu do you use? Can you turbocharge it? I have a serious problem. I am addicted to turbos. I´ve turbocharged almost all my cars so far. Now i don´t want to cut the body in any so it can´t be converted to original. maybe you can point out a doch engine that would easily fit the car and some links to find new forged internals. At the end i am hoping to get 180-220 bhp from the wheels. So i´m not gonna overdo this project. Do i even need forged internals or is there a ford engine that can be turbocharged and handle this small power? English is not my first language so i´m sorry if i´ve made some grammar mistakes. Thank you Raido
  7. Hi guys looking to get twin pipes and an st diffuser for my focus mk2 pre face lift 1.6TDCI. I'm going more for looks than anything else but I'm just wondering what I would do to make the car sound Nice, not looking for a huge BOOO or to be seriously loud just want it to be Nice, any recommendations? High flow air filters or what? Have no clue about exhaust modification or would an air filter even make it sound decent
  8. Came home from work just about to get changed to go out to eddie rockets rob your pockets with the other half but upon further investigation of the letterbox i had noticed that the stainless steel blank + gasket for blanking the egr had come in the post...so me being me (Any excuse to work on the car) I pulled out the tool box and fitted it. I'm no mechanic (just an electrician by trade) so I didn't really know what I was doing, i just about know a few odd things about cars so I kinda winged this instal because I couldn't find a tutorial to do this on my car.( probably is a few but wasn't arsed looking any longer) Now it makes it easier if you take off the scuttle panel but I think you have to take your bleeden wiper arms off and all and I hadn't got time for that as the missus was waiting. First thing I did was locate the egr valve, it's located behind the fuel filter. I took the 3x 8mm bolts off the black bracket that holds the filter in place. Then i removed the filter assembly and shoved it to the back of the engine bay ( fully intact) Second thing I did was take the bracket that the filter sits in to that bolts on to the side of the engine off so I could have the room to slide the blank and gasket in to place. There is another 3x 8mm bolts holding in place And last but not least I undone the two bolts on the valve just enough ( about 5mm) to get the gasket and the blank in to place. These are also 8mm Then put back together. Gonna try add all the pictures I have to this post. You will know what I'm talking about when you see the pictures. This is not a massively detailed tutorial as I ain't got time for that but it's enough so that you'll have half of an idea of what to do. The picture with the red circle is where you slide your blank plate in. Total cost =10.50 time= 30 mins.( not including scrubbing the hands haha)
  9. Focus tdci boost problem

    Hi, having a bit of an issue, my car is grand when it's cold it has power but just as the engine starts to get warm theres absolitely no power in all gears, there's no engine light on, its not throwing a code and it's not in limp mode. From reading other forums I've been lead to believe that it might be the boost control solenoid. Does anyone know anything about this problem and could someone help me locate the solenoid, thanks a lot!
  10. Hi Everyone New to the site, just after some advice. I have a 2009 1.8 tdci Focus, car drives well apart from when accelerating. So when I'm approaching a junction or roundabout, where you would usually drop it in to second gear just to keep moving. when i press on the throttle there is a serious lack of power just feels flat. so i drop it into first when moving and have to slip the clutch a little. seems like lagging from the turbo, but im unsure. I'm not able to drive the car in a normal fashion, if you have to pull off quick it doesnt really happen as there is to much lag, so give it a rev and pull off faster the required, there is no middle ground. Cheers
  11. Hi! As i said in a previous thread, i finally installed the turbosmart Dual Port Valve. I found the installation quite confusing for me so i let a good mechanic friend of mine to do the job. When it was done, we test drive it. Here is the impressions... 1.- If you drive very slowly and calmly, uncle-mod, you will feel you haven't changed anything. 2.- If you drive happy (revving up to 2.500-3.000) and shifting, then it will make a weird sound like a ¿pigeon? (ill come back to this) 3.- If you run fast! here the sound comes. Sounds like an EVO! nice and clear Swoosh sound. Im very happy with it, i haven't noticed loss in power, nor nothing similar. Coming back to the 2 point, its the only thing worrying me a little. I don't know wether its the valve making that sound coz as im not really flowing air into the turbo, so its like open-close-open-close making that funny noise (this is what the mechanic of mine said), or its the air going backward into the turbo and stopping the spool... this is what i don't want! any ideas, helps? Also, my friend advised me to change the air intake, coz the valve itself its quite hidden so by changing the air induction it will become much louder. Don't know about this... Thanks!
  12. Just got the car back from the garage, and he confirmed my worst fear, that I need a new turbo. So im not sure I should replace the turbo, car still runs but it has less power and has the turbo whine, mechanic says it would be around £700 to repair, which isn't to bad considering the turbo itself online is £599. so I said I don't know if its worth fixing, to which he said probably not. got a 2009 focus 1.6tdci thats done 109,000miles. and I've just spent £500 replacing lower suspension arms and all 4 springs. with the £700 on top, the cars not worth much more than the cost of the last 2 repairs. I could do it myself but am I bit wary of buying a turbo on the e bay for £250. thats just too cheap. thoughts and ideas? I was planning to keep the car until I went electric, but not sure about going electric yet.
  13. Anybody able to help me with my latest issue.... Ive recently developed a whirring/whining noise which is audible when accelerating, and is affected slightly regarding increasing speed, it is a little more lethargic. Thought id open her up today to get a proper look, and was greeted by a decent amount of dirt and possibly oil. Ive attached 3 pictures with the areas if not highlighted. Pic 1 shows the dirt on top of the turbo and the heat shield. Pic 2 is a side on view of the turbo and heat shield and oil pipe covered in dirt. Pic 3 shows under the turbo the areas that appear to be suffering a leak of some kind. Any help or advice is greatly appreciated.
  14. ok so i bought a 2005 mondeo ghia 2.0 tdci 130ps, on the way home the coil light was flashing and there was a lack of power, felt like it was a non turbo'd diesel, it didnt cut out and it would rev out to 4k also (meaning the revs weren't limited), it has none gone off since even after restarting, constant flashing and lack of power, however i have noticed when you first start it it runs fine for about 5 seconds before the light apears. now after doing some research i have changed the fuel filter, full tank of premium bp diesel, cleaned egr and inlet manifold, checked for sticky turbo actuator and checked all fuses and relays. after going through some of the paper work that came with the car it turns out that 5 years ago it had 4 brand new injectors and a brand new fuel pump aswell as some other bits and bobs most of which were service and mot paperworks. i have now run out of ideas and money (for now) and cant think what else is wrong with it, so any advice would be greatly appreciated
  15. Vacuum hose?

    Whilst changing my turbo hose (the 90 degree one) I've managed to break the little black plastic pipe which comes off the turbo. I'm making the assessment that it's a vacuum pipe, and I've wrapped a whole load of tape on it for now. It seems to work OK, the turbo kicks in with seemingly no loss of power, but it's far from a permafix, so I have two questions: A) What is it? B) how much will it cost me to fix it properly? Thanks in advance
  16. Hi all, I have Mondeo 2.2 09 plate. I think I have a boost leak (the distinct whooshing noise is hard to miss when the windows are down). I have checked the intercooler pipes and they are good. Induction pipe onto the turbo is fastened correctly (No movement at the turbo end) and there is nothing blocking the airflow around the airbox. Does anyone have any ideas on where else it can be? Thanks, Jono
  17. Hello Yesterday I went to the shop and had the cat go into limp mode (engine system fault) manage to clear it and fine on way to work this morning. After leaving work tonight I noticed a whistle sound from the engine bay, I popped the bonnet and noticed it was blowing from the clamp that connects the dpf and turbo, I thought I could make it home but car was soo underpowered like limp mode but even less power (10MPH) so I pulled over took the dpf off and refitted using gum gum to seal the gap which worked fine but when I tried to pull away the same thing happened 10mph 2800 - 3000 RPM at this point there's nowhere to pull over and noticed thick black smoke out the back, about a minute later the engine makes a hissing noise I pulled over on the grass turned the engine off opened the bonnet and the turbo was smoking/steaming and one off the dpf pressure sensor was blown off I tried to reconnect it but blew off as soon as I started the engine. I have towed it to my garage. Am I right in thinking it's a turbo failure or do I have something more serious? Thanks in advance
  18. Fiesta mk6 turbo???

    I was looking around and was wondering if I can put a turbo on my 1.6 fiesta zetec s? im looking for a moderately priced 'bolt on' kit. Not really looking to do fabrication work. i was jus wondering if the engine is able to cope with a turbo? And if not what other options are there for increasing power?
  19. Hi, I drive a 2013 focus 1.6 diesel and want to modify the car to make more power without spending a lot of money. Can anyone recommend suitable modifications, preferably those who have done it to the same car. Thanks
  20. Hi all, I have had the current c max cor over 3 years now and other than the damn annoying squeaking dashboard, I have enjoyed it greatly, just wish there was a cruise control but you can't have everything. To cut to the chase, TURBO NOISE! Over the past year the turbo whine has become increasingly noisy, but now it has got to a horrendous screaming noise. I presume it is the turbo fan, but, I have read elsewhere it could be a number of things. Having replaced the clutch and dual fly wheel only last year I could seriously do without another expensive repair. How simple is it to refit a turbo?
  21. Anyone able to advise on the removal of a damaged sump, and subsequent fitting of a new replacement on a 2015 Fiesta 1.0T (140)? Looks like the exhaust may foul any straight-forward removal of the existing casing?
  22. Hello I got my car remapped today, but when I picked it up the mechanic said I have severe underboost and recommended replacing the turbo. Does anyone know anything about underboost that could shed some light. Thanks in advance
  23. Turbo or split hose?

    Hi all….! Brand new newby here, asking about a problem I have with my 2010 Mondeo Estate 1.8 TDCI. On acceleration, just as the turbo kicks in at about 2000rpm, there is a low noise – like a wooo . The pitch does not increase with the engine speed. I have managed to record and upload the noise it makes here: https://youtu.be/zJv3o48Dv74 Is that the turbo or maybe a hose split, do you think.? Thanks for any help offered.
  24. 2005 1.6tdci i have found a vacuum pipe that is hanging from underneath the turbo, I cannot see where this attaches any help would be appreciated
  25. Hello, Go easy on me, it's my first post! I'm confused, frustrated and ill with the stress my car has caused me. I have a 2014 plate Ford S-Max Titanium, 2.0 TDCI. Purchased from a Ford Dealer at about 15 months old. It is still under warranty until April. It's been in a Ford garage since 16th Feb (11 days ago), after suddenly cutting out while driving the previous day and losing all power completely. It brought up a warning light saying "Service Now" or something along those lines, and apparently when they first got it in they were completely stumped as it was bringing up lots of different fault codes. As of about 4:50pm today, they STILL haven't been able to identify the exact problem. I know they haven't been consistently working on it, as they have had to contact Ford's Technical Department for assistance with it. They have said on more than one occasion that it is the turbo that isn't working, but they don't know why it's not working. I asked today if they can't just do something to get it going again, but he's said no. So at the minute, I am gathering my car is unfixable? Has this happened to anyone before? Specifically with a car still under warranty? At the minute I'm totally in limbo