AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Brake+light'.

Found 225 results

  1. Hi there, wonder if anyone can help?  I have a 03 1.6 Streetka that normally runs ok but yesterday started this issue of revs not dropping off when you take your foot off the pedal.  This morning I try it and it runs fine again.  No doubt it will return again when it feels like it!  Likely causes? What to do? Although she normally runs real sweet, she has had the engine light on for a while. The local indy took a look some time ago and suggested it might be one of 2 sensors on the exhaust, but that one is likely to break off when changed and if that happened it might mean replacing the exhaust.  Is it possible to check a sensor?  This morning I have pulled Obd code P0420, which is clearly to do with the exhaust but not sure of the best plan of action?  Could this be something to do with the revving issue or have I now got 2 separate problems to sort. Any thoughts or advice would be greatly appreciated. Jeff
  2. Morning all Been trowling through the net for this, and cant find anything, so apologies if its already been answered/posted. Please feel free to just point me to the thread if so.  Sooo. I got my Mk 2.5 1.6 tcdi Zetec the other week. Looking to do a few bits to improve it. One of which is the interior lights. I always liked having the map readers in my Seat Ibiza, so id like to upgrade to the same. A little disappointed in the trim of this car to be honest, VERY basic. But hey ho.  Anyone done this? easy? looks easy enough to be fair, but any indications on what part to get / good place to look? When i do an ebay search it mainly comes up with just the bulbs and not the unit its self.   Im also not against the idea of installing the courtesy light in the rear too.... its not a major want, but possibly look into it too. This easy to fit also?   Any help appreciated :)  
  3. My 2013 ford fiesta 1L ecoboost's start stop isnt working, the button to turn it on and off just stays illuminated when pressed, you can turn the light off when the ignition is on but as soon as you start the car the light comes on and you cannot turn the light off, and therefor the start stop isnt working.  any advice  thanks  
  4. Hi, I have a 1.4 Fiesta 2004 Mk 6. About 2-3 moths ago the battery light came on, I took it to the local garage and was advised that it was a problem with an alternator so had that replaced. The battery light was still on when they gave the car back and I was suspicious but the mechanic showed me the alternator charging the battery etc and was satisfied that the car worked well enough, albeit with the battery light on. About a month later, after leaving the car parked for about 10 days the battery was flat, so took it upon myself to invest in a new battery. Problem solved but battery light still on. I have been driving the car a fair bit since then, couple of long distance trips, lots of night driving etc all with the battery light still on but the car seems fine. Have even left the car parked for 3 weeks and it started first time. I do however want to get the light sorted so I can tell when there actually is a problem with the alternator and/or battery and concerned that it may not pass the dreaded MOT with this warning light on. Would be grateful if anyone knows if this is a common problem with a simple solution, my searches on various sites hasn't come up with anything of much use. Your help is much appreciated.  
  5. Location of rear fog light relay?

    When i press the rear fog light button, nothing happens. The bulb is ok, so I'm suspecting a faulty relay, occasionally I hear a short buzzing sound when pushing the button, but not near enough to identify it further. I have browsed through forums, manuals, asked my way around - but haven't been able to find any information or diagrams showing the position of the relay. Can anyone here point me in a direction? S-max 2008 TDCi Thanks in advance Thomas (Denmark)
  6. Hi there, I'm new to this site, has anyone got a answer to my problem. 2008 1.8 tdci s max, when I turn corners with a tight steering lock my Abs/traction control warning light come on and don't go off until I switch the ignition off. There was a bracket under the o/s/f wheel arch fitted the wrong way round and was pulling the abs sensor wire when on full lock, but this has been turned round the correct way and the abs sensors changed in case it caused any damage. The abs and traction control are both working fine, it's just this !Removed! warning light that I have run out of ideas with. Any ideas would be greatly appreciated. Thanks Ken
  7. Hi all, I've got a mk2.5 focus with the standard 1 bulb interior light in, now I was just wondering about changing it to one with map reading lights, I've seen some on eBay and I'm not sure if it's the correct one for my car or not and just wondered if they just plug straight in or will have to rewire, if anyone knows I'd just like a bit of advice 😊 Thanks
  8. 2011 Fiesta Headlight Tint

    hey, Im kinda new to all this and would like to know what size headlight tints everyone has been buying for their fiesta, sorry if a silly questions also what legal LED headlights would anyone recomend. Thanks :)
  9. Ford Fiesta Problem!!! Help

    Hellooo, I have a 1.4 diesel ford fiesta, which is 10 years old now. Recently it's started to cut off randomly, it feels as if the engine goes off for a couple seconds and then starts again. The battery light and the engine light comes on when doing this, but only for a second. It tends to do this when in 5th gear at around 50mph-60mph, which is around 2000rpm. The car has been in a garage all week and no fault comes up! Also, every now and again the 'transmission light'? (i think) comes on, (looks like a cog with a ! in) and goes into limp mode, where is makes it impossible to go over 5mph and very jumpy. Once i switch the car off and on again it goes fine. Has anyone had this problem before? Thanks in advance!
  10. Focus Mk1.5 Footwell Light

    So... I have seen in the forums that many versions of the Mk.1 Facelift Focus has all the wiring for footwell lighting, and I think I have managed to locate on of the harnesses behind the glovebox by the fuses. However, for the life of me I can't find the socket for the driver's side footwell light! I can see the plastic mounting where the bulb socket is meant to fit, but the socket and wiring is nowhere to be found... Is this taped to another wiring loom or piece of the dash/footwell? Also, if the socket behind the glovebox is the correct one, where does this go? Do I have to lift the foam matting in the bottom and place under there? Any help is much appreciated!! Cheers, Al
  11. All, I'm a newbie on the forum and have changed my interior LEDs to blue to match my candy blue Fiesta S. Just looking for a guide to whip out the centre cupholders and change the LEDs to blue. Any suggestions? Or anyone know of a guide to do it? Ta thanks in advance! CJ
  12. I want to check the washer is connected correctly and look at the seal, then disconnect and dry the high level brake level light out as water inside. I noted there are two grommets (mine were missing) but got 2 from a Fiesta. Removing the grommets do I just push through the hole with a screw driver to release each side, and does it clip and push back in easily. Don't want to begin without being sure...you know what happens, it won't go back in and you drive around at xmas with it blowing in the wind!
  13. just taken delivery of a 2010 fiesta 1.6tdci titanium, love the car drives well. just one or two dilemmas. 1, can't find or see a switch for the front foglight/drivers light? theres one for the rear but just can't find it tried all switched but nothing illuminates them, they are fitted just in case someone says. 2, the front heated screen, does it work only with the press of the right button or should climate be on as the screen looks like it not clearing? please help a newbie?
  14. So I was driving towards a junction and the light turned amber and I thought I could make it, but just as I went through, the light turned red and the camera flashed twice!! What I'm unsure of is if I will get a penalty. The camera was on the opposite side of the road facing the front of my car and from what I've read so far, the cameras can't flash the front of your car. Has anyone had a similar experience and not got a penalty or does everyone think I'll get the 3 points and a fine?
  15. Hi all I'm new to this forum so hello. I'm a fiesta zetec owner and have just bought my son his first car. It's a fiesta studio 2013 model. The petrol looks very low but no warning light has appeared. I know on mine it comes on just before I go into red. Please tell me that this model HAS a petrol warning light? I know it's a basic model but.... thanks
  16. Can any one help. I have a 2006 mondeo tdi,130 ps with 210,000 miles on. I start it up and it's in limp mode,5 minutes down the road switch ignition off and on and it's back to full power,been doing this for months now.had the car plugged in and had 2 error codes. P0121 throttle pedal position sensor a. P132b turbo charger/super charger boost control a. I've changed both and still have the same error. Can anyone point me in the right direction. Thanks dave
  17. Hi all, I have recently purchased some upgrade l.e.d tail light units from ford. Took 4 weeks to arrive as ford didn't have them in stock, this is very true as the manufacture date on the units is dated 8 days after my placement of order last month. Guide now available in PDF Format see link: http://www.fordownersclub.com/forums/topic/62561-guide-fitting-ford-rs-led-rear-light-units-focus-mk25-pdf/ Tools Required: 1 x Philips head screwdriver 1 x socket driver 1 x Torx T25 Screw driver bit so in the big box we find two smaller box's with ford fitting instructions, These units are very light weight at only 2.4kg including packaging. Ford instructions are not very helpfull as you can see below lol So let's see what's inside the inner box's To my surprise they are supplied with bulbs, But I don't like the fried egg effect of the indicator bulbs so I'm immediately fitting some silvatec BA++ offset bulbs. Before: After: Much better :) As above images only opposite side, If purchasing these from a breakers or ebay; you can strike lucky and pick up a bargin as some sellers are not aware of the l.e.d units value. Such as this seller: http://www.ebay.co.uk/itm/Ford-Focus-ST-3-59-reg-3-door-O-S-rear-light-drivers-side-rear-offside-gen-ford-/221224879856? pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item338207c6f0 Notice the difference in the lens; the ford l.e.d unit has straight lines etched on the lens. The standard dual filament bulb units have a diamond etched lens.
  18. Brake Fluid Reservoir Sensor

    Hi All, Had started getting an infrequent brake fluid warning light when going up hill or accelerating hard - which was getting more frequent. Had checked fluid level and it was in between min and max so though I'd have to shell out for a new reservoir, as the sensor was integrated into it (rather than just in the cap as per MK1 Focus) As a quick fix try though I'd top up the fluid to the max (which has actually sorted the problem) as whilst it had been checked for water-content and properties over the past 3 years hadn't actually been replaced. However, actually adding fluid on the MK2 focus seemed a pain as the reservoir was under the front windscreen cover. So I cut a small bottle in half and used this to funnel the fluid into the reservoir. Hope this is useful for anyone else who may have the same need. James.
  19. Hi All, Just bought myself a 56 plate Fiesta Zetec 1.25 petrol. Picked it up today and found that the red snowflake light is constantly on and the outside temperature is showing up as -36 degrees. I know that the dealer I bought it from steam cleaned the engine before I purchased it so I'm guessing this is whats caused the light to come on. Can anyone advise on the best course of action to take to rectify this and how much it may cost? Thanks!! Al
  20. Hi all, I'm new to this I was wondering if I was going mad after replacing the ford cd 6000 stereo in my 2002 focus 1.8tdci only to have the airbag light come on??? Is there any way for this to happen as I wouldn't have thought the airbag would have anything to do with the car stereo loom, Is it a case of buying a new module and just fitting it, had it on a diagnostic scanner and the guy said that the problem was airbag module not turned on???? Btw I cannot find how to search forum topics so I'm not sure if this has been posted before, Any guidance would be greatly appreciated, thanks
  21. Cracked Fog Light Glass

    Hi, I am hoping someone on here can help me as you will have more knowledge of this than me. I have noticed tonight that my ST has a cracked glass on the fog light. Clearly this has been hit by a stone, however just having a quick look at the car tonight and I can't work out how you get to the fog light? It seems that the bumper has no access from the front as feels like it is solid all the way under that area of the car. Also does anyone have any idea how much a new fog light costs? Do I have to buy the whole light fitting or can you just buy replacement glass? Any help would be great. Here is a link to an image; http://www.dropbox.com/s/8xz9traqrdfd11f/2015-10-19%2016.15.10.jpg?dl=0
  22. I have the solid yellow engine light on the past two weeks. I had it checked with a scanner and the two issues that recur after the system is reset (it hadn't been scanned in a long time) are: 1. P1709: PNP Neutral Position Switch Out of Test Range 2. P0420: Catalyst System Efficiency Below Threshold (Bank 1) I am quite technical/money poor right now so I'd like to learn to fix these myself. From what I've been told the cat is impossible to test (you can't open it, just replace it. Also, I have the feeling its not this as it passed its NCT/MOT 2 months ago and the emissions were fine - wouldn't they have caused trouble? As for #2 - I have absolutely no idea what that is? What is my best path to take if I want to investigate these errors myself?
  23. Hi Guys, I have the clear rear lense type with LED rear lights (Part of the assembly) I'm looking for the bulb code for rear brake lights on this unit. The actual bulb has to be red as the case is clear. Tried Halfords but they directed me to the wrong one (Returned easy though). Any ideas?
  24. Fuel Light Weirdness?

    Hi guys hope your all well im truly sorry for bugging you all i know this has probably been covered so many times (and im not shy round Google, can normally find my answers) but im stuck as i have no idea how to google what help i need. I have a 2000 plate 2.0 focus ghia, it has a trip computer which i use to a point, since ive owned the car some of the instrument lights haven't worked but didnt think much of it just assumed blown bulbs (traction control light which i know the bulb has blown got to change that and i thought fuel light as they have never illuminated) However tonight i saw a video about the hidden menu, so i checked it out, and it turns out my low fuel light bulb works. But this is where i need some advice because it doesnt work when the car is low on fuel? ive only had it a couple of times where ive let the trip drop to 0 and the gauge is nearly bent round the needle, has anyone had this or could anyone guide on what this could be. I though that if the trip hit 50 miles left the fuel light would come on and it would beep, but i get nothing (obviously i havent trusted the fuel trip so i end up putting tons of fuel in when its not necessary) I just wanted to see if anyone could point to where i should look for this? im lost :) Thanks guys and again sorry if this has been covered before Nate
  25. Mk7 Map Light Trouble

    Hello everyone, I'm hoping for a little help regarding my interior map light. When I bought the car there was no problem, when the door was opened or the car turned on the auto light came on perfectly. However, I then changed the bulb to a same fitment, different colour bulb. That's where the problem began: When it's 'off' - on the left side - it's off. When it's on 'auto' - in the middle - it's constantly on. When it's 'on' - on the right side - it's off. I now have no light when it's needed and when I leave the light on (middle/constant) and lock the car it stays on permanently. I honestly have no idea what to do so any help or advice would be gladly appreciated! Thanks, David