AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Fuel+Rail'.

Found 129 results

  1. Hi in need of help my Ford Fiesta year 2001 1.6 was running fine then left standing for 2 weeks battery went flat so replaced new now the fuel pump / ecu fuse blows as soon as it starts up for 1 second replaced fuse starts then blows is this just bad luck or is something else gone wrong desparate need help Bioman
  2. Hi Everyone, I am planning on changing the Fuel Filter on the above car over the weekend and I have the good old Haynes Manual to follow, however I was just wondering if anyone knew of any good posts of this nature on the forum already or of any useful guides - a quick search didn't return anything? Any useful advice or things to watch out for etc also wouldn't go amiss! Also can anyone recommend a good Diesel Primer Pump - there are quite a few on Amazon, but most of them have less than brilliant reviews. Many thanks in advance! Glen
  3. New fuel filter -now won't start

    I changed the fuel filter on my 09 focus titanium and now it won't start.  I topped up the filter with diesel, and after letting it soak, topped it up once more. ive tried priming it with the ignition the fuel lines are not swapped over my mistake The filter and o ring is secure and tight all nozzles are clicked in with their o rings in place. does the system need bleeding manually? Is there a nipple? There's no fuel cut off switch either and when I discount the the fuel lines and test it no fuel comes out. im out of ideas!!! please any help would be extremely valued many thanks Al      
  4. Hi, I am new to this site but after some advice. My 2013 Fiesta 1.0 ecotechnic recently started smelling strongly of petrol. I took it to the garage and they replaced a leaky fuel pipe under warranty. Ever since then (about 3 weeks) my car has a rattle - its not that loud but you can hear it even with radio on and its one of those annoying rattles, like a bottle or your sunglasses or something in a door pocket, but its not as I emptied my car of everything! Generally its louder when the engine is cold and dies away a bit once its warm. I've taken it back to the garage and they can hear the rattle too, they referred it back via warranty and apparently the new part is slightly different (and that's just the way it is now) and so therefore this noise is normal?! I cant say I understand this, especially as the hire car they gave me was almost identical (same engine etc but being one or two years newer) and doesn't make this noise. Any ideas on the real cause and what I should do next? I don't want to be left with a car with an annoying rattle and am concerned that if I ever decided to sell that no buyer will believe me that the rattle is normal! Thanks in advance!
  5. '57 plate 1.6 petrol Mondeo Mk 4 (owned fro new, no other problems, serviced, low mileage for year) refuelled 69 litres from nearly empty which then refused to start at the Sainsubury's petrol station. Just lurched 1 metre forward and apart from 2 hiccups, nothing. Towed it home and have discovered (by taking fuel line off in engine) that there is no fuel pressure. Engine turns but will not fire. Squirted brake cleaner into air cleaner and whilst squirting it would fire, suggesting electrics and engine ok. Central fuse box F22 20amp fuse on main board ok although it looked as if it had been hot as the edges of the legs were blackened. Green flag attended and their generic OBD scanner apparently showed no fault codes. So some help please.... 1/ Is there an inertia cut out on this model and, if so, where is it? 2/ What other devices can stop the pump from operating and how can I check them? 3/ Is there a complete system diagram anywhere such that I can evaluate the items that may be stopping the pump from running and how the power routes to the pump? 4/ Is the pump only accessible after lowering the tank? 5/ What is the layout on the pump and what can I check? Answers and any other advice very much appreciated.
  6. Hi all, First post, apologise in advance. I've a 2012 Mk7 Fiesta, Zetec, and I noticed a few weeks ago that when I filled up the car (full tank), the estimated mileage on the car had changed. It had gone from the usual 315+ miles (when I purchased back in July), which lasted for a few months, to around 275+ miles on the clock. Is there anything in particular, other than driving manner, that could cause this? As I've only had the car a few months and 40 mile drop is a bit weird.
  7. Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards
  8. Recently whilst going to work in the morning the car sudddenly stuttered and "Engine Malfunction" light came on. I stopped and swithced car off and started car again, no problems whatsoever, however just to be on the safe side rang AA to come and have a look. The chap did an OBD reading and fault code P2290 came on however the car was driving fine. It's been all ok for the past week however last night on my way home, the car had the same problem, however this time, I was overtaking a lorry and it felt as if the car lacked power at 70mph after stopping and starting the engine. This morning everything was fine again. I contacted a garage who told me that it could be the fuel sensor regulator switch made by bosch or it could be EGR, TURBO, FUEL PUMP and to drop the car off to have a look. It seems that when I go above 3000 rpm on the motorway this problem seems to pop up. I nearly got killed last night!!!!! Anyone had anything similar problems? 1.6TDCI 110HP 59 Plate (service at ford garage according to service schedules, all maintenance done etc) Thanks
  9. I'm looking into the following error code on my 1.8 TDCi: P0191-61 - FRP Sensor Range/Performance The code appeared after I changed the glow plugs, which I did as a response to an earlier error (which is now cleared): P0380-68 - Glowplug control circuit I've taken a reading of the Fuel Rail Pressure using FORScan with the car running. I'm getting readings of about 5000 psi (340 bar). I don't have my Haynes manual with me, and Google isn't helping much. What are the expected ranges for pressure at the rail? (These values seem a bit high to me, but then this is the first time I've had to play around with fuel lines.)
  10. hiya there im new to this site. i have a ford focus 1.6 estate, it has not been started in 4 months, i hve tried to start it today and will not start i have sparks but no fuel evening going to the fuel filter. i have already checked the fuel cut of switch but still nothing any one have any ideas it will be much apprecated
  11. Hi, so I have a mk3 Mondeo 53 plate 2.0 TDCI Ghia, and I have been getting the warning light come on with the engine cutting out if I try overtake/ go shove 3k revs. I have taken it to an auto-electrician and to a garage and both have run tests, and the garage said it was pointing towards the sensor, and the auto electrician said it could be the fuel pump. Now that's cost me £150 for a non definitive answer and its !Removed! me right off. Anybody know what the answe could actually be? It drives fine unless I try boot it, has to work overtime going up hills. I don't know if it would be worth the money sorting it out or not. I have had the fuel filter changed and that hasn't hanged anything but the garages old diagnostics machine pointed to the injector, but his recent one that's better lead to the sensor. Anybody else had the same problems or know what it could be!? Thanks The warning light is the far left one and it flashes and if I try accelerate whilst it's flashing, the engine cuts out and all power goes and power steering and then the engine management light will come on
  12. Fuel Light Weirdness?

    Hi guys hope your all well im truly sorry for bugging you all i know this has probably been covered so many times (and im not shy round Google, can normally find my answers) but im stuck as i have no idea how to google what help i need. I have a 2000 plate 2.0 focus ghia, it has a trip computer which i use to a point, since ive owned the car some of the instrument lights haven't worked but didnt think much of it just assumed blown bulbs (traction control light which i know the bulb has blown got to change that and i thought fuel light as they have never illuminated) However tonight i saw a video about the hidden menu, so i checked it out, and it turns out my low fuel light bulb works. But this is where i need some advice because it doesnt work when the car is low on fuel? ive only had it a couple of times where ive let the trip drop to 0 and the gauge is nearly bent round the needle, has anyone had this or could anyone guide on what this could be. I though that if the trip hit 50 miles left the fuel light would come on and it would beep, but i get nothing (obviously i havent trusted the fuel trip so i end up putting tons of fuel in when its not necessary) I just wanted to see if anyone could point to where i should look for this? im lost :) Thanks guys and again sorry if this has been covered before Nate
  13. Hi everyone, I have recently purchased a 2011 Mondeo Titanium X Sport Estate - and my goodness what a car it has turned out to be, very proud owner. My pride and joy has the chrome Roof Rails fitted, however I have just seen exactly the same car without the Roof Rails and it did look better I must admit. I wondered if it was possible to remove them, and if so can it be done without any damage or detriment to the car body? Any advise and thoughts appreciated. Ryan
  14. Just wondering where abouts is the oil filter on my 2008 1.8 TDCI and what's the best way to get at it? Also if I am changing the fuel filter, is there anything I need to do (i.e bleeding the line) or can I just swap filters out?
  15. Hi im new here but just joined because i need advice please. I've recently had the DPF static regenerated but at the same time the reading for the fuel delivery pressure was low so I bought a fuel filter £42 and fitted it myself ... All straight forward. .. i started the car fine and it it ran for 20 seconds i assume on what diesel there was in the rail but then stopped! It won't start again.i took the pipes off the filter and cranked the engine and there's no diesel coming out? Im at a total loss. Any suggestions would be much appreciated thank you.
  16. OK so basically I had a 2.0 TDCi Zetec S a few years back on an 04 plate that had diesel pooling around the injectors. It turned out to be the Leak off pipes/ connectors, we changed the lot to be sure. However when we changed it the car would not start at all! It took about a week of disconnecting and really connecting rando stuff to.get it finally started in limp mode. After that it was fine and the error we were getting of low pressure in the fuel rail went. Now I've just bought a mondeo 2.0 TDCi Zetec again with the same issue if diesel pooling around the injectors. My concern is ill.change the pipes and connectors and my car won't start again! Can anyone she'd some light on why that would happen? Thanks in advance :)
  17. Hi new to this, So i have a build)project on the go. Cut along story short my injectors are not putting fuel in the cylinders. Car is sparking i have fuel pressure as i have run a direct live to fuel pump but its itst starting and plugs are drier than a smackheads pocket.. Thanks in advance.
  18. Hi all, I have a problem that as baffled all mechanics that has came into contact with it. The fault When I am driving down the road everything will be fine, Then randomly without any warning the car will simply not allow me to accelerate and roll to a stop, when the car does eventually come to a stop (complete stop the car doesn't even idle) I get the normal warning lights like the oil pressure/battery but I also get a audible sound accompanied by the left red lamp being illuminated. the amber power steering lamp also comes on and the message reads steering assist failure. most of the time the car will restart fine but sometimes it can take up to 5 times to restart the engine. all warnings are cleared when the car restarts. The fault started off once every few months but now it is guaranteed to happen every few miles and the car is now unsafe to drive. Replacements I have had the fuel injectors changed because they were leaking and the fuel filter replaced. But the problem just seems to be getting worse and more frequent. is there some sort of safety feature that shuts off the fuel supply to the engine? Pic and Video The picture shows all of the fail lights after the car has come to a stop. the video show the car just after the car has physically stop me from accelerating the car does come to a stop quicker because I applied the brakes. it feels like fuel is no longer being fed to the engine but why? Any help would be massively appreciated cheers Alex car video.MOV
  19. Changing Zetec S 05 Fuel Tank

    Hi, The tank has split on my 05 plate zetec s I have purchased a new one for £35 being delivered tomorrow. How much of a job is it to change over? Does the exhaust also have to come off? Thanks
  20. Ok so I have had my Fiesta Zetec S since the 20th of March. Today on my way to work I broke down , after being towed to the dealership , I was told about a problem that they are having with the fuel pump. My car is the sixth one in the area to suffer from this problem. Has anyone else had or heard about this problem that has left me with a slow, shed on wheels of a courtesy car? I'm feeling very upset as I was also told that it may not be able to be fixed until the end of the month.
  21. Petrol Leak! Ughhh

    Hi guys, Took the car out for a 150 mile motorway run yesterday and on return the car had to fuel up, so I turned the engine off, fan whirring away and then I heard a funny spitting/weird sound . Then it stopped doing that after like 2 mins. Engine temp everything was fine, coolant was fine. Anyway. filled up Decided to take the car out today and it smelt a little like petrol, just thought I had perhaps got some on the body work when filling up yesterday (given its a hot sunny day today) anyway, took it out and when I returned the smell was there. Noticed on the drive a patch of petrol probs the size of a dinner plate. Now question is, how expensive is it to replace the replace the fuel tank (if at fault)? Note, I did have a look underneath, it looks like the previous owner put a new fuel pump in, but the tank does look slightly rusty. I haven't found any visible petrol leak sources. If it is a fuel line, can it be fixed? Or does it need replacing? Have I effectively written this motor off? how expensive is it to replace those parts? :(
  22. Petrol Leak! Ughhh!

    Hi guys, I took the car out for another 150 mile motorway trip, on return I popped into local Shell to fill up. Turning the engine off, I heard some weird noises, like spitting etc I noticed the temp gauge was normal. Anyway, that lasted for like 30 secs, I immediately put up the bonnet up but nothing was obvious, no steam etc. Anyway, I proceeded to fill up and went home to nap. Today, I got into the car and put the windows down because it was hot and I could smell petrol. I drove for about 5 mins and came back to notice there was a patch of petrol probably the size of a dinner plate on the drive way. I don't think a lot leaked out because the gauge was still above full. Anyway, got under the car to have a rudimental check, noticed the previous owner put a new fuel pump in so it cant be that. Umm..there isn't any obvious fuel leak source I can find. But the tank itself does look quite pitted and rusty on one side. Question is: Have I written this motor off? how expensive is it to replace the tank (assuming that's at fault) and if its fuel lines, can it be fixed near the region? OR does the whole lot need to be replaced? How expensive is all this? I hope its a cheap hose or something. Thanks
  23. Hi, Looking for some help. I have inherited my late fathers Ford Fiesta 1.25 zebec 1998 s Reg (Mk4 I think). It has been stood for about 2 yeas however I have decided to give it the attention it deserves. It has 42k on the clock and is in mint condition. I had a non start issue however found it to be a blown 10 amp fuel pump fuse located under the bonnet. I replaced it and it started first turn of the key. I drove it home from where it was being stored and it didn't run well, a bit chugging. I removed the battery and charged it. Again non start and a blown fuse. I located a grommet under the rear seat and gave the top of the fuel pump a gentle tap and it started up. I left it running to get it warmed up properly as it felt damp inside. I stopped after about 1 hour of idle and it refused to start again literally straight again. I left it for a couple of days and retried it, it started with a little persuasion, however it doesn't idle brilliant, more so when the A/C compressor kicks in. I left it running for ages today and it now won't re start. has anyone had issues with fuel pumps failing. I am thinking it may just be a pressure issue. thanks in advance. Paul
  24. Problems With Kuga 1.6 Titanium Awd A/t

    I have been very patient, but enough is enough!! I have left a message for the owner of Hoffeldt Auto in Bronkhorstspruit, Mr. Robert Hoffeld, at 08:11 this morning. If I don’t hear back from him, or Ford South Africa (Ford UK) with a satisfactory and adequate replacement transaction (and NOT the insult of an offer sent to me by Lou Erasmus on Friday (6March) afternoon) by 17:00 this afternoon the following will happen. This is what I will be putting on EVERY website, blog, forum, Hellopeter, etc., I can find that will accept the post. I have already registered on numerous blogs and forums, both in SA and Internationally. I will also be placing several advertisements, both local and national, to very strongly get my point across!: “I bought a Ford Kuga 1.6 AWD Titanium A/T for my wife in May 2014. From the very first week I called the Dealer Principle, Lou Erasmus, to complain about the cars fuel consumption. Now, almost a year later, and with the utmost patience from my side, I am fed up! Finished! How is it possible that a 1.6 litre vehicle, with today’s technology, gives you an average of 15,63 l/100km over the last 12 full tanks of petrol? I tested it myself every time. The last tank = 16.76 l/100km. This is when they publish, on the Ford website, and advertise in the vehicle's brochure, a fuel consumption of 7,7 l/100km???? There is no way that I am accepting this!! One of the main reasons for buying the car in the first place was because if it's fuel consumption. Car has been tested by Hoffeldt Auto, Lazarus Ford and Ford SA with an official letter from Ford SA that there is nothing wrong with the car? NOTHING WRONG WITH 15,63 L/100KM????? You have to be joking! Stay away from FORD and stay away from Hoffeldt Auto!!” I have also asked, since beginning of January 2015, for the report from the Ford Engineers, on the testing done on the car in December 2015. I have yet to receive anything. What are you hiding??
  25. Mk4 Mondeo Petrol Fuel Pump

    Does anyone know where I can get a replacement fuel pump for a 2010 ford Mondeo 2.0ltr petrol model??????? Cant find one anywhere and my current one has blown up. Happy to do repairs myself just cant find any to replace it with!!!! Used or new. Desperate Mondeo owner struggling. Thanks Steve