AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Hood+Lid'.

Found 5 results

  1. Hi all My 2009 Zetec focus is running smooth apart from a slight issue with the bonnet. It doesn't seem to sit completely shut, instead it it raised a few inches from the car when closed. The car isn't springing any warning signs regarding it not being fully shut which is promising. What could I do about this? I'm concerned about it becoming a possible safety hazard as well as rain escaping below the bonnet hood. What is causing this and how can I overcome it? Thank you!
  2. Good afternoon all, I'm in need of some advice. the lock mechanism for the release hood has stopped working. (The right turn no longer opens the hood). Is there anything I can do to save taking it to the garage for a big bill? Thank you
  3. Hi There!

    Hi all, I am currently driving in a 1.3 Fiesta Finesse which I have had for just over a year and I'm just looking for some advice on things to do to my fiesta to make look a bit cooler and general up keeping of my wee ford. Thanks for reading!
  4. Hi, I live near Worthing West Sussex and was wondering if anyone knows where I can get a new back window/screen for my Streetka. I folded the hood and the screen has split in two places and is damaged beyond repair. Ford charge an arm and a leg so will probably have to fork out in the end but was just wondering if anyone knows anywhere that I could get one cheaper. I have been quoted £100.00 to fit it when I get it. Here's hoping :)
  5. Can anyone out there help please, I cannot open roof storage lid on my daughters KA Convertible, normally I would press the button on the driver’s side door frame and that would open the lid to store the roof, but now when I press that button it does not open. I can open the lid manually from inside the boot, so mechanically everything works, but if you store the roof it blocks access to the mechanism, so you can't open the lid to get the roof back up. I think it’s either the switch itself or the switch mounted under the lid which moves the locking mechanism (see attachment). Anyone else had the same issue or knows how to fix the problem?