AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Mondeo+Titanium+140'.

Found 354 results

  1. Hi guys, can someone throw me a bone here. Following a rather harrowing accident an object hit the front of my bonnet, the catch popped and the wind threw the bonnet back over and into the windscreen. Now the car's been a great runner, but it's worth less than a grand so the £400 excess to have it repaired wasn't economically viable. I've managed to get a replacement bonnet, new hinges and new support rams - all fitted without problems, but the latch mechanism is damaged and unserviceable. However the lock mechanism still works perfectly, so I've bought a new latch, my question is, how do you get the old latch mechanism out? Is it possible to undo the two retaining bolts and either lift out or drop out the old one without having to start butchering the lock? If anyone has changed out this unit and can give me some pointers that would be great. All the searches I've done turn up loads of things about bonnets stuck closed or unable to latch correctly but very little about actually replacing the latch, not the lock.
  2. What should I look out for?

    Hi all Just about to finally pick up my first Ford on Monday, it's a 12-plated Focus Titanium 1.6 diesel. Ideal for me and my small family. As I'm new here I'm just wondering if there's any tips, ideas, advice, or anything worth knowing about the car - Quite a vague question I know, but anything you guys can tell me would be of benefit and greatly appreciated.   Thanks in advance Jody
  3. Hello!

    Hey guys First-time Ford owner here (as of this Monday) from deep in the South Wales valleys! Picking up a 12-plate Focus Titanium 1.6 diesel (115), ideal for my family and looking forward to it being part of some great memories for us just as my 06-plate Clio (don't laugh!) has been! I've had a quick browse through the forums and some of the things you guys do to your cars, your knowledge, your experiences, I'll enjoy reading them, interesting to say the least!! Hopefully I'll chat with a few of you over time!
  4. Ok hi fellow ford owners! so just paid 3000 for a 2004 ford mondeo st220 3litre v6 and am having some issues that need adressing and are quite worrying!! Ok so its only done 85k miles all service history but problems am having are  1. When i turn right i get a loud high pitched squeel. 2. Its quite a moany engine and a little loud when it does in low revs 3. After warm when i stop can hear a very faint knocking noise from engine only happens when still  but works fine hoping its nothing major but any help would be appreciated thanks!! 
  5. Newbie From Dorset !!

    Hi All New member, Just purchased Mondeo 2012 ZBE
  6. Hey, I've got a (new to me) '62 plate focus estate titanium X, 1.6TDCI (115) stop-start engine with keyless entry and keyless start button. it has around 120k on the clock. Timing belt/chain has just been done. I've had it arpund 2 weeks. I have a problem where the car will not start using the button (have not tried the emergency key yet) it takes many attempts for the car to start. A faint, but dull click can be heard after pressing the button - sounds a bit like  the starter motor solanoid -but don't read too deep into that. it cut out at the weekend when I was on holiday - it was either stop-start kicking in, or me fumbling about and made it cut-out, or it just cut-out its self - I'm not sure. either way it wouldn't start, all signs pointed towards having a flat battery, that's what it felt like. THe AA came out and couldn't start it either, eventually it just started by fluke.140miles later after getting going again it did the same thing when I turned the car off to pick the dog up, got in the car and it would not start until about 8 tries of pressing the button, each time there was a faint, dull clicking noise from the engine bay. there's no warnings that I can see, but I did see *something* about hill-start assist on the display as I got into the car for the first time on the day it first broke down. here's a video (car was warm - I'd just stpped it to nip into doctors) https://www.dropbox.com/s/n9yszdu8wig847e/20160201_105618.mp4?dl=0     The AA ran diagnostics but their system didn't read the ford codes and he said there were 5 electrical faults in the memory but he could not tell me what the errors meant. (p.s I'm not talking about the ~4 sec delay between pressing the button and waiting for the coils to warm up where the engine fires its self after the short pause. This happens with a warm car too)
  7. Hi all, First post! I've just bought myself a 58 plate Titanium, I'm massively pleased with it, I made sure it had some of the gadgets I wanted such as cruise control, parking sensors etc. knowing that I could have a go at retrofitting the bluetooth myself (and for an added bonus get USB support! - fingers crossed). I know this is a heavily discussed subject, but please bear with me, I have done my research. So, I have the Sony single CD (no DAB) with MP3 support, and I've checked the firmware (press and hold 1 & 6 together then turn on stereo) and it's 05-03-03 so I think I'm also good for USB support. I've also got the correct light housing for the microphone and it looks like I have a wire stowed up there to clip the microphone into. I've taken the glovebox out and I'm pretty positive I don't have the wiring loom for the bluetooth/VC module so this is the only sticking point so far. I'm just about ready to email Ford Parts UK to get a quote and place an order and could do with a few pointers before I go ahead. Any help is hugely appreciated. I have the microphone wire, where does this come out? I had a 3 pin black and red socket taped to the existing AUX input cable, it had white/black, yellow/black, and black cables attached. Is this it? Once I've confirmed, how am I going to attach this up to the new wiring loom? I found an excellent guide to fitting USB in the glovebox with an original bezel to hold the USB here http://www.fordxr5tu...p?topic=12187.0 It says the the Nokia bluetooth module has been replaced with a Novero (1726157 Module (AU7T-19C112-AR) is this OK for my stereo and will it give me full USB/ Voice control support? Once I've got it all installed what do I need to ask Ford to program with the WDS, I've seen various things posted, but I get the feeling I'd turn up and they wouldn't know what I was on about? Can anyone tell me exactly what to ask for? I've gathered part numbers from all over the place, it looks like they get replaced with never versions, can anyone confirm the below? Bluetooth: 1726157 Module (AU7T-19C112-AR, 2010 Module Bluetooth BT/VC+USB Connect) 1353218 Module Bracket 1355147 Screw For Bracket x 2 1318965 Steering Control Stalk 1532666 Bluetooth Mic 1467152 Retrofit patch loom for universal fit. (there seems to be different versions of this for focus/fiesta??) USB: 1543691 USB cable 1543450 USB socket 1550778 Glovebox bezel Finally if anyone can recommend anywhere to get hold of some of the parts other than Ford Parts UK that would be appreciated, I've not had much luck sourcing stuff on ebay.
  8. Hi all I'm new to this forum sorry if this has already bin covered.  I've recently become the owner of focus 2013 2.0 diesel titanium x and really like the motor. But I'm wanting to change my cornering light bulbs and main beam to match up with the 'cool white' look from the drls and xenon headlights  Am I right in thinking cornering bulbs are H1 and main beam is H7.  I'll be changing indicator bulbs to silvervision too
  9. Hi All, I thought I would try and make this more open to the public as Ford seem to be doing everything they can to not tell customers about this issue. I own a 58 plate (Registered 09) Ford Focus 1.8 TDCI Duratorq, since the car was new it has suffered from 2 issues. Issue 1 - While driving on the motorway the car will have intermittent hesitations when accelerating. This will usually happen then naturally allowing the car to decrease speed by taking your foot off the accelerator then applying it again. This can also happen when just cruising in 5th. Issue 2 - This cannot be replicated however randomly you can get a violent jolt forward with the error displayed on the dash "Engine Malfunction". The car will go into limp mode then when you pull over turn the ignition off, wait a minute and start again will be cleared and free to drive normally again. My car has been into Ford for this issue during its warranty period and after it expired to be told there were error codes relating to a particular injector however they were telling me all 4 needed replacing at £1500. The issue was so intermittent and could go months without it happening I have not yet had them replaced. I cover 350 miles a week commuting and can got weeks/months with no occurrences of this. Ford have never told me about a known issue with the injectors until recently when I took my car to the Ford dealership in Eastleigh, Hampshire. One of their service department told me they were aware of a known issue with a batch of injectors ending in the part number 3. While my car was in for diagnostics they advised all 4 of my injectors ended in 3 and would need replacing at guess what... you got it £1500. I argued that surely if this was a known issue with a bad batch Ford should replace these. They said not and the car is out of warranty so I will have to foot the bill. I asked whether there was any documentation on this however they said no, even their customer services director categorically told me nothing existed after checking with their service desk. I have since found out online and from help from the guys on this forum and other that there is in fact a TSB (technical service bulletin) released by Ford documenting which cars are affected and saying what I had been told about the injectors ending in 3. The TSB is TSB 27/2012 dated 14/05/12 and affects 1.8L Duratorq-TDCi (Lynx) engines between 2008/2009. It affects the Focus, Mondeo, C-Max, Transit connect and Tourneo. The title of the bulletin is "Excessive combustion noise and or hesitation during light load acceleration with the engine at high operating temperature". I don’t believe I can post the bulletin in full due to copyright however I can pm this to anyone interested. The bulletin states that there are PCM calibrations released to try and help the injector nozzle performance however Ford failed to tell me about the TSB or the PCM calibrations once in all the times my car was in for diagnostics. I have raised a complaint with Ford regarding this however they are unwilling to replace the parts at their cost, I have told them I am willing to pay for the labour however I don’t feel I should foot the bill for the parts given they were fitted from brand new faulty. I have so far got them to discount the price from £1500 to £1100 then recently a further 30% off this price. Still not happy as still leaves me with a £6-£700 bill to replace faulty parts they fitted. I would advised contacting Mark Ovende via this email address - movende1@ford.com He is the MD at Ford Motor Company. Mark will not respond however you will get a call back from the Ford Head Office. I was initially told they wouldn’t do anything however after continuous emails and phone called I have got them to discount the total initial quote by around 50%. It appears Ford are doing whatever they can to not tell customers about this issue so they have to pay out a fortune to replace parts that were not fit for purpose. Ford should issue a recall as this affects a lot of cars and is potentially dangerous. The fact they are not even telling customers there is a PCM update which could help is shocking, the go straight for the replacements instead. A free or £95 PCM update or £1500 to replace all 4 injectors....... disgusting. I want to try let as many people know about this as I can so they dont get lied to and forced into spending thousands when a PCM update might fix it. Ford should replace these parts at their cost not the customers regardless of warranty on the car. This whole situation has put me off buying another Ford especially from the dealerships I have dealt with. Regards Allister
  10. Warning Light

    Hi, my s max when locked the hand brake warning light stays on and a red flashing light has appeared in the center of the top row of warning lights. the hand book doesn't show this warning light. also I now have a 'Low battery' warning when turning vehicle on. Has anyone any ideas?
  11. Hello all! I'm having an issue with a 2002 Mondeo Ghia X, bought it at the beginning of last year but has created a problem of not always starting, it will always start first time but then if you stop, turn it off and come back within 5 minutes it just doesn't want to start. All of the dashboard lights and other stuff works fine it just doesn't want to tick over from time to time, it's very odd. I think it also has a Clifford alarm fitted, and I'm not sure if that is doing anything to cause the issue. It can be a real bother at times, if you stall at the lights sometimes it has not started at all, so it can be dangerous. It had the starter motor done a few months back so it isn't that.. Any ideas of what this could be? Cheers!
  12. Hello I have a Mondeo which is making a whining/whirring sound, not just under acceleration (ie makes the same sound when foot taken off the accelerator), and is more pronounced at low speeds (10-35mph especially) - the sound resembles the noise some cars make when reversing at more than walking pace. It seems to be more a bit noticeable after 15 minutes into a journey. Any thoughts? Thanks.
  13. New Member

    hi there all . My name is P.J. and I have just joined the club . I am the proud owner of a Ford Focus Titanium Mk2.5 , it is a 1.8 tdci and it is an 09 model . I have been a ford fanatic now for many years , owning many fords from the mk1,s and 2,s to serria,s and for the last 2 and a half years my Titanium . I have been watching this forum now for a while and have learnt a lot from it so far , I have enjoyed my Focus as a standerd model with all of it,s extras since I bought it and I now wand to do a few mod,s to it . I want to start with the basic and easy ones first them move onto putting a kit onto it , I have already done a few easy ones like rear parking sencers , wind deflectors on the front door windows and DRL,s but now want more . I have now gotten the bug from reading here about things to do . I would love to hear from other members about things to do to my baby .
  14. Hi guys, I'm thinking of getting a new daily and I shortlisted my model range to either a Focus or a Fiesta. Since it is going to be a daily car I want it to be a diesel. The diesel engines I'm opting for are either the 1.4 tdci (DLD 414) or 1.6 tdci (DLD 416) for the Fiesta or the 1.6 tdci (DLD 416) for the Focus. Now I know that these engines are not all done by Ford but in some websites I read that Ford use Peugeot (HDi) engines and in others I read that these engines where produced together with Peugeot. So what I am asking is, is it true that these engines are only done by Peugeot and Ford source the engines? or it is a new engine that Ford designed researched and produced together with Peugeot? Please any sources in your answers are very appreciated since I want to see whether Ford are sourcing PSA engines or developing them with PSA. Thank You :)
  15. Blown Turbo

    At the end of a 200+ mile journey last night and 3 miles from home in our Mondeo Mk3 (2003) I suddenly lost power, then one up one hill too many a grating noise coming from the engine (like going over a cattle grid) then all hell as the engine went out of control with increasing revs and smoke coming from the bonnet as we all bailed out in fear that it was about to explode. The revving continued with the ignition turned off but almost at it's peak of revving suddenly stopped. Luck would have it that a local mechanic was passing at that precise moment - he got us home and the car now sits in his garage waiting for inspection. He was able to offer 'blown turbo seals' as an on-the-spot diagnosis and said that 9 times out of 10 that meant a new engine or the end of the car. I'm hoping then, while I await his full and proper diagnosis in the sober light of day, that someone might be able to give some hope to cling to. A fuller explanation of what might have just happened to my car... should we actually be just thankful that my wife, two boys, golden retriever and I are still alive... and if it is as common and unpredictable as the friendly mechanic was suggesting will I be able to drive a turbo powered car ever again?... Frightening, still shaken, everything that was in the car now stinks of burned oil and I have little idea what just happened. Any advice and positivity would be much appreciated at this time.
  16. Hey Guys, Hope someone can help and advice. I am driving a Ford Mondeo Titanium X Sport 61plate (build 2012) and it has the standard Sony Dab stereo installed as picture attached. However I want to change it to the sat Nav version. As attached. Would that be possible? Also can you confirm the latest sat nav from Ford can be installed as well. The new one has the parking buttons at the bottom and my ones at the top. The layout is different too. Please help. Been looking to change for a while.
  17. Hi, just bought an 2010 1.6 Titanium Focus. Got 2 keys only one works 😐 How do i check what's wrong with it? Tyre pressure warning light came on..what should tyre pressure be ? When I close the boot or passenger door I can hear a rattle underneath, any idea's? Thanks in advance DEANO
  18. Evening all! TLDR: My mk3 TDCI is producing an intermittent rattling noise on idling, which disappears when I raise the revs slightly by depressing the throttle. Appears to come from the right-hand side of the car, and seems to be external to the engine. Any theories? The long version: This week I needed (i.e. badly wanted!) a new car to replace my battered 20-year-old Corolla. I ended up with a mk3 Mondeo 2.0 TDCi, 115PS, 2006-plate hatchback in green. Great cosmetic condition, 136,000 miles on the clock, with no service history apart from last MOT (March 15), which it passed with a couple of advisories, one of which is the noise I'm asking about here. Okay, so I took a risk, but the car looks great, is much newer and better-equipped than anything else I could have afforded, and cost me just £450! It has a couple of issues, but I figure it's worth spending a bit of money to keep this one running. My theory is that the first owner was a business driver/high miler, as the car is in great condition and the passenger and rear seats have hardly been used. It then seems to have spent about 8 months in the ownership of a young man from a family of traveller types who own horses and buy and sell vehicles - but who don't seem to have done much maintenance or servicing on this car (evidenced by the fact that it needed a thorough cleaning inside and out after purchase, but scrubbed up great!). I was relieved to learn that the mk3 TDCI has a timing chain rather than cambelts. However, it appears that one might still need to check the condition of the timing chain (£200 bill?), and the replacement of the auxiliary belts is due at 125,000 miles (also £200 bill?). As I mentioned in my summary above, there is this metallic rattling noise when idling. It's not there all the time - usually takes several seconds of sitting at traffic lights for it to begin, and it comes and goes. It can be relieved by raising the revs slightly using the accelerator pedal, and also seems to vanish when the clutch pedal is depressed. With the bonnet up, the noise seems to be coming from the area of the auxiliary belts on the right-hand end of the engine. Everything seems to be working; it's just this noise. The car stops and goes just fine and has plenty of oomph. Worth pointing out: the car pulls to the left noticeably, pretty much all the time. This has not been cured by having the wheels aligned or replacing the tyres worn by the misalignment. The only time it has not done this is on a surface with a right-hand camber. The left-hand pull also occurs if I brake sharply (once the car has shed most of its momentum; it then kind of "digs" to the left just before coming to a complete stop, with the steering wheel twisting to the left). Whilst driving I find myself compensating, and at times if feels as if I'm fighting the steering a little. I don't remember having anything like this or noticing heavy power steering on the brand new TDCi estate I hired for a week whilst living in Germany back in 2002, which I put about 1,500 miles on - I was very impressed by that car, and that's one reason why I bought my current Mondeo. So I'm wondering if the rattling is anything to do with the drive to the power steering pump which in turn might contributing to the steering issue. Clearly the car needs an oil and filter change which I will probably do myself. A friend (trained mechanic) drove behind me yesterday and said he saw the odd puff of smoke - not sure how much oil it's consuming but it's in the middle of the dipstick, albeit quite black. Anyway, I'd be happy to clear up the rattling on this thread and investigate the leftward drift separately. PS To avoid wasting time with comments about the risks I've taken, can we please just assume I've done all the self-beatings and sleepless nights about buying a car with no service history from dodgy people - I've got good reasons for not wanting to put any more time or energy into looking for a car, and would just like to know what I might need to do to get this running as sweetly as possible (or indeed if the issue is one I can ignore safely). Over to you! Thanks in advance for your suggestions!
  19. Hi all, Just joined this forum on behalf of my dad who is having a number of issues which we can not seem to solve, so any help here is much appreciated! Dad owns a 2011 Mondeo Titanium X Sport 2.0 Eco Boost Auto with 14k miles on the clock, owned it for about 2 years now. A couple of months ago the car started to play up where the key fob would unlock the car but the wing mirrors wouldn't open out, the push to start button would not start the car but the instrument display would show the Ford logo. AA man came round, disconnected the battery for about 10 mins then the car was ok and started up. Couple of days later same thing happened so dad did what the AA man did and was ok, but then the car wouldn't turn off! It is an Auto so couldn't stall it. Took it to Fords while running and the guys come out and agreed that it wouldn't stop. Eventually the car did turn off after pressing the on/off start button a few times. Left the car with Fords to investigate and they said that there was nothing wrong with it after doing the Vagcom/diagnostic checks etc. Paid about £300 for this so far. They gave the car back to us and it was ok for a day or so until the same thing happened. Ford then flashed the internal computer and updated all the firmware etc and the car was ok. Today (about 2/3 months later) dad went to start his car and nothing, the key fob wouldn't open the car and even using the internal key in the fob would not open the doors! Ford have said they have never seen this before and don't know what to suggest, so we have a car we are unable to get into. Dad has tried both key fobs and tried every possible thing we can think of. Has anyone on the forum experienced this before or have any ideas as to what it could be!? Any help/suggestions are welcome. Thanks,
  20. hiya im a new member as of today, im sorry if this is in the wrong section but i was wondering if anyone has got a cylinder head for the mondeo ive described in the title for sale? 2 inlet valves are bent on cylinder 2 and the head is warped so i cant find any decent excuse to refurb it. \if anyone has one layng around for sale please lt me know Cheers Bradley P.S. iirc the cylinder heads are the same for both 1.8 and 2.0 zetec lumps
  21. Can any one help. I have a 2006 mondeo tdi,130 ps with 210,000 miles on. I start it up and it's in limp mode,5 minutes down the road switch ignition off and on and it's back to full power,been doing this for months now.had the car plugged in and had 2 error codes. P0121 throttle pedal position sensor a. P132b turbo charger/super charger boost control a. I've changed both and still have the same error. Can anyone point me in the right direction. Thanks dave
  22. Ford focus

  23. Repairing Front Bumper

    I have damaged the the lower part of front bumper by hitting a raised kerb. The visible damage is not much but the underside looks a mess. Are there any pictures available showing the various parts of the complete bumper assembly?
  24. Multi Stack Cd Unit

    Hi, has anyone got any info on fitting different multi stack CD unit. i have a Pioneer multy stack and am hoping to marry it upto the sony head unit. Ricardo48
  25. Hi guys, I have a 2001 Mk3 mondeo estate 1.8 Petrol. The drivers door got smashed and the barrel was destroyed and the car was stuck with all the doors locked. A locksmith charged me £120 to get the door open and make a new standard key, but still only the drivers door would open, the rest of the doors remain locked. I found a cheap door on ebay, so I'm hoping after putting that on, the other doors will unlock when I unlock that. The locksmith said that my remote key is ok and communicating with the car, as you can hear the clicking noise from the dash, when I push the buttons and if I hold down the unlock button, all the windows will open. I'm told the central locking module is in the drivers door, so that is obviously damaged aswell. So after putting the new door on, will i need to have the key re-programmed, or should it just work? Thanks