AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Speedometer+SMax'.

Found 39 results

  1. Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards
  2. Hi I'd be grateful for experienced suggestions please. We have 8-month old twins and a 4 3/4 old. We need to get three child seats across the back (middle), and am keen to hear on a seat mix - 2 x stage 2 and 1 x stage 3 - that works. Seats or particular interest are: Cybex Solution Q2 Britax Kidifix Xp Maxi Cosi Rodifix Jane Montecarlo R1 Does anyone have one of the above as well as 2 x stage 2's? If so which combination allows for the seatbelt in the middle to be done up with, relative, ease? V many thanks Bruce
  3. Hi all, My fiesta is causing me many troubles so please bear with me whilst I pour out the details... 1. Instrument Cluster replacement due to immobiliser fault. 1 week later: immobiliser came on whilst driving so it was returned to Ford but the fault did nit reoccur. 2. First motorway drive - Speedo reading incorrectly; stuck at 50, stuck at 70, dropped to 30 when stationary then moved to 70 and stayed there. When driving the needle climbs at a reasonable speed. 3. Post motorway drive - Loud whirring/screeching sound from engine - sounded like a belt movement. No change when revving - okay once cooled and driven again for a shirt distance. 4. Didn't drive car for 2 weeks (involved in accident) - drive 10 miles to Ford and cab hear screeching noise again. Revved (gas pedal to floor) and upon calming there was a 'clunky' noise and then the normal engine/screeching belt sound remained. Any ideas? Am I unlucky or is it linked? (Asking for advice as I go away on holiday tomorrow and will not liaise with Ford for a week! Plus want insight as I think the instrument cluster is faulty even if not the cause of both problems?)
  4. Hi My high level brake light lens and lamp holder has fallen out, and dangles by the wire. I've taken off the internal trim, but can't see how the lens and holder are supposed to stay / be fixed into the recess. Are there clips, missing, which hold the fitting in place? Thanks Bruce
  5. Hello All!

    Hello to you all, new here, so hope to fine some good advice and topics.
  6. Digital Speedometer

    I saw that you can get a digital speedomoter to show on the trip computer. My understanding was you hold the black trip reset button on the speed panel, then turn your key till the electris come on and it said keep holding it till it says GAGE, hoever mine said TEST and then start the engine up. You should then be able to using the black trip reset button go through the trip options till the digital speedometer shows. It never came up on mine and I couldn't see anything different. How do you get this working? Thanks
  7. Hi All, First post here, unfortunately in need of advice. The speedo on my 2004 MK1 Focus stops working intermittently (stays at 0). This happens approximately every other journey. The odometer also stops recording miles when the speedo stops. This is accompanied by it occasionally stalling when I pull up to a stop as the engine falls back to idle. I have not noticed a lack of power as other people have but this could just be as I am gently driving around town. The same applies for the drop in radio level. I have only noticed the speedo stopping working when I am moving off from stationery (it doesn't seem to stop whilst it is showing a speed). I have only done short journeys since this has started happening (less than 10 mins/3 miles) and it has yet to start working again. When I restart the car it resumes working. Having read other posts here and on other forums I was relieved that it appeared to be the VSS. I got this changed but the same symptoms are occuring. All the other dials are working OK throughout. Does anyone have any idea what could be causing this? I think its unlikely the new VSS is faulty. Incidently it was replaced by a previous owner in 2009. Thanks in advance... Doug
  8. I have never contributed to one of these forums before but have been trawling them for a solution to this problem and on every site people have said I need to reset my ECU or remove the battery. I have done both and neither worked. So I went back to basics and started checking the 'very' simple things. I noted that when I applied the brake pedal, both front and rear position lights came on... which lead me to believe that there was a short in the brake light system drawing down the intelligent lighting solution voltage etc etc. So I checked the bulbs and low and behold... I had fitted an incorrect brake light bulb on that side of the car and when I moved it to the other side it transferred the fault. When I removed the faulty light bulb (brake light on the NS) and reset the ignition, the fault cleared and I am back in business. Now just to replace the brake bulb with the correct type (double filament). Thought I would share this as the investigation has taken a bit of time and would have cost me quite a bit for a really simple solution. So in short, both position lights out, check the brake bulb on the same side first to ensure it is the correct type and not causing a short. Hope this helps!
  9. Hello, I would appreciate any advice on the predicament i have found myself in. I have put down a deposit on a 2010 titanium x sport 2.0 petrol at a local non ford dealership. They have delayed collection for a week before they told me it needed a software update before they released. when mechanics have delved further into it at a ford dealership nearby they have said that it may need a new engine. At this point i was stopped getting updates direct from the ford dealership. I now fear I am getting watered down information from the non ford dealership. The car is a good price for the spec so I am still keen to purchase if fixed appropriately. So, if Ford said it was in need of a new engine can I insist with buying rights that the car is fixed to these standards, bearing in mind when I deposited the car was in working order. if they go cheap and put a reconditioned engine in I have no idea if a poor reconditioned engine with 200k on the clock. if they put in a new engine I think they may want to recoup monies and put the price of the car up. Can they do this if they have agreed a sale price already? Would appreciate your help or any advice. Thx Paul
  10. Jasonmarie Smax

    Hello .............. As they say Iam back
  11. Help! Smax Part Required

    The 4 plastic slats/molding where the roof bars go in are ruined and I can't find replacement ones anywhere, please can someone help?!?
  12. Hi everyone, Hope someone can help in guiding me how to remove the trim on my 2007 Ford smax tailgate. I need to replace the faulty release switch. I can not see any screws and a bit frightened of just pulling the trim. Cheers Terry
  13. Hi all, I hope someone can give me some advice I bought a 2011 1.6 TDCi S-Max in January to replace my written off Mondeo. Since I have had it, I have had nothing but niggles with electrical systems in the car. It started out with the bonnet claiming to be open when it was firmly closed and the alarm going off because of it, and a speaker in the dash that wasn't working. The dealer cleaned up the bonnet catch and hey presto the bonnet registered as closed and the alarm stopped waking up the neighbours in the night. I've been trying to find a good day to get it in to look at the wiring for the speaker as it works intermittently, sometimes crackling, sometimes with good sound and sometimes not working at all. I have had other issues crop up in the last week though: The parking sensors beeping at me when I'm driving forwards slowly The radio console not lighting up at all - after pressing some buttons the CD player worked, but I couldn't change it to radio or turn it off without turning off the ignition The near-side windows would only open half an inch, and go up again, but not open more than half an inch All of these things have spontaneously resolved. And now the bonnet is claiming to be open again and the alarm keeps going off. I love the car but might go all Basil Fawlty on it at this rate . The dealer has been very helpful, but I have limited time I can let them have the car to fiddle about with. My concern is that it's something major rather than lots of niggly dodgy connections. I would be grateful for any pointers so that I can steer the dealer in the right diection rather than waste time. Many thanks
  14. Warmed the car for 10 minutes before setting off, everything was working on the dash, put it into reverse and reversed out of the drive into the street and then put the car into first, looked at the dash and everything was dead (the speedometer, rev counter, fuel and temperature gauges and the digital LCD mileometer- the whole lot- dead). Thought I stalled it, but the engine was on..so I bravely drove it back into the drive and took the bus. ;) Don't want to drive in snow and ice with no gauges thanks Has the snow killed it? I hope its a simple fuse.. Help. Please. Watch the YouTube video link in the title (the forum doesn't let me copy and paste the url or link it using the button) Thanks guys
  15. warmed the car up for 10 minutes, like every day...Reversed out of the drive, (everything was fine on start up and when I got into reverse)..so reversed into the street and about to go into first when I noticed that everything on the dash had died. I thought I stalled it, gave it some revs and the engine was on..so I was confused. It was a snowy start today, the colds murdered it..I hope its a cheap fix like a fuse. Help me out guys! :/ p.s. see the YouTube link on the title (wont let me copy and paste on here nor will it let me link it using the button) thanks guys
  16. tailgate

    From the album My '08 S-Max Titanium

  17. smaxsidefull

    From the album My '08 S-Max Titanium

  18. smax clean

    From the album My '08 S-Max Titanium

  19. side wheel toyo

    From the album My '08 S-Max Titanium

  20. rear side

    From the album My '08 S-Max Titanium

  21. front Led

    From the album My '08 S-Max Titanium

  22. artsy ford

    From the album My '08 S-Max Titanium

  23. smax

    From the album My '08 S-Max Titanium

  24. The speedometer on my 2001 fiesta sometimes does not work and will come back to Life without any intervention can anyone give advice on how cure or where to start looking
  25. I am looking to replace the head unit of my 2007 S Max but I am struggling to find a nice double din stereo which has red back lights/features to match the rest of the car. All units I am finding are blue (or very ugly). I am preferably looking for a touchscreen, has anyone replaced theirs and if so with which unit? Any suggestions or experience would be gratefully received... Thanks in advance