AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/Voice+Control'.

Found 61 results

  1. After driving my Focus MK2 for over 6 1/2 Years it was time for something new. Of course it had to be a Focus MK3. Unfortunately there were only a few (very young,low mileage) used cars for same in the country which met my requirements. After a long search and even considering a brand new lower spec car I finally found a suitable replacement for my Focus MK2: 2013 Focus MK3 5-doors Champions Edition My car is a German spec Focus MK3 Champions Edition. Because of the Ford sponsorship of the Champions Leage in 2013 Ford Germany offered this special (limited) edition for a few months. My car has the following options: Engine: 1.0 ECOboost 125 PS with 6-speed manual transmission. Color: Midnicht Sky metallic. Interior: Ultimate/Lux / Charcoal Black Options: Front and Rear Parking Sensors. Active Park Assist. Active City stop. Powerfold Mirrors. Power 1-shot Up/Down Front & Rear Windows. Global opening/closing (remote control) Rear Privacy Glass. Dual Zone Climate Control. Heated Windshield. Heated Washer jets. Heated Seats. Start/Stop System. Rain Sensor. Light Sensor. Front Fog Lights. SYNC with APPlink. DDS Tyre Deflation Warning System. Hill Start Assist. The car did have 16 inch alloy wheels as standard but because I like my own 17 inch alloy Focus MK2.5 wheels a bit more I decided to install my own wheels instead of the original 16 inch alloy wheels. In my opinion these wheels look great on the Focus MK3. During winter I drive on a set of 15 inch steel Focus MK2/MK2.5 wheels with Goodyear Ultragrip winter tyres. Despite 15 inch wheels were officially never available for the European Focus MK3 they fit without any problems on the 1.0 ECOboost models. The 1.6 TI-VCT and 1.0 ECOboost versions have 278 mm front disc brakes. This is exactly the same disc size as the Focus MK2/MK2.5 versions which were available with 15 inch wheels. On other Focus MK3 engine types Ford used bigger brakes which require at least 16 inch wheels. My Focus MK3 did originally not have Cruise Control. Cruise Control was not a standard feature on the German spec Champions Edition. Strange enough the first owner did order all possible options which were available on the Champions edition except Cruise Control. Because I am used to have Cruise Control and I really miss it I decided to retrofit Cruise Control to my car. There are some aftermarket solutions to retrofit Cruise Control to a Focus MK3 but personally I do not want an extra stalk or aftermarket buttons. So I decided to retrofit the OEM Cruise Control system. Because I could not find a mint condition replacement Cruise Control steering wheel for my car I decided to modify my own steering wheel instead of buying a new one. In my opinion it looks very good. The Cruise Control switch fits perfectly into the cutout I made at the side of the steering wheel. The Cruise Control switch is a very snug fit and all edges line up perfectly. The steering wheel does look exactly the same as an original Cruise Control steering wheel. From the outside there are no visible differences. I wrote a guide about retrofitting Cruise Control to a Focus MK3. This guide can be found on the following weblink: http://www.fordownersclub.com/forums/tutorials/article/274-retrofitting-original-cruise-control-on-a-focus-mk3/ After a few weeks I really missed the HID lights I had in my previous Focus MK2 so I decided to install new headlights. After a long search I decided to buy a pair of Sky Wing projector headlights. http://i1272.photobucket.com/albums/y388/ford_focusMK2/DSC04006_zpsf2e7014f.jpg I installed a 4300K HID kit into the Sky Wing headlights. The light image and the light output are very good and the Sky Wing headlights look great. Next I decided to install DRL lights. I bought these lights from a Taiwanese seller on the AliExpress website. The DRL lights are made of high quality materials and look very good. Some time ago I found some illuminated rear bumper reflectors on Ebay. However the price was ridiculous so I decided to wait a little longer. A few weeks later I found the same reflectors in an internet auction. I made the seller an offer and bought the reflectors for a really good price. The illuminated rear bumper reflectors look really nice. The light output is about the same as the original taillights. I also made the following modifications to the car: * The "Focus" and "Econetic Technologies" badges removed from the tailgate. * The "Champions League" badges removed from the B-pillars. * Rear seat hinge covers installed (originally used on a focus MK1.5). * I installed front and rear Titanium interior lights with LED lights and reading lights. Because of the different wiring/connectors I made an adapter wiring loom to connect the Titanium interior lights to the standard wiring loom. * I installed the original footwell lights. I changed the red LED's to ice blue LED's (same color as original). * I changed the red/orange control lights of all switches to ice blue LED's (same color as original). * I changed the 3.5 Inch monochrome MFD display to a 5 inch Sat Nav colour display. Afterwards I retrofitted the complete OEM Sat Nav system. * I installed LED bulbs into the puddle lights. * K&N 57S air filter. This Year I plan to do some more modifications on the car. The next modifications are on my wish list: * New instrument cluster with a bigger display. * New OEM rearview camera.
  2. Mk2.5 fitting cruise control

    I'm thinking of fitting CC to my focus and I've seen some steering wheels on eBay and just wondered if they were the right ones ano wondered if ford dealers activated it or not, the links below are of the steering wheels I have found if anyone has any advice or tips that would be great, thanks :)  http://www.ebay.co.uk/ulk/itm/301866028862  http://www.ebay.co.uk/ulk/itm/111872166314 
  3. Hello, I've sourced some replacement cruise control buttons for my 1.8 07 plate S-Max after forking out a few quid for DM Flywheel slave cylinder and clutch, what's a another £100! I know after reading around it needs a software update to enable cruise control - can anyone near me help for a few quid? I'm just over the severn Bridge but can drive over anyone local-ish. Otherwise It will be a case of asking the dealers, probably getting initially some confused looks, then "oh that's not something we can do" followed by "okay hand over £200 and we'll have a bash" Cheers!
  4. Hello there, I hope not to get stoned for repeating questions as I am sure what I write here has been covered already. I have done my browsing on here and I think I have some of the answers but I would like to get the full picture so please bear with me. After a long period of driving Japanese I ended up having a 2005 Focus Estate with a 1.6 TI-VCT engine. I have had it for a good week now and as far as I can tell after about 500 miles I like it. When I bought it the coolant temperature guage was suspiciously steady at 60 C even after 15-20 miles. I think I should have thought of the obvious why the previous owner parted with it. I suspect my thermostat is stuck open or semi open. The tests I have done so far: Set the on-board computer to show the engine temperature ( I hope I am right saying this shows the cylinder head temperature) started the engine and put my hand on the radiator. Started with the radiator being cool and the temperature in it started to build up very quickly , although the engine temperature was only showing about 86-88 degree C. The coolant temperature gauge was still on 60 degree C. Then I spent another 20 mins sitting on 1500RPM (still on the drive) to get the engine temperature up to 120-125 degree C. At this point the coolant temperature guage had reached around 80 degree C. I carried on warming the engine to test if the fan was working as I had never heard it come on before. About 10 minutes later at around 142-143 degree C I finally could hear the sound so the fan was working. At this point the coolant gauge was just under 90 (ever so slightly before the middle mark) so I guess the gauge is not the most accurate as people here say the fan is set to come on around 100 C. I also took the car out for a drive a day later. I drove 20 miles to see what would happen under life like conditions with the computer set to show the engine temperature. I was doing a mixed drive, revving the cr@p out of it as well as go as slow as possible and the engine temperature just would not get over 80 degree C. I could only push it over when I rolled onto the drive and let the engine run for a few more minutes. The other thing I think my be a give away (I might be wrong) that from Peterborough to Birmingham and back with no traffic issues I could do near enough steady 65-70mph and the coolant guage would not move from 60 C and my mpg when I refilled the car worked out only to be 32-33mpg (around 8.8 l/ 100km). I would have expected more on a long run, given that the temperature was relatively mild at the weekend. The car pulls OK otherwise and does not judder or misfire. One strange thing I think is also worth mentioning that when I checked the engine temperature from home to work this morning upon turning the key to the second position whilst holding the trip computer button and selecting the engine temperature the starting temperature was about 43 degree C. I found it a bit odd as the car had not been driven since the evening before. I would have expected it to be around 10 C , same as the air temperature. Here are my questions: 1. Do you guys think it could be thermostat or is it something else? 2. Is it possible that my temperature sensors are not working or giving false reading? 3. Where is the coolant temperature sensor situated in my focus? 4.What temperature does the engine temperature sensor actually measures? Is it the cylinder head? 5. What is the usual operating temperature measured by the engine temperature sensor ? 6. At what temperature folks would you expect the thermostat to open and let coolant go to the radiator? 7. What is the temperature set point for the radiator fan? Is it 140 +/- 5 degree C of the engine temperature or is it the coolant at 90 -/+ 5 degree C? 8. Which temperature sensor feeds the ECU (PCM)? And would the ECU give the signal to the gauge on the dash or would it be a separare unit? Sorry for the lenghty post, I am new to cars although have been driving for 15 years but only just recently started to show interest in how they actually work. Thanks in advance! Pete
  5. Hi Ford Brits, I have recently taken delivery of a new 2015 Mondeo Titanium wagon (I think this aligns with your Titanium X...anyway it's top of the range). Apart from a nasty incident with about 1000 miles on the clock where the power steering failed on a windy road (!), I have an ongoing query about the use of cruise control in this car. I'm hoping that the vast experience on this board may be able to come up with a definitive answer - Ford Australia haven't had this car available for very long, so their knowledge of detailed topics appears very slim... So, the question: on the wide range of vehicles I have driven professionally over the last 15 years or so, once cruise control is set, the driver can adjust the speed manually by pressing the + button or - button. The increments are always 1km/h per press. On some cars, if you hold the + or - button for a second or so, the speed set varies by 5km/h or even 10km/h. In all cases though, the minimum increment is 1km/h. On my Mondeo, even though the Manual says it should change by 1km/h, it ONLY moves by 5km/h increments. If you're doing say, 83, one '+' press takes it to 85, but further presses move it to 90, then 95 etc. And the same in reverse ('-'). Can someone check on their car, or provide any advice? I wondered whether it could be configured in software... Thanks for your help, Happycamper700
  6. Info On A Couple Of Mods

    hey guys, just wondering if any one has any information, price range and level of difficulty to install global locking and cruise control in my 57 plate focus. cheers
  7. ?less Bluetooth

    Hi everyone I have been looking on this website for a little while now and I am about to buy a titanium Ford Fiesta, but I'm a little confused, and don't worry I will be going back to the sales team to find out these things for sure, but in the meantime I am researching like crazy and coming up empty, Basically what it is is is during our meeting today was informed that the car has Bluetooth and voice activation and reads out text messages etc etc, however when looking at home on the "go to website" Ford Etis that that the guy was using in the sales room and bearing in mind I had looked at so many was confused which car had what, he stated that it has the voice activation etc, but on researching myself, it says less Bluetooth, less voice activation nodules, but has this ICE DAB radio. Not quite sure what I'm looking for to see if it has ford sync on there, as on the ford etis website it doesn't list ford sync at all. Does anyone know if it has the ability to sync music and phone calls etc and whether it does have voice activation etc? Can anyone shed any light, or have I completely confused everyone what I'm asking? Thanks everyone and apologies for confusing paragraph.
  8. Hi Guys, I have 2 problems to which I hope here can help me sort and I hope this thread might help someone else. I have a Ford Focus MK1 1.6 Zetec (engine pictured below). My problem No.1 is it idle's on the 700-750rpm line and kinda shakes the cabin more than it should, it feels wrong and sometimes hunts for idle. Problem No.2 when i turn things like the light, blowers and front/back heated windscreen the revs drop to about 650 and shake the car considerable more to a point where you think it might stall but never does. Too be clear, my car does not have a MAF sensor. I have changed: - Idle valve sensore - Throttle position sensor - Coil Pack and leads I have checked: - PVC/breather valve hoses into the T and all is good - All hoses involved in air intake for a potential vacuum leak. I also used carb cleaner to spray every area to see if revs increase with no luck. - Battery/alternator connections wiggled and everything. - Earth connections cleaned. At the moment I can't find anything with anything but I did check battery voltage at Idle. Voltage at idle - 14.3V Voltage at idle with front electric windscreen heater on - 12.5V Not sure if this is a problem as when I rev the car the voltage increases with the heaters/lights on from 12.5V plus past 14V, any one have a view on this? Could the culprit be all along the alternator? Next actions - Apparently the PCV valve can cause this if broke, anyone have a view on this? Im also gonna do a ECU reset. Disconnect batt for 20 mins, let it idle for 20 mins then drive for 5 miles. I heard this works. One last thing is Ford do a ECU update to sort this out people say, is this BULL???? One thing to add my exhaust does have a blow but i don't think this will cause any of the above. If anyone has any ideas/experiences or tips please share I would be very appreciative. Thanks Jono ADDED: Forgot to say my car says there are no fault codes stored.
  9. Mk5 Heat Problem

    I've heard and read that fiesta MK4 and MK5s can have a heat problem with either hot or cold constantly feeding through and not being able to change the temperature. Mine is doing the exact same. It's feeding through constant hot air. After having read a solution, I thought it could be a thermostat problem. The guy I bought the car from told me he'd already changed that not so long before I bought the car and it was bought in March. I then read it could be a heater control valve problem. I changed the heater control valve and it worked! For a day or two... No I'm slightly stumped as to what next to look for. I don't believe it could be the matrix. I don't think there is a blockage anywhere otherwise it wouldn't have worked as soon as it was swapped. I'm reluctant to think its the connection as I checked that while swapping over the HCV and it seemed OK. Plus, it wasn't all that long ago. There's definitely no Leaks. The head gasket hasn't gone and its not on its way out. A few people had mentioned the heater control panel might be an issue. The fans are working on all settings but there's no wires running from the temperature knob. It's all running from the fan switch, the bottom of the PCB board and the 12v power supply. I don't think it could be the HCP neither becauxe it was working g when the HCV was swapped over. And I'm sure the wiring is normal anyhow. Has anyone got any ideas? I've searched all over this forum and I can't seem to find the answer. I'd rather not take it tons mechanic and part with my money haha. Thanks guys.
  10. Hi folks i have a ford mondeo titanium x model and just recently had it mot'd only to find that i had no brake lights at all after some investigation by my mechanic found it to be a fault with the body control module apparently these are £600 to buy from ford +fitting and coding to the car my mechanic has bypassed the modue with a bit of wireing but but i want it back to factory standard HELP
  11. I just finished installing my S&C module 8M5T-19C112-AH. I made all the wiring mods and added a GLI. Great sound. USB works great. All titles are displayed in the NAV and in the Convers+. Full control over changing songs etc. IPOD and hard drive work great. Also have Bluetooth audio!! That was a great surprise. I thought BT audio was only available in -xM units and later. Additional cell phone options (last call made, last call rcvd...) are displayed in the Convers+!! Here's my problem. My previous BT/VC module was a 7S7T-19G488-BE, German language. I installed a 8M5T-19C112-AH, supposedly English, but the voice control is still in German. How do I change the voice control language. German isn't a problem for me, but the VC doesn't like my accent. Help!!!
  12. Please don't waste your money and buy from ebay I made this mistake buy from Fords Even my car is old it is reregistered disabled so Fords gave me a price then I asked for the 20% V.A.T off man looked confused as long as the car is reregistered disabled and I buy the part from Fords it is exempt from the 20% and presto got the 20% off Car is nice and cold again will never buy from ebay again but did get my money back from the seller in full
  13. Hi all, I have a 2011 Titanium X Mondeo which I have just purchased. However, an annoying fault has just surfaced with regards to the Speed Limiter and Cruise Control functions. Last Saturday, the Speed Limiter function stopped working all of a sudden. I had been in my car for about 2-3 minutes, set it to 30mph, and was approaching some lights when it disengaged automatically. I pressed the button on the wheel to switch it back on but nothing happened. I tried long press, short press, hard press etc, but nothing. The cruise control button also did not respond I noticed. It stayed like this for well over an hour, and I only realised it had come back to life when I tried it later on in the journey. I mentioned this on Wednesday to my local Ford garage but was told that it was very hard to diagnose if they can’t see the fault. As I drove off, I set the limiter and the fault just happen to appear again and the same thing happened… I approached some lights after about 2-3 minutes and it dropped out and would not come back to life. I turned round and went straight back to the garage while the fault was still present. One of technicians ran some diagnostics on the car and found (I think he said) a communication fault to do with the instrument control panel, but he wasn’t able to identify if it was software related or even just a loose connection. I believe he then cleared the fault on his computer so that it showed clear on his laptop and all working, but the actual fault of the Speed Limiter and Cruise Control buttons not working, was still present. I have attached a screenshot of what his computer said. The actual fault remained present until I got home. So maybe what his computer showed was not the Speed Limiter fault maybe? Half an hour after I got home, I had to go out again and low and behold, everything was working ok again. The buttons weren’t working when I parked up, but had come back to life once I had got back in the car. So there is a definite intermittent fault somewhere, but from what I understand, it will quite difficult to diagnose and was certainly not a fault the local garage had seen before. Has anyone heard of this before? It has happened a third time now. The only common thing I can link all three times with is that I turned the speed limiter function on within about 2-4 minutes of starting the engine. Do Mondeos need a few minutes to warm up and boot up maybe!?!? I also have the PowerShift gearbox. I have used the function plenty of times in a journey, but on those occasions, I have turned into on later in the journey. It could be purely coincidental, but that is the only common thing I can think of. If anyone knows the answer, then it would be great to hear from you, as my Ford garage are scratching their heads. Thanks, Matt
  14. Ford Focus 2014 Aircon

    The aircon on my 2014 Focus failed after about 8000 miles and it being just over 1 year old. The garage want £470 to fix it and say it isn't a warranty item as the condensor has been damaged by road debris. I've spoken to Ford Customer care and they are taking the side of the garage. My argument is that if it has been damaged at such a low mileage then the condensor is not adequately protected and it is a design fault and Ford should pay for the repair (or at a minimum contribute). Ford however completely disagree and say they are unwilling to help in any way whatsoever. Naturally I'm concerned this problem may re-occur. Is anybody aware of this being a common problem, or can anybody offer any advise as to what I might do? Thank you
  15. Focus Ghia Cruise Control Problem

    hello this is my first topic on this amazing forum my cruise control switch that is located on the pedal has just brook see the image i dont know how to put it back there is any way to just make the 2 wire together and let it work forever ? without any problem that affect anything else thank you please help me
  16. Hi All, I am new to this forum and unfortunately for me it’s not through good circumstances, I purchased a Ford Fiesta Zetec 10 plate from Jennings Ford in May 2012 when it was 2 years old and had only 10,000 miles on the clock. I am just a young girl (early 20’s) and had to buy it on finance (the only debt ive ever had in my life), it was something of a luxury for me and I had to buy it on Fords finance (through Santander) for 4 years. I have never ever purchased a car through a garage before, only second hand through private dealers and have never had any major issues with them. Lucky me….just under 2 years later the car is 10months out of warranty I had been away for 2 nights I came back and tried to drive the car and the power steering had gone off and the steering wheel light and traction control lights were on the dash board. The AA came out and couldn’t figure out what was wrong with it, I am only a petite girl weighing 8 stone and I couldn’t possibly drive the car without power steering. My dads in motor trade and first instinct was to get a friend to put the diagnostic on it, which he did and he advised my dad it was the steering column, to which we rang the Jennings ford garage I purchased it from and he advised us that of a car that age (NOT EVEN 4 YEARS OLD!!!) that its simply not possible and to bring it in for them to check (which has cost me around £100 inc VAT) and sure enough the results were that it is the steering column. Jennings ford want £1,000 to repair it. Can I just ask how is it acceptable to expect someone to pay £1,000 for something which is clearly a mechanical fault??? I brought this up with ford and was very patient with them – I have now been without my car for nearly 3 weeks while it has gone on and basically I have to pay it or I am paying my finance everymonth for NOTHING!! I joined this forum to advise everyone to STAY AWAY FROM FORD FIESTA ZETEC’S 2010 REG AS THEY HAVE A CLEAR MECHANICAL FAULT WHICH FORD ARE UNWILLING TO ACCEPT IS THE MANUFACTURES RESPONSIBILITY. It would have been an entirely different story if I had my 2year old niece and 6 year old nephew in the car and it had went off when I was driving it as I would have clearly lost control of the vehicle and crashed. I am absolutely disgusted with ford and the way I have been treated and how SHODDY this car is!!!!! I wont stop until as many people are aware of this issue!! Funny how this is my rights yet Ford does not care…… The Sale of Goods Act 1979 doesn't say exactly how long goods should last. The general rule is that goods should last for a reasonable time and in reasonable condition. For example, a new car should last for several years in a reasonable condition but you may need to replace some of its parts over time. If goods don't last as long as they should, they probably weren't of satisfactory quality when you bought them. For example, if the sole on a shoe comes away after a few weeks of normal wear, this suggests that it was never of satisfactory quality. – WHO HERE THINKS A STEERING COLUMN SHOULD BREAK BEFORE THE CAR IS EVEN 4 YEARS OLD???? Thoughts and comments are welcomed……….. Thank you for your time
  17. I'm needing some help with a crusie control issue that has developed recently. Ford focus mark 2 2.0 tdci. It surges or pulses as if the brakes are being pulsed while at the cruisng speed I set. A bit like driving through lines of treacle. It only happens when trying to maintain the cruising speed. not on throttling up or down using the steering wheel controls. Ive had it into to the ford dealer who are perplexed. It's not showing up any error codes. However i have had the EGR replaced and the fuel filter changed in pursuit of the problem but it's still there. Does cruise control apply any braking if you run over the set cruising speed? say going down a steep hill is it applying braking I'm asking my self? Where are the sensors for the cruise control? where does it get its info from for mainting a constant speed? Any help you can give me would be appreciated.
  18. Hello All, New to this, not sure if I am posting in the right place, just need some help with a problem in my car. I have Ford Fiesta Titanium 2009, the bluetooth, usb, power socket (cigarette lighter) and voice command/speech recognition all do not work. The radio, CD player and the menus all work find with the media system, but the things mentioned above do not work at all... Any advice on what may be wrong would be helpful :)
  19. Fiesta Problem Help Please

    Just got fiesta titanium 2011. Have connected my iphone and if I go manually my phone book is showing and it works fine by clicking ok to select and make call. I am trying to use voice control but I think because it's 2011 model it won't sync with my contacts just says directory empty. Take it that means the cars directory?? The only way I can use voice control is to save name then save number. This is a pretty tedious way one letter - confirm etc... Is there any other way or have I got to individually put numbers into cars memory this way? The other thing is, I've never had low profile tyres before and noticed that if drivers side wheels touch the central white line the car feels twitchy through the steering wheel. I had tracking checked and it was way out so that's been sorted but can still kind of feel it occasionally. Is this normal as my friend says she can feel reaction to different surfaces also. Any advice ??? Thanks
  20. My dad has just got a mk7.5 titanium & under his central heater control he has a digital read-out. On my mk7 zetec I have a black space-saver which looks like a card holder.. I was wondering if anybody has managed to do anything productive with it, along with any other interior detail modifications alike?
  21. My dad and i had a discussion about this earlier - When it is icy what is best traction control off or on? I thought off as you don't want it to compensate for ice as it could put you in more danger, make you skid wheel spin etc My dad said if you have it on surely it will help you not skid or wheel spin? I've always read that it is best to have it off, whenever it's icy i turn it off i was just curios as to what everyone else though?!:) Thanks Jon
  22. Hello, we have a 2011 S-Max and the dual control heating has gone out of sync; normally if you adjust the dial nearest the driver the temperature adjusts the same both sides but the last couple of days they have gone out of sync, once you get to HIGH or LOW they match up but anything in between is pot luck; does anyone know if there is a simple fix?
  23. Yesterday I got my first car, a 53 Ford Fusion 2 1.4 Petrol. Unfortunately it only came with one key, and I would prefer to have a spare available. How would I go about retrieving/buying/having a new one made? Any help would be appreciated!
  24. Sony Dab Head Unit

    can anybody help, I have a 2010 focus mk2.5 titanium which has the sony dab radio/cd player,but it doesn't have bluetooth or voice control,is there anyway of retrofitting bluetooth and voice control without replacing the unit ???
  25. Please help I have an 07 PFL Focus ST3 with Denso sat Nav. The other day my voice button decided to mute the radio instead of initiating the voice recognition woman. And my phone icon disappeared off the stereo, I'm led to believe my bluetooth module may be on its way out. I've resented my battery Removed the cable from the back of the module and reconnected Pulled fuses 108 and 112 to try and reset/resync it. Nothing, I have just bought a modified ELM327 module hoping to reflash the module with my VIN number but when I try that module the ELM Config always asks me to connect at a faster braudrate-rate. Has anyone got any help or can talk me through the process or at least try and she'd any light on the matter My Nokia module doesn't have a mini USB on the back. Thanks for any help Chris