AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/ford+mondeo+engine+shaking'.

Found 1,321 results

  1. Well today has had me pretty much finally snap with my dealer after a 3 month battle with them over reversing sensors on my ST.   Basically when I went to pick the car up I noticed that the sensors were the complete wrong colour for the car, my car is Spirit Blue and they'd used Deep Impact Blue instead on the sensors, so this had the car going in a week in for a day to have them re-painted, with the excuse that they didn't have any paint available at the time and they had to paint them in something. Seemed like an odd excuse but fair enough no argument.   So I go to pick up the car and notice the paint is still not right, this time the excuse was that they couldn't get the paint mix correct and would have to have it back again so they could have another go, unhappy at this but fine whatever, I'll give them one more go (third time lucky or something I hoped...). So back it went again to have this re-done and guess what, STILL not a good match on the bumper colour, to which the service manager wanted my car for a week for them to do the job properly which I was hugely against because it was obvious they were going to flash it in to the bumper leaving me with an effectively 'repaired' bumper.    So this was the third time this car had been in now, and the next time it went in I said the sensors needed looking at because they had never worked properly and they beeped continuously whilst in reverse, it also needed checking for an engine fault after going into limp and showing the service light. They said there was nothing wrong with the sensors (or the engine which is no surprise). So I went away annoyed, and then all of a sudden next day the same thing with the sensors happens again and so once more it gets booked in.    It is this time that finally they find that the sensors don't work, however it took me taking the car back, going into the car park and doing the fault myself that they finally admitted there was an issue - their technician that morning found nothing wrong somehow. So after making 2 trips in the same day they finally found the fault, which marked the end of visit number 5.   Visit number 6 should have been the best, they replaced everything with the sensors and found 2 were faulty at lower voltages (i.e. when cold), so I went to my bumper and actually felt like smacking my head off the floor. Some absolute buffoon had used a screwdriver to remove the sensors and the paint was chipped and bits of plastic had been gouged out from the bumper. So this leaves us now onto visit number 7 which they were to inspect it and get it booked in to be repaired and the service manager was taking this on personally; but somehow he decided to listen to his technician who said some touch-up paint would sort the issue out, and he never looked to see. So I get back and even though I didn't expect it repaired, was beyond words that the same person who damaged the bumper tried to fob me off with touch-up paint; sure it was no longer showing bare plastic but it still had lumps missing out of the bumper at each sensor point.   So by this point Ford have had my car for 8 days in total, when the service manager says enough is enough, leave the car with them for a week and they will get it to the body shop to have the repair done properly once and for all, as well as look at the engine as the light had been on again and gone into limp mode. This was this Monday just gone. I ring up on Wednesday as I was told there was a chance that the car may be ready by mid-week but leave it with them until the Friday in case; I was told the car is in Burnley where the body shop is. Oh no, I get a phone call this morning apologising that they would need it another week as the car had been sat in their car park since Monday and had gone nowhere as the body shop had been too busy to do my car, at which point I went practically nuclear and told them under no circumstance does that car leave the dealership at all. My dad rings them too to find out what the heck is going on and finds that at 3 (baring in mind I told them at half 10 not to move the car) the car is now on it's way to the body shop, so we go down when I finish work for half 3 smelling one huge rat. So now, after the car has been down there for 5 days (bringing it to a total of 13) they're going to want it for 10 next time, as the engine fault hadn't been looked at and the paint hasn't been done, so 5 for the paint and 5 for the engine fault. It's now booked in for next Monday so I spend yet another stint with a courtesy car that is absolutely horrible; it's a 1.0 Ecosport that is more expensive to run than my ST...   But wait I hear you say, surely there's more?!   You'd be right! The car is brought back to me this evening as the mechanic who had dropped it off had to go get it back and there was the rat, sat on my left front wing - a nice group of scrapes and scratches, along with chips on the bumper nearby. That is why the car was sent off to body shop in such a hurry hoping I'd keep the God awful courtesy car for God knows how long more instead of getting the car back. Got the service manager on the phone (who must have been happy seeing he was at home) and he said, 'Oh we'll paint it when it's in the body shop.'   Now that is the end of the story as of now, but I'm not leaving it all just to get sorted and then let it go. I'm not happy whatsoever that by the time it's finished, if it's finished next time, I'll have had the car for 3 months and the car has been with the dealer for 23 days of that time, so almost a third. As well as this, I'll have a repaired rear bumper, front wing and front bumper because of them damaging it after I have taken delivery because of their incompetence. I'm going to be writing to Ford about this, but do you guys think perhaps contacting trading standards as well? I love the car don't get me wrong, it's amazing, but the service I've had after buying it is beyond shocking. I can't fault the salesman as he's always been great (our family has had now 5 cars from him and soon to be 6th), and the people on the service desk are great too as when I've dealt with them they've always been upfront and honest about things, but beyond that desk Jesus Christ...   I know I don't probably get worst dealership experience ever here, but it's quite the shocker for sure... Will upload pictures tomorrow of what I can :P
  2. Hi there, wonder if anyone can help?  I have a 03 1.6 Streetka that normally runs ok but yesterday started this issue of revs not dropping off when you take your foot off the pedal.  This morning I try it and it runs fine again.  No doubt it will return again when it feels like it!  Likely causes? What to do? Although she normally runs real sweet, she has had the engine light on for a while. The local indy took a look some time ago and suggested it might be one of 2 sensors on the exhaust, but that one is likely to break off when changed and if that happened it might mean replacing the exhaust.  Is it possible to check a sensor?  This morning I have pulled Obd code P0420, which is clearly to do with the exhaust but not sure of the best plan of action?  Could this be something to do with the revving issue or have I now got 2 separate problems to sort. Any thoughts or advice would be greatly appreciated. Jeff
  3. Bluetooth installation

    So I want bluetooth installed on my Ford Fiesta Edge, 62 plate. I'm just sick of trailing wires and having to find the AUX cable all the time, i want to just get in, select a song and then go, and do everything through the car and not have to pull over and answer a call. I've looked at the parrot things & i don't really want to get one as it's separate from the actual car and i've have to mess around hard wiring stuff in, not what i want. So does anyone know if it's possible to get bluetooth installed as if it was factory fitted? Also where I could get it done? If not what other options do I have. I'm based in Manchester too if that helps. Thanks :)
  4. Hi guys, new to this forum, just signed up. I'm having trouble with my new fiesta ST, I picked it up on the 29th of January 2016 - should add it's bought on PCP - And it's got an irregular knocking coming from the engine ( over the tapping of the injectors ) I've already took the car back to the ford dealership that I bought it from and they admitted they could hear it also and they changed the oil from 5w30 to 0w40. This hasn't cured the problem and further more I've learned that this is because there are incorrect machining tolerances in the bottom end of the engine? This information came from ford techs over different forums. They say that ford won't tell you this and they just change the oil. Now I have the car booked back into ford this coming Tuesday (Feb 16th) as I'm not happy with the results. I've contacted ford direct via phone and email, and the ford finance also, this is to cover myself with evidence as they have opened up a case.  The dealership have been nothing but nice to me, for example there aren't any courtesy cars available so the manager is giving me his and paying for all insurance costs.  Although im aware if this is the problem I have then the only solution is an engine swap, or ultimately a car swap. I'd like to know what my chances are or being successful? I've told the dealership if I reject that I'd be more than happy for a swap replacement as they have been spot on with me from day one and I don't want to burn any bridges so to speak. But if it needs done I'll be stamping my feet.  Thanks in advance! 
  5. Which DashCam?

    Guys. I'm wanting a DashCam but I have no idea where to start.  I want something that can hide behind the rear view mirror with no cables exposed.  Something that will either record all of the time/when parked up.  I'm not sure if it's possible to have one that records constantly, but I've read somewhere that there is something called parkmode? I'd like to spend less than £150?  Guys. Any advice? Suggestions? Links?  Many thanks in advance. Cookey. 
  6. Right I've just bought a SUB for my fiesta it's a FLI Trap single sub 1200watts i was wondering if it would wire into my head unit or will i have to buy a new head unit from halfords? Also where can i get Mk7 radio pullers from so i can remove my head unit.  Cheers Ben_140
  7. My 2013 ford fiesta 1L ecoboost's start stop isnt working, the button to turn it on and off just stays illuminated when pressed, you can turn the light off when the ignition is on but as soon as you start the car the light comes on and you cannot turn the light off, and therefor the start stop isnt working.  any advice  thanks  
  8. Hi all, So, I've just recently checked my engine over, no problem there, until I noticed a pipe was hanging down from the engine. So far I've determined it's the cold air intake, that the joint that held the pipe to the front grate (or wherever the intake actually draws from) has broken partially - the piece still slides in to the appropriately shaped gap, but it will not stay in place. It's my belief that a piece of plastic that should keep it connected on the top of the intake-to-pipe assembly (I'm sorry, I don't know if there's a proper name for it) just wore out over time. So, that's the situation. my questions three are these; - I understand a faulty air intake can have an effect on fuel economy and engine performance, would it affect this much if it were left hanging down as it has been? - Given that I have to reattach it and the standard fitting is failing to hold in place properly, would it simply be a case of supergluing it back into place or is there something more appropriate for fixing it? - how long would any such repairs last?   Any help you can give would be much appreciated. Thanks!
  9. UPDATE 19/01/2015 - I started this thread specifically for my sub enclosure. From there it grew into a general ICE thread. It's now turning into a general thread about mods/maintenance to/on my car. I also have topics on; Fiesta mk6 HID Retrofit - This topic shows how to fit Facelift head/tailights to a pre-facelift Fiesta mk6. It also explains how to install Bi-xenon projectors and HIDs without hurting the bank. I hope you enjoy reading, and subscribe to stay up to date! _______________________________________________________________________________ Few images of my custom sub box build... Just want to note now that I'm not building this box with competition specs in mind.. It's simply built to 1.) take up as little boot space as possible whilst 2.) providing more bass than the stock speakers. I'll be upgrading the rest of the audio in the car in due time! Just want to show off my amazing test of the box with a 6.5" "sub" although my box was designed for a 10" :) I'm using 12mm MDF and some strips of Ply to build my box. I'm also gluing all the joints with No Nails & Screws to make it as solid & airtight as possible. More pictures to follow once my sub, amp & carpet arrives! Fire away with any questions
  10. Hi guys, can someone throw me a bone here. Following a rather harrowing accident an object hit the front of my bonnet, the catch popped and the wind threw the bonnet back over and into the windscreen. Now the car's been a great runner, but it's worth less than a grand so the £400 excess to have it repaired wasn't economically viable. I've managed to get a replacement bonnet, new hinges and new support rams - all fitted without problems, but the latch mechanism is damaged and unserviceable. However the lock mechanism still works perfectly, so I've bought a new latch, my question is, how do you get the old latch mechanism out? Is it possible to undo the two retaining bolts and either lift out or drop out the old one without having to start butchering the lock? If anyone has changed out this unit and can give me some pointers that would be great. All the searches I've done turn up loads of things about bonnets stuck closed or unable to latch correctly but very little about actually replacing the latch, not the lock.
  11. New badges fitted!

    Finally got round to fitting my white badges. ST spoiler going on this week and then going to get alloys toward the end of the month. Car's slowly coming together :D What do you think of the badges?
  12. Engine revving

    I have 2004 Ford Ka, 1.3   engine is revving by itself when idle. engine management is on. engine sounds like its struggling to breath (intermittent)   once I drive the car, it can drive steadily without my foot on the accelerator!!.diagnostics suggested 02 sensor. been advised to put fuel treatment in it the car is getting a little unnerving to drive at times    
  13. Hi I have a ford fiesta ghia 1.4 5d 53 plate and I am wondering if it has a belt or chain and when it will need chaining. It has 70,000 at the moment. Cheers     
  14. Hello all :)

    Proud owner of Ford C max 2010, 1.8 tdci, hope to have a lot of nice memories with it . Regards from Sarajevo,  Mihael
  15. A few months back, my 10 reg Focus 1.6Tdci went into turbo overdrive, which I had to stop by stalling it. It was recovered to our local Halfords garage. They said too much oil in engine had bypassed seals and got into turbo with turbo then running on the oil. They dismantled the turbo system and cleaned it all out. Replaced filter etc. They had to fit a new CDPF which cost me an arm and a leg. They instructed me on how to drive it to regen the new CDPF, but that didn't work. They took it to the local Ford dealership who did a forced regen. Having got the car back, I noticed that at low revs in low gears (around 1100 to 1500 rpm in 2nd and 3rd), the engine would hesitate. I lived with this and the car behaved normally otherwise. However, just over a week ago, on the way to work, the alarm sounded and a message came up saying "ENGINE MALFUNCTION". I found that this reset by turning the engine off, but came back after driving again for about 15 or 20 minutes. Before I had chance to take to the Ford dealership, I had an extra fault arise with the little orange engine symbol lighting up. This didn't go away with restarting the engine, so I took it into the dealership. They managed to clear the orange engine light then suggested I took it for a drive to see if it was OK, but after about 20 minutes, the "ENGINE MALFUNCTION" message came up again. I took it back to the dealership for them to investigate. That was Tuesday, it's now Friday and they still haven't come up with an answer.
  16. Ok hi fellow ford owners! so just paid 3000 for a 2004 ford mondeo st220 3litre v6 and am having some issues that need adressing and are quite worrying!! Ok so its only done 85k miles all service history but problems am having are  1. When i turn right i get a loud high pitched squeel. 2. Its quite a moany engine and a little loud when it does in low revs 3. After warm when i stop can hear a very faint knocking noise from engine only happens when still  but works fine hoping its nothing major but any help would be appreciated thanks!! 
  17. Newbie From Dorset !!

    Hi All New member, Just purchased Mondeo 2012 ZBE
  18. Hello I've had a light come up on dash of a Ford fiesta ztec s diesel 58 plate which is a amber cog shape with a exclamation mark inside of it, I went into the hidden diagnostic menu but now it won't seem to go back to the normal menu which shows you mpg, mileage till I need to put more diesel in, average speed anyone now how to get it back to normal?
  19. Hi all, Looking to do an oil service and fix a leaky sump plug at the same time! Does anyone know what type of washer I need to go on the sump plug and where I could buy one?    Thanks in advance! Ben
  20. Hi All, My epic search for an S-Max continues, have seen some decent examples but all seem a bit overpriced (good popular car I guess) We have seen a 2.0 TDCi 115bhp model on a 10 plate My question is what is the difference between this and a 140bhp model?  Is it the same engine just mapped differently (ie could it be remapped)? Thx In Advance
  21. Hi, I've has ongoing problems with my 2007 Diesel Fiesta since I bought it 2 years ago. Firstly I know diesels can't misfire in the normal sense of the word because of the lack of spark plugs, but it's the best way to describe the problem. Basically (usually under load), every now and then (once every 500 miles), the car will lose power for a split second then regain it. Once it starts doing this it will do it a few times then stop, usually. Sometimes it lasts longer than others, and it can do it several times in a row. The more I'm accelerating when it happens, the more violent the kangaroo effect is. Of course, when I get a mechanic to sit in the car with me while I drive it, the car doesn't do it... The full timeline of events: I buy the car used, ~50k miles on the clock, average mpg of 47mpg suggests it's been used for driving around town. I start driving it 70 miles a day, mpg increases. first big journey, it starts misfiring. Check engine light comes on at end of journey. EGR valve replaced by person I bought the car from. Every other fix this guy did was a bodge, so I didn't expect much. some time later, car goes into limp mode. Power train failure, dashboard becomes a christmas tree. When car is turned off and on, it often stops going into this mode. Took it to Ford garage for diagnosis. Fault determined to be with injector no. 1, Ford garage wanted £1000 to fix it. Took it to independent tester with full machine for injector testing. He found no faults with any of the injectors, so he switched injector no.1 and injector no.3 around so if the fault re-occurred, we would be able to find the faulty one. "Misfiring" persisted. A few months ago, the check engine light came on again, then disappeared. Eventually it was on more than off, and as I'd determined it was an EGR problem, I wasn't concerned. During thsi time, average mpg steadily dropped from ~60mpg to ~56mpg (maybe because of increased heater use as winter started properly though). Eventually got it booked in a few weeks ago. EGR valve replaced, check engine light cleared. Since the most recent EGR valve replacement, not only is the problem still present, but the car seems to have less power. Most worryingly, pushing the throttle a certain amount (just above cruise speed) causes the engine to act as though one cylinder is not firing, then firing, then not firing, then firing etc. it doesn't do it when flooring it, however the car now tops out completely at 95mph, whereas before it could go faster, so it's definitely less powerful. Car is now at 83k miles, and gets driven around 80 miles a day. I've seen lots of other threads about this issue. They point all over the place. The throttle linkage, splits in air hoses or boost hoses, ECU software updates(?), and injector seals. No smoke is present and the car isn't giving me any engine fault codes either (at least, the check engine light hasn't come on). What I'd like to know, is if the fault is something potentially causing damage to the car e.g. timing chain misalignment or something? And no I don't really think replacing the EGR valve ~3 weeks ago made it worse, it just didn't fix the main "misfiring" problem as I hoped it would.   TL;DR: Car has always had intermittent "misfire" problem, once it got bad but problem couldn't be traced, now it seems less powerful too with certain throttle setting causing more power/less power/more power etc. problem, with noise to go with it. no other problems with car, no warning light currently on, car was at 50k miles, now at 83k miles. Help?   Edit: I should add, the air con was bodge-fixed by the previous owner so is now broken again (he just topped it up rather than fixing the leak, so gas has since evaporated off). The AC is always off. Could this lead to problems at all?
  22. Hi, Some funny symptoms on my 56 plate Mk2 Focus. It's always done this to some extent but seems to have got a lot worse in the past 2 years since the cambelt and the clutch were replaced. * Clicking/rattling sound when under engine load (going up hill or accelerating hard or with a heavy car) * Sound like it's either coming from the engine bay or from near the front of the car around the clutch area * Seems to happen mostly in 3rd and 4th and 5th gears when hitting above 2,000 rpm until about 4,000 when putting on a fair amount of gas. * Occasionally under these conditions get a much louder rhythmical clicking (which the video below shows), but normally is irregular and sounds mechanical/metal/clicking (can't seem to get this to show up on a video, but can hear inside the cabin). It is def not any under-car heat shield rattles (these are all checked and speedbolted) I think it could be the engine pinking, but have one eye on the either the clutch or some other aspect of the engine- is it even possible for the clutch to be clicking without slipping? What do people think - anything similar experienced?
  23. Ford Fiesta Mk6 1.25 For Sale

    I Am Considering Selling My Ford Fiesta Mk6 1.25 Zetec Climate (2005) Last Month I Had A Brand New Power Steering Rack Put On, Brand New Brakes All Round. I Also Had Body Work Done On It As There Was Dinks Here And There And A Full Respray In Moondust Silver With Silver Metal Flake. Also Has New Lenso BSX Staggered Wheels ( 7x15 & 8x15), FK AK Street Coilover Suspension Kit. The Car Hasn't Been Used Since Owning It And Is In Great Condition. It Is Also Sorn Off Road. Looking For Any Offers? Feel Free To Message Me Too. Many thanks.
  24. engine system fault

    Hi all   i hope someone can help. i have a Ford C-Max, 2007 reg, 1.6 petrol engine. today the car has come up with a fault "engine system fault", then says "speed limited mode", and a red light is on. can anyone shed any light onto this please? from what I've read elsewhere this problem is quite serious and never seems to go away! need advice and help please.   thanks.