AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/fuel+leak'.

Found 191 results

  1. Hi. Just bought a mk5 fiesta. I just noticed a wet boot. Any ideas ?
  2. Hi in need of help my Ford Fiesta year 2001 1.6 was running fine then left standing for 2 weeks battery went flat so replaced new now the fuel pump / ecu fuse blows as soon as it starts up for 1 second replaced fuse starts then blows is this just bad luck or is something else gone wrong desparate need help Bioman
  3. Hi this is the first I have used a forum, I'm a typical girl not the best with cars but the back passenger side carpet is wet no other carpet is wet. I have a ford ka 60 plate it's a 3 door. Any suggestions of what I can be done or is this an expensive repair? I have read that garages don't like this type of repair as there is a lot of work :(  appreciate ted any help thanks 
  4. Hi Everyone, I am planning on changing the Fuel Filter on the above car over the weekend and I have the good old Haynes Manual to follow, however I was just wondering if anyone knew of any good posts of this nature on the forum already or of any useful guides - a quick search didn't return anything? Any useful advice or things to watch out for etc also wouldn't go amiss! Also can anyone recommend a good Diesel Primer Pump - there are quite a few on Amazon, but most of them have less than brilliant reviews. Many thanks in advance! Glen
  5. New fuel filter -now won't start

    I changed the fuel filter on my 09 focus titanium and now it won't start.  I topped up the filter with diesel, and after letting it soak, topped it up once more. ive tried priming it with the ignition the fuel lines are not swapped over my mistake The filter and o ring is secure and tight all nozzles are clicked in with their o rings in place. does the system need bleeding manually? Is there a nipple? There's no fuel cut off switch either and when I discount the the fuel lines and test it no fuel comes out. im out of ideas!!! please any help would be extremely valued many thanks Al      
  6. Hi, I am new to this site but after some advice. My 2013 Fiesta 1.0 ecotechnic recently started smelling strongly of petrol. I took it to the garage and they replaced a leaky fuel pipe under warranty. Ever since then (about 3 weeks) my car has a rattle - its not that loud but you can hear it even with radio on and its one of those annoying rattles, like a bottle or your sunglasses or something in a door pocket, but its not as I emptied my car of everything! Generally its louder when the engine is cold and dies away a bit once its warm. I've taken it back to the garage and they can hear the rattle too, they referred it back via warranty and apparently the new part is slightly different (and that's just the way it is now) and so therefore this noise is normal?! I cant say I understand this, especially as the hire car they gave me was almost identical (same engine etc but being one or two years newer) and doesn't make this noise. Any ideas on the real cause and what I should do next? I don't want to be left with a car with an annoying rattle and am concerned that if I ever decided to sell that no buyer will believe me that the rattle is normal! Thanks in advance!
  7. '57 plate 1.6 petrol Mondeo Mk 4 (owned fro new, no other problems, serviced, low mileage for year) refuelled 69 litres from nearly empty which then refused to start at the Sainsubury's petrol station. Just lurched 1 metre forward and apart from 2 hiccups, nothing. Towed it home and have discovered (by taking fuel line off in engine) that there is no fuel pressure. Engine turns but will not fire. Squirted brake cleaner into air cleaner and whilst squirting it would fire, suggesting electrics and engine ok. Central fuse box F22 20amp fuse on main board ok although it looked as if it had been hot as the edges of the legs were blackened. Green flag attended and their generic OBD scanner apparently showed no fault codes. So some help please.... 1/ Is there an inertia cut out on this model and, if so, where is it? 2/ What other devices can stop the pump from operating and how can I check them? 3/ Is there a complete system diagram anywhere such that I can evaluate the items that may be stopping the pump from running and how the power routes to the pump? 4/ Is the pump only accessible after lowering the tank? 5/ What is the layout on the pump and what can I check? Answers and any other advice very much appreciated.
  8. Hi all, First post, apologise in advance. I've a 2012 Mk7 Fiesta, Zetec, and I noticed a few weeks ago that when I filled up the car (full tank), the estimated mileage on the car had changed. It had gone from the usual 315+ miles (when I purchased back in July), which lasted for a few months, to around 275+ miles on the clock. Is there anything in particular, other than driving manner, that could cause this? As I've only had the car a few months and 40 mile drop is a bit weird.
  9. Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards Hi Guys I need some help! My wife has an SMAX 2.0tdi manual titanium MY2010, it has approx 80,000 miles on the clock. The car had been great up until now and returning a very good fuel economy, we took it into Ford a month ago to have a basic service, oil, oil filter, fuel filter etc. Since getting the car back, we have noticed that it now does about 100 miles less on a full tank (10-15%), there have been no changes in driving styles, habits, routes etc and the car seems to drive fine other than the fact that the fuel economy has dropped a lot! We have taken it back to Ford and they can't see any problems, any ideas as to what might have happened. Your help is much appreciated. Thanks and regards
  10. Recently whilst going to work in the morning the car sudddenly stuttered and "Engine Malfunction" light came on. I stopped and swithced car off and started car again, no problems whatsoever, however just to be on the safe side rang AA to come and have a look. The chap did an OBD reading and fault code P2290 came on however the car was driving fine. It's been all ok for the past week however last night on my way home, the car had the same problem, however this time, I was overtaking a lorry and it felt as if the car lacked power at 70mph after stopping and starting the engine. This morning everything was fine again. I contacted a garage who told me that it could be the fuel sensor regulator switch made by bosch or it could be EGR, TURBO, FUEL PUMP and to drop the car off to have a look. It seems that when I go above 3000 rpm on the motorway this problem seems to pop up. I nearly got killed last night!!!!! Anyone had anything similar problems? 1.6TDCI 110HP 59 Plate (service at ford garage according to service schedules, all maintenance done etc) Thanks
  11. I found the engine oil leaking on the surface of cylinder block, ranging from the upper of the oil filter to the behind of the starter motor. Such leaking originated from the cylinder head gasket or oil pressure switch? e
  12. Leaking Fluid Into Driver Footwell

    Hi all! Have a weird issue with my focus.... there seems to be a leak coming down the clutch pedal and into the foot well. Not a massive one but it's there! Looks like from the cylinder. I recently had a massive power steering fluid leak and that's just been fixed. When the leak started, weeks and weeks ago, I marked all the 'bottles' in the bonnet where the liquid was. None of them have moved except for the power steering fluid, as mentioned. I known issue I have is the seals gone on the bottom of the windscreen so rain could get in. Any ideas?
  13. I'm looking into the following error code on my 1.8 TDCi: P0191-61 - FRP Sensor Range/Performance The code appeared after I changed the glow plugs, which I did as a response to an earlier error (which is now cleared): P0380-68 - Glowplug control circuit I've taken a reading of the Fuel Rail Pressure using FORScan with the car running. I'm getting readings of about 5000 psi (340 bar). I don't have my Haynes manual with me, and Google isn't helping much. What are the expected ranges for pressure at the rail? (These values seem a bit high to me, but then this is the first time I've had to play around with fuel lines.)
  14. Hi everyone. I wondered if anyone would know where I can get some replacement door seals from for a 2004/05 Streetka passenger side please? I have a leak in my passenger side car door. I have figured out my seals are in two parts and are held together by a plastic pin and was pulled off one day by a garage man after the door was bashed in a crash. My poor car has not been the same since (it has been about two years now). I have tried my hardest to get replacement seals but I have been told by Ford that they stopped making them a long time ago and it seems breakers yards never get any. My seals have been held together for the last two years with a patch from a bycle puncher repair kit which has worked, unfortunately the rubber has perished and this is no longer an option. I can try and get ome more secondhand ones of ebay and hope the pin is not damaged and if so continue with the puncture repair kit method. I would prefer a more permenant solution though and I can't afford a new car at the minute. Would anyone have any ideas please? Thank you x
  15. I have a 56 plate Fiesta MK6 Zetec S, done 99k and hasn't let me down yet, untill recently. I first had a problem arriving at work after a 26 mile commute, noticed steam coming out of the bonnet so lifted it up to find there was NO coolant in it what so ever after being serviced 2 weeks before. so i topped it up and kept an eye on it. 2 months later after everything seemed fine, i was on the same commute and my engine temp rose from 90 to 120 in around 45 seconds while idleing in traffic, so i pulled over as there was luckily a petrol station right next to me and filled it up with coolant, then resumed on my way home, checked in the morning and all semmed fine, got to work this morning, checked again straight away, all seemed fine, checked an hour later after explaining my problem to a colleauge and it had dropped to basically 1/4 of the amount i had put in?! but the car had not moved, there are no puddles and no "mayonaise" in the engine oil. any advice would be appreciated on this as its doing my head in. thanks Chris.
  16. hiya there im new to this site. i have a ford focus 1.6 estate, it has not been started in 4 months, i hve tried to start it today and will not start i have sparks but no fuel evening going to the fuel filter. i have already checked the fuel cut of switch but still nothing any one have any ideas it will be much apprecated
  17. Hi, so I have a mk3 Mondeo 53 plate 2.0 TDCI Ghia, and I have been getting the warning light come on with the engine cutting out if I try overtake/ go shove 3k revs. I have taken it to an auto-electrician and to a garage and both have run tests, and the garage said it was pointing towards the sensor, and the auto electrician said it could be the fuel pump. Now that's cost me £150 for a non definitive answer and its !Removed! me right off. Anybody know what the answe could actually be? It drives fine unless I try boot it, has to work overtime going up hills. I don't know if it would be worth the money sorting it out or not. I have had the fuel filter changed and that hasn't hanged anything but the garages old diagnostics machine pointed to the injector, but his recent one that's better lead to the sensor. Anybody else had the same problems or know what it could be!? Thanks The warning light is the far left one and it flashes and if I try accelerate whilst it's flashing, the engine cuts out and all power goes and power steering and then the engine management light will come on
  18. Fuel Light Weirdness?

    Hi guys hope your all well im truly sorry for bugging you all i know this has probably been covered so many times (and im not shy round Google, can normally find my answers) but im stuck as i have no idea how to google what help i need. I have a 2000 plate 2.0 focus ghia, it has a trip computer which i use to a point, since ive owned the car some of the instrument lights haven't worked but didnt think much of it just assumed blown bulbs (traction control light which i know the bulb has blown got to change that and i thought fuel light as they have never illuminated) However tonight i saw a video about the hidden menu, so i checked it out, and it turns out my low fuel light bulb works. But this is where i need some advice because it doesnt work when the car is low on fuel? ive only had it a couple of times where ive let the trip drop to 0 and the gauge is nearly bent round the needle, has anyone had this or could anyone guide on what this could be. I though that if the trip hit 50 miles left the fuel light would come on and it would beep, but i get nothing (obviously i havent trusted the fuel trip so i end up putting tons of fuel in when its not necessary) I just wanted to see if anyone could point to where i should look for this? im lost :) Thanks guys and again sorry if this has been covered before Nate
  19. Just wondering where abouts is the oil filter on my 2008 1.8 TDCI and what's the best way to get at it? Also if I am changing the fuel filter, is there anything I need to do (i.e bleeding the line) or can I just swap filters out?
  20. Hi im new here but just joined because i need advice please. I've recently had the DPF static regenerated but at the same time the reading for the fuel delivery pressure was low so I bought a fuel filter £42 and fitted it myself ... All straight forward. .. i started the car fine and it it ran for 20 seconds i assume on what diesel there was in the rail but then stopped! It won't start again.i took the pipes off the filter and cranked the engine and there's no diesel coming out? Im at a total loss. Any suggestions would be much appreciated thank you.
  21. OK so basically I had a 2.0 TDCi Zetec S a few years back on an 04 plate that had diesel pooling around the injectors. It turned out to be the Leak off pipes/ connectors, we changed the lot to be sure. However when we changed it the car would not start at all! It took about a week of disconnecting and really connecting rando stuff to.get it finally started in limp mode. After that it was fine and the error we were getting of low pressure in the fuel rail went. Now I've just bought a mondeo 2.0 TDCi Zetec again with the same issue if diesel pooling around the injectors. My concern is ill.change the pipes and connectors and my car won't start again! Can anyone she'd some light on why that would happen? Thanks in advance :)
  22. Hi all, Ford Focus Mk2, 1.6 petrol. 2005 / 55. So yesterday I discovered that my engine coolant level was looking pretty low (maybe half an inch below 'min' when cold). No engine warning lights up to that point though. Today I took the car out to pick up some coolant / battery top up water (yes, I know that I probably could have used tap water!) to give it a bit of a top up before I decided what to do next. It was on the way back home that the fun began and I could feel the car juddering while driving up a hill until it got worse and worse. Experience told me that this was probably a spark plug / coil pack related issue. Still, at least the car still drove so I wasn't completely stranded, which is more than can be said for my previous cars. At this stage I hadn't twigged that the coolant issue was in fact related to the juddering as on inspection I discovered coolant / rusty water in / around the core plugs and it had made quite a mess. At least it solved that mystery. The frustrating this is that this is the very same issue that was discovered by my garage in Feb last year while they were doing the timing belt, except it had only got to the stage of making a mess / causing some corosion and hadn't had any noticeable impact on running or performance. I should also add that my car appears to have the modified screen washers and having done a few splash tests, they do seem water tight in my opinion. I only bought this car 2 years ago, directly from Ford, so I put my stern face on and drove (noisily) over to Ford and kind of dumped the car on their front door step and insisted on a resolution. I spoke to the head of servicing right away who said that the fault would be diagnosed and a solution decided at no charge, so at least I don't have to pay for them to find the issue. I accept that my car is gettinng on a bit, but I don't think it's acceptable for this to be happening once, let alone twice. The first time it happened was 6 months after I bought the car, so wasn't covered by a warranty. What stance should I take? What are the questions to ask? What is the actual solution so that I can check what they say against what you guys say? Can anyone explain to me what is actually happening to cause this and Is there a permanent fix? I'm hoping for a call back from them tomorrow. Thanks for any help or advice that anyone can give. J
  23. Hi there, I've tried refilling my a/c few months back and it was leaking somewhere. According to the mechanic it was the condenser. So i changed that during the week end. I went to refill it again, and it's still leaking. Went to 4 mechanics and no one knows where it's leaking? apparently they have put dye through the pipes but still in vain. Anyone have any suggestions please? The heat is unbearable Thanks in advance.
  24. Diesel Injector

    Hi can anyone please help I have a 2007 1.6 tdci focus its the 110 bhp model with the duratorq engine I have a leak from my number 4 injector I have been told the seals are easy to change but im worried if I do will the injector need re programming if I put the original one back in with a new seal? Thankyou for taking the time to read this look forward to a reply.
  25. Hi all Apologies for the rather flaky description here but I have noticed a small leak (possibly fuel) from the engine of our circa 2007 Ford Ka. Upon closer inspection there is a lead hanging loose with some kind of electronic switch or sensor on the end. This is dangling just below the bottom of the radiator on the right-hand side of the engine. Crawling underneath the front of the car I can see that this should probably sit in a circular hole near the bottom of the block, facing forward. The hole is threaded, around 3/4" diameter and contains a small yellow, rubber membrane. The switch/sensor has a kind of plastic 'push and twist' moulding on it but I still can't manage to secure it in the hole. For now I have pushed it in but it doesn't feel too solid. Does anyone know what this is (in case I have to ask a garage to sort it) or how it connects. With the car on a ramp it would probably be obvious but as it stands I can only guess. Thanks in advance! Martin