AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/glow+plug+light'.

Found 232 results

  1. Hi there, wonder if anyone can help?  I have a 03 1.6 Streetka that normally runs ok but yesterday started this issue of revs not dropping off when you take your foot off the pedal.  This morning I try it and it runs fine again.  No doubt it will return again when it feels like it!  Likely causes? What to do? Although she normally runs real sweet, she has had the engine light on for a while. The local indy took a look some time ago and suggested it might be one of 2 sensors on the exhaust, but that one is likely to break off when changed and if that happened it might mean replacing the exhaust.  Is it possible to check a sensor?  This morning I have pulled Obd code P0420, which is clearly to do with the exhaust but not sure of the best plan of action?  Could this be something to do with the revving issue or have I now got 2 separate problems to sort. Any thoughts or advice would be greatly appreciated. Jeff
  2. Morning all Been trowling through the net for this, and cant find anything, so apologies if its already been answered/posted. Please feel free to just point me to the thread if so.  Sooo. I got my Mk 2.5 1.6 tcdi Zetec the other week. Looking to do a few bits to improve it. One of which is the interior lights. I always liked having the map readers in my Seat Ibiza, so id like to upgrade to the same. A little disappointed in the trim of this car to be honest, VERY basic. But hey ho.  Anyone done this? easy? looks easy enough to be fair, but any indications on what part to get / good place to look? When i do an ebay search it mainly comes up with just the bulbs and not the unit its self.   Im also not against the idea of installing the courtesy light in the rear too.... its not a major want, but possibly look into it too. This easy to fit also?   Any help appreciated :)  
  3. My 2013 ford fiesta 1L ecoboost's start stop isnt working, the button to turn it on and off just stays illuminated when pressed, you can turn the light off when the ignition is on but as soon as you start the car the light comes on and you cannot turn the light off, and therefor the start stop isnt working.  any advice  thanks  
  4. Fiesta recall

    Took my 1.6 tdci zetec s 60 plate in for a winter health check today, and told ford doing a recall on the diesal glow plug module, cos when it rains it affects the module, ford come up with a solution and replacing the module free, just an heads up for other diesal owners. 
  5. Hi all, Looking to do an oil service and fix a leaky sump plug at the same time! Does anyone know what type of washer I need to go on the sump plug and where I could buy one?    Thanks in advance! Ben
  6. Hi All, First Post 3 weeks ago I brought a car from a car garage. Within 3 days it started to backfire and started to lose speed. later realised that water was getting into the spark plugs. So I changed those and also fitted a new battery due to finding that there was hardly any power starting the car. Took to a garage for a report which lead to realising the core plug was corroded, front break disc where corroded and that passenger front shock absorber was severely corroded and leaking oil onto the break disc.  Anyway now the car just isn't starting at all.. Recovery said its the starter motor however partner came home and some how managed to start the car. This morning I've gone to start it and again just not starting at all.  Every light comes on the dash and the mileage is just shown as ----. (See pic below) I've also noticed the immobiliser light is flashing like mad.  So I literally do not have a clue what the problem is?  And whether it's worth fixing as I love the car or just take it back? (however car garage said that if I return it refund will not be in full as he will charge me usage "but won't be more the £500" LOL?! Even though I've only had it 3 weeks)  the car was £1450 55 plate, 1.6 Ford Focus LX, @88,500 miles described as machially sound (just a heat cover needed reattaching which my partner did.) Do you know what's up with it?  Is this common/major issue?  Would your bother repairing it or just take it back for a refund? Any suggestions/ advice I would be grateful 
  7. Hi, I have a 1.4 Fiesta 2004 Mk 6. About 2-3 moths ago the battery light came on, I took it to the local garage and was advised that it was a problem with an alternator so had that replaced. The battery light was still on when they gave the car back and I was suspicious but the mechanic showed me the alternator charging the battery etc and was satisfied that the car worked well enough, albeit with the battery light on. About a month later, after leaving the car parked for about 10 days the battery was flat, so took it upon myself to invest in a new battery. Problem solved but battery light still on. I have been driving the car a fair bit since then, couple of long distance trips, lots of night driving etc all with the battery light still on but the car seems fine. Have even left the car parked for 3 weeks and it started first time. I do however want to get the light sorted so I can tell when there actually is a problem with the alternator and/or battery and concerned that it may not pass the dreaded MOT with this warning light on. Would be grateful if anyone knows if this is a common problem with a simple solution, my searches on various sites hasn't come up with anything of much use. Your help is much appreciated.  
  8. Location of rear fog light relay?

    When i press the rear fog light button, nothing happens. The bulb is ok, so I'm suspecting a faulty relay, occasionally I hear a short buzzing sound when pushing the button, but not near enough to identify it further. I have browsed through forums, manuals, asked my way around - but haven't been able to find any information or diagrams showing the position of the relay. Can anyone here point me in a direction? S-max 2008 TDCi Thanks in advance Thomas (Denmark)
  9. Hi there, I'm new to this site, has anyone got a answer to my problem. 2008 1.8 tdci s max, when I turn corners with a tight steering lock my Abs/traction control warning light come on and don't go off until I switch the ignition off. There was a bracket under the o/s/f wheel arch fitted the wrong way round and was pulling the abs sensor wire when on full lock, but this has been turned round the correct way and the abs sensors changed in case it caused any damage. The abs and traction control are both working fine, it's just this !Removed! warning light that I have run out of ideas with. Any ideas would be greatly appreciated. Thanks Ken
  10. Hi all, I've got a mk2.5 focus with the standard 1 bulb interior light in, now I was just wondering about changing it to one with map reading lights, I've seen some on eBay and I'm not sure if it's the correct one for my car or not and just wondered if they just plug straight in or will have to rewire, if anyone knows I'd just like a bit of advice 😊 Thanks
  11. 2011 Fiesta Headlight Tint

    hey, Im kinda new to all this and would like to know what size headlight tints everyone has been buying for their fiesta, sorry if a silly questions also what legal LED headlights would anyone recomend. Thanks :)
  12. Ford Fiesta Problem!!! Help

    Hellooo, I have a 1.4 diesel ford fiesta, which is 10 years old now. Recently it's started to cut off randomly, it feels as if the engine goes off for a couple seconds and then starts again. The battery light and the engine light comes on when doing this, but only for a second. It tends to do this when in 5th gear at around 50mph-60mph, which is around 2000rpm. The car has been in a garage all week and no fault comes up! Also, every now and again the 'transmission light'? (i think) comes on, (looks like a cog with a ! in) and goes into limp mode, where is makes it impossible to go over 5mph and very jumpy. Once i switch the car off and on again it goes fine. Has anyone had this problem before? Thanks in advance!
  13. Focus Mk1.5 Footwell Light

    So... I have seen in the forums that many versions of the Mk.1 Facelift Focus has all the wiring for footwell lighting, and I think I have managed to locate on of the harnesses behind the glovebox by the fuses. However, for the life of me I can't find the socket for the driver's side footwell light! I can see the plastic mounting where the bulb socket is meant to fit, but the socket and wiring is nowhere to be found... Is this taped to another wiring loom or piece of the dash/footwell? Also, if the socket behind the glovebox is the correct one, where does this go? Do I have to lift the foam matting in the bottom and place under there? Any help is much appreciated!! Cheers, Al
  14. All, I'm a newbie on the forum and have changed my interior LEDs to blue to match my candy blue Fiesta S. Just looking for a guide to whip out the centre cupholders and change the LEDs to blue. Any suggestions? Or anyone know of a guide to do it? Ta thanks in advance! CJ
  15. I want to check the washer is connected correctly and look at the seal, then disconnect and dry the high level brake level light out as water inside. I noted there are two grommets (mine were missing) but got 2 from a Fiesta. Removing the grommets do I just push through the hole with a screw driver to release each side, and does it clip and push back in easily. Don't want to begin without being sure...you know what happens, it won't go back in and you drive around at xmas with it blowing in the wind!
  16. just taken delivery of a 2010 fiesta 1.6tdci titanium, love the car drives well. just one or two dilemmas. 1, can't find or see a switch for the front foglight/drivers light? theres one for the rear but just can't find it tried all switched but nothing illuminates them, they are fitted just in case someone says. 2, the front heated screen, does it work only with the press of the right button or should climate be on as the screen looks like it not clearing? please help a newbie?
  17. Engine Cut Out After Starting

    Hi, this is my first posting on here, although I have followed the site for several years for advice. I have a 2006 Ford Focus Sport Tdci purchased on finance 10 months ago. The 3 month warranty has already expired, and I have 26 more payments to make before I own the car outright. For the past 10 months this car has worked fine, with no issues at all, and sailed through the MOT 3 months ago. Yesterday morning I did what I always do. I turned the ignition key to power up the car, without starting the engine. I waited the second or two for the glow plug light to go off, then started the ignition. The engine started immediately. I put the car in reverse, and just as I lifted my foot off the clutch to reverse off my drive the engine cut out. I put the car in neutral and attempted to restart the engine. This took about 5-10 seconds of whirring before the engine kicked in. The car worked fine for my 35 mile journey, and was fine 10 hours later when I returned to my car for my 35 mile journey home. This morning I again did the same thing. The engine cut out again at the same moment. This time it took 4-5 goes to get the engine started again, but on this occasion the dashboard showed some warning lights. The glow plug light came on for a few seconds, as did the engine management light. The power train light stayed on until the engine started. I revved the engine, got a small cloud of light grey smoke from the exhaust and the car started fine. I drove it only half a mile, turned off the engine for 5 minutes the restarted, and it was fine. No warning lights. Any ideas on the problem and expected cost would be appreciated. I'm guessing the garage or the finance company will not take liability.
  18. So I was driving towards a junction and the light turned amber and I thought I could make it, but just as I went through, the light turned red and the camera flashed twice!! What I'm unsure of is if I will get a penalty. The camera was on the opposite side of the road facing the front of my car and from what I've read so far, the cameras can't flash the front of your car. Has anyone had a similar experience and not got a penalty or does everyone think I'll get the 3 points and a fine?
  19. Hi all I'm new to this forum so hello. I'm a fiesta zetec owner and have just bought my son his first car. It's a fiesta studio 2013 model. The petrol looks very low but no warning light has appeared. I know on mine it comes on just before I go into red. Please tell me that this model HAS a petrol warning light? I know it's a basic model but.... thanks
  20. Can any one help. I have a 2006 mondeo tdi,130 ps with 210,000 miles on. I start it up and it's in limp mode,5 minutes down the road switch ignition off and on and it's back to full power,been doing this for months now.had the car plugged in and had 2 error codes. P0121 throttle pedal position sensor a. P132b turbo charger/super charger boost control a. I've changed both and still have the same error. Can anyone point me in the right direction. Thanks dave
  21. Hi all, I have recently purchased some upgrade l.e.d tail light units from ford. Took 4 weeks to arrive as ford didn't have them in stock, this is very true as the manufacture date on the units is dated 8 days after my placement of order last month. Guide now available in PDF Format see link: http://www.fordownersclub.com/forums/topic/62561-guide-fitting-ford-rs-led-rear-light-units-focus-mk25-pdf/ Tools Required: 1 x Philips head screwdriver 1 x socket driver 1 x Torx T25 Screw driver bit so in the big box we find two smaller box's with ford fitting instructions, These units are very light weight at only 2.4kg including packaging. Ford instructions are not very helpfull as you can see below lol So let's see what's inside the inner box's To my surprise they are supplied with bulbs, But I don't like the fried egg effect of the indicator bulbs so I'm immediately fitting some silvatec BA++ offset bulbs. Before: After: Much better :) As above images only opposite side, If purchasing these from a breakers or ebay; you can strike lucky and pick up a bargin as some sellers are not aware of the l.e.d units value. Such as this seller: http://www.ebay.co.uk/itm/Ford-Focus-ST-3-59-reg-3-door-O-S-rear-light-drivers-side-rear-offside-gen-ford-/221224879856? pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item338207c6f0 Notice the difference in the lens; the ford l.e.d unit has straight lines etched on the lens. The standard dual filament bulb units have a diamond etched lens.
  22. Hi, I need to replace a broken yellow drivers knee airbag electrical plug which is attached to a loom in the driver's foot well, a loom which also feeds the nearby driver's foot well courtesy light. It has just two wires into the plug from the loom and I think it would be easy to repair but is there anywhere that sells this item alone? I will try Ford but I do not want to replace the entire loom just for this one little plug which I suspect is integral to the loom. Is there somewhere online that specializes in Ford electrical plugs such as this? This plug is for a Ford Fiesta 2009 1.25 Petrol Zetec. Thanks, Gallantfive
  23. Hi all, i have been looking through the forums to try and figure out what has happened to my focus, i bought a tuning box from a tdi tuning company, it came with a money back guarantee which i have had to use, after i put the box on the car was using a hell of a lot more fuel, i mean a lot - without any noticeable power gains, so after a few days i decided it wasn't for me, however ever since i installed it, and now even more so since i removed the box my car loses power, glow plug light flashes and the car dies! i turn the ignition off and on and away it goes. the car has had a fully synthetic oil change 3 months ago along with all filters, coolant etc. I removed the cam sensor as advised on other posts here but i cant really tell by looking at it if its ok. I also last month cleaned the egr and maf sensor. im hoping this dam tuning box hasnt messed up the injectors or fuel pump, as when i restarted the car after it died the other night there was a horrible whining coming from the engine bay!! this went away as i stopped the car straight away. also im thinking of getting it on a diagnostics machine but surely there wont be any codes if the problem is intermittent? any suggestions would be greatly appreciated, cheers in advance!!
  24. Hi All, Just bought myself a 56 plate Fiesta Zetec 1.25 petrol. Picked it up today and found that the red snowflake light is constantly on and the outside temperature is showing up as -36 degrees. I know that the dealer I bought it from steam cleaned the engine before I purchased it so I'm guessing this is whats caused the light to come on. Can anyone advise on the best course of action to take to rectify this and how much it may cost? Thanks!! Al
  25. Hello I have a ford ranger 54 plate been to the garage because the glow plug relay keeps on clicking when the engine is turned off and the key removed don't know what it could be ? But after about 10 minutes the battery is flat and the glow plugs burnt out somebody said bad earth somewhere but where ?