AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/too+high'.

Found 19 results

  1. Engine revving

    I have 2004 Ford Ka, 1.3   engine is revving by itself when idle. engine management is on. engine sounds like its struggling to breath (intermittent)   once I drive the car, it can drive steadily without my foot on the accelerator!!.diagnostics suggested 02 sensor. been advised to put fuel treatment in it the car is getting a little unnerving to drive at times    
  2. Hi Have owned a Fiesta ST3 for the last month, best car I've driven in 18 years of motoring. Got the Mountune Performance Pack fitted (MP215); makes an awesome car just that little bit more awesome...You'd be mad to not have it;) Now I'm starting to think, hmm, what next? I do like the look/sound of the Mountune Cat Back Exhaust, that's definitely on my list (sadly not in stock at the moment). If you have this exhaust fitted, would you recommend it? I am aware that the stock exhaust has to essentially be 'cut-off', which has me a little nervous, I'll be leaving that to a garage methinks... I'm also thinking of getting the Mountune High-Flow Induction Hose (a nice red one). Looks very easy to fit and, if the claims are to be believed, makes first to second gear & general power delivery that little bit smoother. Being somewhat of a newbie to modifying cars, I am wondering if I will be able to fit this hose easily. I know my way around some basics, but an online video makes it look like I could cope quite easily. Sadly, at the moment, they don't have the hose clips in stock, but I'm sure they will soon. Again, anyone got this hose fitted & would they recommend it? Thanks for any advice. Chris
  3. I want to check the washer is connected correctly and look at the seal, then disconnect and dry the high level brake level light out as water inside. I noted there are two grommets (mine were missing) but got 2 from a Fiesta. Removing the grommets do I just push through the hole with a screw driver to release each side, and does it clip and push back in easily. Don't want to begin without being sure...you know what happens, it won't go back in and you drive around at xmas with it blowing in the wind!
  4. Hi wondering if anyone could give me some advice as to the problem I've recently put the wrong fuel in ie high octane on my 02 reg fiesta and is now misfiring I think it may have blown a spark plug I'm wondering if anyone could confirm or give me any of cause or advice to what it is or to resolve
  5. Hoping for a little help; after 6 weeks in a petrol focus and an awful lot of customer service errors the garage changed my car for the above focus. It's a 15 plate so 6 months old, ex demo and has the appearance pack (I believe is the tinted windows) I'm clearly paying a bit more for it than the petrol (£15,150 vs the £12,950 petrol) which was a 64 plate eco boost navigator. Anyhow I've noticed a couple of things that I'm unclear on..... It has auto headlamps and yet the auto high beam feature appears to be not working or is missing? - on the steering wheel computer I go to settings and where lighting is the auto high beam is not listed. (And it doesn't work on a test at night unlit road etc....) It also has ambient lighting but the overhead console is missing the controls for changing the colour.... Again on the computer I can turn this feature off and on but I thought if I have ambient I can also control the colour etc.... And I also came across a thing about the car having a parking camera as standard on the titanium? I've got auto parking and sensors back and front but no camera? Is this right?? Really hoping someone is out there who is an expert on the titanium and can offer some advice? I'm really not keen on complaining (yet again) but it feel that since I am paying for all this I should have it!? And I'd like to go in armed with the correct info -and not end up looking like a tit! :) The car also has press button start (but oddly not keyless entry-odd I thought as the fiesta has this!) and cruise control and rain sensitive wipers. (All of which work fine....) Thanks for reading :) New to ford but loving the car despite all the issues so far!! Leanne
  6. Hi My high level brake light lens and lamp holder has fallen out, and dangles by the wire. I've taken off the internal trim, but can't see how the lens and holder are supposed to stay / be fixed into the recess. Are there clips, missing, which hold the fitting in place? Thanks Bruce
  7. 20150519 125833

    From the album ST 2

    Just Fittet my new Mountune High Flow Induction Hose
  8. Reached 120,000 Miles. What Now?

    My MK 6 Fiesta has served me well on my 70 mile round trip to work. But I have now managed 120,000 miles on a 9 year old car and am wondering how much more I will get out of the 1.25 engine. I get a small service ever year- it had a major service when i bought it two years ago, and I mainl do motorway miles in 5th gear. So realistically how many more miles can i expect from the little engine? It only had one owner before I bought it and was regurlarly serviced. Only issues have been thermostat replaced and recently It feels like it starts to lurch a little as i accelerate (could that be a coil pack issue) Other than that mpg is pretty good and the car still drives fine. Also, will the cambelt be due again soon, it was just done before I bought it at around 70,000 miles I think, what age / mileage would it next be due on a 1.25 fiesta zetec? Any advice greatly appreciated. Thanks
  9. Revs Hunting 2000-2500

    In need of some help please My ford focus 2003 1.6 zetec SE has developed a problem. Started of last year in the winter when car suddenly woudnt start but after many atemps started eventually. But ever since revs have been hunting between 2000-2500. It also appears to have lost power in that band range. Also fuel consumption higher too as this was confirm when the car was close to failing emissions test as it had high reading. I have since replaced throttlebody and idle control sensor. Also the vacuum hose at the intake with a new one. Dont what to keep replacing stuff. Thats why i need help Btw idle is fine when cold or warm, the problem is band specific
  10. Hi today my alternator caught on fire. I had some issues before, when driving in hot day London traffic felt burning smell. After inspecting noticed wires in alternator had plastic melted. Next day I went to a garage and they tested my alternators voltage which was to high. Engineer told me that alternator is faulty and will pack up soon. Which it did today (after 8 months). I did get a new alternator and fitted today, but when I tested it had 16V on idle and 15.7 with lights and con on. My mondeo have a heated seats, factory fitted xenon lights, and so on. After running for about 3mins it started smelling burn again and alternator is to hot to touch. What could be a reasons of that? Please help
  11. About a month ago my wife's 05 Focus 2.0 TDCi wouldn't start one morning and our local Ford garage changed the fuel filter and they stated that there was evidence of filings in the housing which could lead to the high pressure pump failing. Sure enough it cut out on her last week. I've sourced a pump and I'm halfway through fitting it and I'm slightly worried about what I've seen in the engine block.... The cavity that the pump fills doesn't seem to have anything there for the pump shaft to engage with, pump shaft being about 1.5" wide and 0.5" high... The pump is a Siemens... Is this normal?... Can I just install the pump as is or should there be something in the cavity to engage... Also found out that the 2.0 TDCi is notoriously difficult to get going again... Any tips? Thanks in advance...
  12. Latest news from the BBC - For various reasons insurance is too high (tell us something we don't know:) - http://www.bbc.co.uk/news/business-25403673 Also, the price comparison sites charge insurance companies to use them, then insist they can not offer the same product at a lower price elsewhere.
  13. Hey guys :) Another question about lowering. I have already searched and have not found what I am looking for. I have springs in at the moment f 60mm rear 50mm. I installed these after removing the eibach pro kit which was only f 40mm r 30mm, as I wanted it lower. But I still have this ugly !Removed! higher rear so you have that slanted look, it is aesthetically horrible :( so I have left in my rear eibach springs to be compressed 50mm so in theory this should be 80mm and I hope this evens out the difference as it looks off as well as chews the front tyres something serious. I found this the cheaper option as it's only £70 as opposed to £630 for coilovers :o . The lady said they may struggle to get as low as that extra 50mm due to the heat needed etc but I thought it was worth a try. Do any of you guys have, or have had similar issues? specially going for as low as I am. I am not concerned with handling more show car look, it sits evenly all around with about 15-20mm above the tyre around. Many thanks, Timmy :)
  14. Hi There!

    Hi all, I am currently driving in a 1.3 Fiesta Finesse which I have had for just over a year and I'm just looking for some advice on things to do to my fiesta to make look a bit cooler and general up keeping of my wee ford. Thanks for reading!
  15. Mk1 1.8 Tdci Power Problem

    Hi everyone, First post here So I'm having a problem with my 2003 focus tdci (115ps). Basically it loses power at high rpm. In first gear it revs to redline no problem with plenty of power. In second gear it loses its power at about 4000 rpm, third gear at ~3200 rpm, and so on. It has perfect power to these rpm's, and then it can only slowly creep up to redline. I can't find anything online that I haven't tried already. Here are the things that I have done: -Checked turbo shaft, no play -Full service last week; air, oil, fuel filters done, oil change -EGR blanked, made no difference except for quicker throttle response -Cleaned MAF sensor -Checked hoses, new silicone hoses put in last week -Cleaned out air intake hoses and intercooler -No warning lights ever come on I hope someone here can help me :-) Thanks! Cian
  16. Focus 2001 1600

    Hi, I'm new to this this. Looking for advice. My focus is revving really high in 1st and 2nd gear. The engine is rattling too. If I get into 3rd gear the revs go back down to 2000. It has lost power on a few occasions. When this happens I have to switch the engine off and wait a few minutes. Any suggestions please? I have read that it could be the tpc, I have no idea though. Thanks x
  17. Ford Focus Mk2 Alternator Problem

    MY FOCUS MK2 , WHILE DRIVING CAR YESTERDAY, BATTERY LAMP ON, FRONT SCREEN AND REAR SCREEN HEATERS START WORKING AND HAND BRAKE LAMP GONE ON IN DASH, I STOP THE CAR AND START IT AGAIN AND LOOK BATTERY FROM DASH , IT WAS AROUND 16.5 CHARCHING AND I PULL OUT CHARCING CABLE , AND DRIVE MY CAR 50KM TO MY HOME, BUT THERE WAS NO BATTERY LIGHT IN DASH WHEN I PULL OFF CHARCING CABLE FROM ALTERNATOR , THEN I BUY TWO WORKING ALTERNATORS FOR MY CAR AND I TRY BOTH OF THEM ON CAR, BUT THEY ARE SAME , THEY ARE CHARCING HIGH :( WHAT IS THE PROBLEM WHERE IS IT ??? I LOOK ALL CABLE FROM BATTERY TO ALTERNATOR , THEY ARE IN GOOD CONDITION, IS THERE ANY PROBLEM WITH FUSE BOX ??? OR ANY PROBLEM WITH PCM SOCKET ???
  18. Hello, I'm finding i've had a bit of an annoyance when I happen to be in too high a gear for the current revs. If I for example, change to third gear maybe 3-4 seconds too early, and likewise in all gears, I hear quite a high pitched squeek that sounds a bit like a none-oiled cog turning. The noise seems to come from drivers side but I can't work out if it's infront of me or behind me. It's annoying me loads, any ideas? Paul