AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Search the Community

Showing results for tags 'forums/wrong+oil'.

Found 4 results

  1. After a few miles the water hose coming from behind the engine feels very warm,but not hot,whilst the hose that fits into the water pump only feels warm,and the water in the expansion tank is cold...what is the problem...I have been chuffed with my 2002 2.0 tdci 130 zetec estate which is 500 miles off 200,000,it has served me very well as a work horse.
  2. Wrong Oil?

    I was yesterday at the mechanics to replace the oil and filter. He told me that he have Ford oil, not to worry. I thought as I already talked to him before that he has Motorcraft or Ford oil but ... I come back and he gives me rest of a 5L Total Quartz 9000 oil (5W-40). Well, how?! It is this oil: http://www.totaloil.com.au/Pages/content/NT0000C302.pdf Oil is for Citroen, Peugeot, BMW ... but no for Ford and it does not say that it'sunder the specification WSS-M2C913-B, but only ACEA A3/B4, and Ford bible says: If you are unable to find an oil that meets the specification defined by WSS-M2C913-B, you must use SAE 5W-30 (preferred), SAE 5W-40 (except Flexfuel vehicles) or SAE 10W-40 that meets the specification defined by either ACEA A1/B1 (preferred) or ACEA A3/B3. Using these oils can result in longer engine cranking periods, reduced engine performance, reduced fuel economy and increased emission levels.What do you think? Should I remove this oil out and change proper oil?
  3. Hi There!

    Hi all, I am currently driving in a 1.3 Fiesta Finesse which I have had for just over a year and I'm just looking for some advice on things to do to my fiesta to make look a bit cooler and general up keeping of my wee ford. Thanks for reading!