• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Search the Community

Showing results for tags 'slipping'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Ford Owners Club
    • Review your Ford
    • Discount Scheme
    • New Member Introductions
    • Was it you!? FOC Members Spotted!
    • General Ford Related Discussions
    • General Chat
    • Ford Guides
    • Show off your motor!
    • Car Insurance Discussions
  • Ford Models
    • Ford Fiesta Club
    • Ford Focus Club
    • Ford Mondeo / Vignale Club
    • Ford Mustang Club
    • Ford KA / StreetKA Club
    • Ford Kuga Club
    • Ford Edge Club
    • Ford B-Max Club
    • Ford C-Max Club
    • Ford S-Max Club
    • Ford Galaxy Club
    • Ford EcoSport Club
    • Ford Fusion Club
    • Ford Puma Club
    • Ford Escort Club
    • Ford Sierra Club
    • Classic Ford
    • Ford Transit Club
    • Ford Ranger Club
  • Buy & Sell
    • Club Cars For Sale
    • Ford Parts For Sale
    • Classifieds
    • General Items (Non Ford Related)
    • Wanted
    • eBay Finds
    • Buy & Sell Archive
  • Traders
    • Visit Owners Club Insurance Page
    • Opie Oils
    • Mountune
    • Burton Power
    • Puma Speed
    • Revo
    • Advertise Here
  • Ford Modifications and Projects
    • mountune Discussions
    • Photoshopped Ford Photos
    • Ford Project and Build Threads
    • Ford Modification Discussions
  • General Forums
    • Ford Owners Club Meets & Regional Discussion
    • Maintenance / Servicing / MOT Discussions
    • Dealer Problems & Consumer Advice
    • Technical Knowledge
    • Wheels & Tyres
    • Detailing your Ford
    • Audio & Electronics
    • General Site Requests
    • Computing, Gaming and Geeky
    • Dash Cam Videos
    • Ford Motorsport
  • Back Office
  • Ford How-To Guides

Categories

  • Ford Reviews
  • General Ford Guides - Modern Fords
  • Ford Fiesta Guides
  • Ford Buyers Guides
  • Ford Focus Guides
  • Ford Fusion Guides
  • Ford C-Max Guides
  • Ford S-Max Guides
  • Ford Ka Guides
  • Ford Mondeo Guides
  • Ford Kuga Guides
  • Ford Galaxy Guides
  • Ford Puma Guides
  • Ford Escort Guides

Calendars

  • Community Calendar

Categories

  • Articles

Found 4 results

  1. Hi, I just replaced my cam belt and turned the engine over, it started up fine, then the top part stopped spinning, but the bottom half was turning fine. If anyone with any sort of knowledge know about this I would soo grateful, Thank for your time, Glen
  2. Fiesta Clutch Pedal Issue

    Hey guys just wanted to share this with you all. I have a Ford fiesta 2005 MK VI and recently my clutch pedal started to click, sometimes it would be fine and other times pedal went straight to floor. So I had it recovered to my local garage, and was told it is a common problem and was told to buy a clip from Ford, cost less than 50p. The garage fitted it for free as i'm a regular but guess what it didn't last 5 days, the clip failed. Again recovered to garage when they checked this time the shaft or connecting rod for the master cylinder had slightly worn hence the clip had come off, honestly this clip looked like it was made from tin foil it was that thin, you could shave with it that's how thin it was. I was then told that a hefty bill was expected as master cylinder and pedal assembly would have to be changed, I left to sulk and see if I can source parts myself thus reducing the bill, amazingly I found a seller on Ebay selling a clip, more like a locking ring that fits on the end of the shaft where the pedal attaches and bingo!!! it has only sorted the problem out for good, so far been on my car for around 5 weeks and still everything ok, im using the same clutch master cylinder and pedal and it cost less than £20 and best of all I fitted it myself in under 10 mins although it was a pain to get to. Just thought id share this with you folks I will send link here if it will allow me. I tried pasting link guess it wont allow me, but if you type on the search bar in ebay "ford fiesta pedal clip" it will pop up you get an allen key and washer and the ring. I hope this helps you guys.
  3. Hi, Don't no of I'm in the right section but just need little bit of advice. My brake fluid was dropping about 6 months ago. After realising what it was and topping it up during this time I've now had the master cylinder changed. Now, 2 days after, the clutch started to feel strange and was slipping a lot. Had to rev really high to get a slight movement. Now it wil not move at all and I can select any gear and release the clutch fully with accelerating at all. Would just like to know if anybody knows exactly the problem before I take it back to the garage. Cheers, Jamie
  4. HI All After purchasing a ford mondeo (54 plate) with an 5 speed triptronic automatic box, all dose not seem to be going well. I have trawled through everything about the automatic 5 speed JACTO box on the net but they seem rarer than blue steak, and unfortunitly people knowing how to fix them without saying just put a new box in even rarer. The problem is as follows. normal driving seams fine changes up and down without issue. foot down it goes like stink. However travailing at 60mph on the motorway it will be 2K revs (no gear change) slight increase in throttle and the revs will increase to 2.5K (even jammed in 5th so no gear change) and a boot full will instantaneously rise to 3K with a slight audible whistling noise under bonnet. which can get rather annoying. I have checked the following. box oil level - ok bottle of stop slip added - did nothing checked all wiring and connectors seam ok. TC stall test 2,300rpm - I have been told this is correct and shows the box and TC is ok from what I understand the issue seems to be the torque converter is not locking up but cannot find were the solonide is or if its electronic or vacume operated. (no vac pipes go to the gear box) getting rater stuck with this one if anybody has any Ideas i would be great full