Jump to content


Photo

any mechanics about focus 1.6 zetec


  • Please log in to reply
4 replies to this topic

#1 scouser15373

scouser15373

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: focus
  • Location:

Posted 10 July 2008 - 04:18 PM

03 1.6 zetec

engine emission light has just started coming on

speedo , rev counter, jst all of a sudden go to zero then back to whatever the speed is and the rev's

car drives normal

cheers for any help

Have something to contribute?

Sign in or register to start a topic...

#2 old cruiser

old cruiser

    Settling In Well

  • New Member
  • PipPipPip
  • 94 posts
  • Ford Model: wife's 2006 Fiesta 1.25 [Climate]

Posted 10 July 2008 - 06:31 PM

03 1.6 zetec

engine emission light has just started coming on

speedo , rev counter, jst all of a sudden go to zero then back to whatever the speed is and the rev's

car drives normal

cheers for any help

I wonder if this is the dodgy dashboard PCB? Have a look on BBC Watchdog site and look for the Focus issue , this I think is it; http://www.bbc.co.uk..._20080414.shtml
Cheers Pete

#3 scouser15373

scouser15373

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: focus
  • Location:

Posted 10 July 2008 - 09:23 PM

I wonder if this is the dodgy dashboard PCB? Have a look on BBC Watchdog site and look for the Focus issue , this I think is it; http://www.bbc.co.uk..._20080414.shtml
Cheers Pete




cheers for that, ive booked it in next week i'll see what they say when it gets put on the compoutor

#4 the controller

the controller

    Settling In Well

  • New Member
  • PipPipPip
  • 65 posts
  • Ford Model: mondeo

Posted 11 July 2008 - 08:08 AM

cheers for that, ive booked it in next week i'll see what they say when it gets put on the compoutor

Hi mate this will be the vehicle speed sensor located in the gearbox, any Ford dealer can confirm with IDS, very common. Replaced many in my time.

#5 scouser15373

scouser15373

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: focus
  • Location:

Posted 16 July 2008 - 09:09 PM

just an update for anyone interested

its the instrument panal completeely gone !Removed! up

feller in fords is getting me a new one for 50 and going to fit it for 40

happy days , sick of going past speed cams doing about 0.2 mph


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users