Jump to content


Show
Photo

Turbo On 2Liter Tdci 54Plate Not Cuttin In


  • Please log in to reply
3 replies to this topic

#1 davd

davd

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: mondeo

Posted 18 February 2010 - 06:26 PM

turbos not cutting in at required revs!!!!it just starts smoking,,its done 70 000 odd miles !!!!has any 1 had similiar problems with this engine????need some advice to rectify the problem!!!could it be sumthing else???like a sensor or sumthing else,,,dont really know where to start and i dont wnna be ripped off by the dealers!!!!i have had diesels in the past that have done far greater milege with no problems with regards to the turbo!!!the car still drive ,,,but i gtta avoid puttin my foot down,,as the smoke starts to billow out,,,plz plz help!!!!!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 chris bowman

chris bowman

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 255 posts
  • Ford Model: ford mondeo 2.0lx tdci 115

Posted 19 February 2010 - 12:48 AM

turbos not cutting in at required revs!!!!it just starts smoking,,its done 70 000 odd miles !!!!has any 1 had similiar problems with this engine????need some advice to rectify the problem!!!could it be sumthing else???like a sensor or sumthing else,,,dont really know where to start and i dont wnna be ripped off by the dealers!!!!i have had diesels in the past that have done far greater milege with no problems with regards to the turbo!!!the car still drive ,,,but i gtta avoid puttin my foot down,,as the smoke starts to billow out,,,plz plz help!!!!!



check the email ive sent u mate

#3 tony b

tony b

    Member

  • New Member
  • PipPip
  • 16 posts
  • Ford Model: mondeo 2.0 tdci 2003
  • Location:

Posted 11 May 2011 - 09:10 AM

check the email ive sent u mate

seems similiar problem that i have, will start and drive but accelerate it smokes v badly and turbo seems to kick in at 2700rpm.

#4 davd

davd

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: mondeo

Posted 15 May 2011 - 09:50 PM

seems similiar problem that i have, will start and drive but accelerate it smokes v badly and turbo seems to kick in at 2700rpm.

ok if its smoking ,check your intercooler pipe , might be split thus causing the loss of power and smoke,,the pipe is located to the left of the radiator, and goes down parallel to the rad!
if it aint that or you cant find no splits then get your erg valve cheked, its probably clogged up,,get it taken off and cleaned with petrol,,dip it in petrol and clean it up properly!
if its not that then might be a turbo problem ,sometimes they start playing up etc ,it could be the fins are stiking??
good way to chek is to drive the motor and have the window down and wen the turbo cuts in at about 2000revs you can hear it,,,,if its making a clattery noise that means your turbos playing up,
if youve got a glow plug light on the dash that is flashing or a engine management lite flashing ,get the code read from a code reader,,some bak street mechanics do have them and then get bak to me with the codes or just look them up on the net!!

david


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users