Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
billyboggins

radio died when removed

5 posts in this topic

hi,took old radio out and replaced with new unit.aaaaaagh!!! fittings at back are different to old radio.when i took old radio out of dash message came up 1 hour.any idea what this means .old radio is as fitted to focus is 5000 rds eon new radio is ford 6000 cd rds eon.help please old radio now dead after putting back in car :angry:by the way i've checked the fuse and its ok...but i didn't remove battery terminal before i started this game!! new to car and didn't want to mess up locking etc

Share this post


Link to post
Share on other sites
 

Make sure that tjhe security panel is located correctly, this is the panel with the preset buttons 2-5 on it, remove it and clean the contacts and re-fit.

Share this post


Link to post
Share on other sites

Make sure that tjhe security panel is located correctly, this is the panel with the preset buttons 2-5 on it, remove it and clean the contacts and re-fit.

The 1 hour bit is due to the unit being turned on with ignition off, it will allow the unit to be on for that 1 hour then it will turn off to save battery life.

Share this post


Link to post
Share on other sites
Make sure that tjhe security panel is located correctly, this is the panel with the preset buttons 2-5 on it, remove it and clean the contacts and re-fit.

The 1 hour bit is due to the unit being turned on with ignition off, it will allow the unit to be on for that 1 hour then it will turn off to save battery life.

Share this post


Link to post
Share on other sites

found out what the problem is...the "new" unit that i bought off ebay blows the fuse when i connect it up..just goes to show that there is no such thing as a free lunch..thks for you advice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0