Jump to content


Interesting Pedal Problem - 2005 Fiesta Finesse

  • Please log in to reply
1 reply to this topic

#1 charlycoates



  • New Member
  • Pip
  • 1 posts
  • Ford Model: Fiesta

Posted 04 March 2010 - 11:42 PM

Hi all!

Just wondering if anyone can solve a little mystery for me!

I have a 2005 Fiesta Finesse and the pedals have gone a bit odd. I've already had the problem with the 'popping' clutch needing a clip to secure it so the clutch pedal can be engaged. This problem is a bit different. When driving along and changing gear, on releasing the clutch pedal there is a slight 'flick' in the brake / accelerator pedal, almost as if something is preventing the pedals from being pressed a little bit. I thought my shoes were catching on the other pedal at first!

It doesn't affect the drive (I hope), it doesn't do it all the time and I can still change gears but it is a bit worrying!

And yes I know I can take it to a garage but its 11.30pm and not even Kwik Break (sorry fit) don't open this late :s

Anyone had the same problem?


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,563 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 06 March 2010 - 10:12 PM

check around the pedal pivots points for any signs of binding or anything loose.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users