Jump to content


Photo

Stiff Steering


  • Please log in to reply
5 replies to this topic

#1 corbz9

corbz9

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: Mondeo Zetec S

Posted 06 March 2010 - 01:55 PM

Hi everyone im a fgoc virgin so be carefull with me :D can any one help me i recently bought my fifth mondeo its a 52 plate tdci Zetec S. When i bought it i asked to look at the test certificate as ya do and there were 3 adviseries on it but the only one that concerned me was one that said steering slightly rough and they are the exact words the guy at kwickfit where the car was tested had used anyway i took the car out for a testdrive and i noticed that when you were driving in a straight line and then you come to move the steering wheel it is slightly stiff like something is sticking i have been told this could be a number of things includeing the steering rack and the pump i just wanted to no if anyone else has experienced this problem and what was the solution i would be gratefull for your opions. thanks carl :)

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,808 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 06 March 2010 - 02:36 PM

Hi everyone im a fgoc virgin so be carefull with me :D can any one help me i recently bought my fifth mondeo its a 52 plate tdci Zetec S. When i bought it i asked to look at the test certificate as ya do and there were 3 adviseries on it but the only one that concerned me was one that said steering slightly rough and they are the exact words the guy at kwickfit where the car was tested had used anyway i took the car out for a testdrive and i noticed that when you were driving in a straight line and then you come to move the steering wheel it is slightly stiff like something is sticking i have been told this could be a number of things includeing the steering rack and the pump i just wanted to no if anyone else has experienced this problem and what was the solution i would be gratefull for your opions. thanks carl :)


i would start by looking at the cheapest part first, strut bearings. these may have seized or are just getting a bit worn/old.

#3 chris bowman

chris bowman

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 255 posts
  • Ford Model: ford mondeo 2.0lx tdci 115

Posted 06 March 2010 - 04:31 PM

always worth checking the obvious just incase the garage hasnt. though they should have.
tyre pressures, fluid level etc.

#4 L S Auto Repairs

L S Auto Repairs

    Settling In Well

  • New Member
  • PipPipPip
  • 57 posts
  • Ford Model: fiesta
  • Location: Hertfordshire

Posted 06 March 2010 - 07:39 PM

if the rack or pump are faulty you may have metal fillings in the PAS resvoir so check a sample of the fluid.

the UJ on the colunm could be slightly seized so remove and check all angles of movement.

top strut mount bearings could have broken up.

check them first and go from there

hope that helps

#5 corbz9

corbz9

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: Mondeo Zetec S

Posted 10 March 2010 - 01:29 PM

i would start by looking at the cheapest part first, strut bearings. these may have seized or are just getting a bit worn/old.

O.k cheers for that :D

#6 CAR PARTS EXPRESS

CAR PARTS EXPRESS

    Authorised Trader

  • New Member
  • PipPipPipPip
  • 448 posts
  • Ford Model: mondeo

Posted 10 March 2010 - 01:43 PM

I'm sure there is a tsb out for this involving a replacement bolt and grease on lower steering shaft...will get back shortly

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users