• Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


corbz9

Stiff Steering

Recommended Posts

Hi everyone im a fgoc virgin so be carefull with me :D can any one help me i recently bought my fifth mondeo its a 52 plate tdci Zetec S. When i bought it i asked to look at the test certificate as ya do and there were 3 adviseries on it but the only one that concerned me was one that said steering slightly rough and they are the exact words the guy at kwickfit where the car was tested had used anyway i took the car out for a testdrive and i noticed that when you were driving in a straight line and then you come to move the steering wheel it is slightly stiff like something is sticking i have been told this could be a number of things includeing the steering rack and the pump i just wanted to no if anyone else has experienced this problem and what was the solution i would be gratefull for your opions. thanks carl :)

Share this post


Link to post
Share on other sites
 

Hi everyone im a fgoc virgin so be carefull with me :D can any one help me i recently bought my fifth mondeo its a 52 plate tdci Zetec S. When i bought it i asked to look at the test certificate as ya do and there were 3 adviseries on it but the only one that concerned me was one that said steering slightly rough and they are the exact words the guy at kwickfit where the car was tested had used anyway i took the car out for a testdrive and i noticed that when you were driving in a straight line and then you come to move the steering wheel it is slightly stiff like something is sticking i have been told this could be a number of things includeing the steering rack and the pump i just wanted to no if anyone else has experienced this problem and what was the solution i would be gratefull for your opions. thanks carl :)

i would start by looking at the cheapest part first, strut bearings. these may have seized or are just getting a bit worn/old.

Share this post


Link to post
Share on other sites

always worth checking the obvious just incase the garage hasnt. though they should have.

tyre pressures, fluid level etc.

Share this post


Link to post
Share on other sites

if the rack or pump are faulty you may have metal fillings in the PAS resvoir so check a sample of the fluid.

the UJ on the colunm could be slightly seized so remove and check all angles of movement.

top strut mount bearings could have broken up.

check them first and go from there

hope that helps

Share this post


Link to post
Share on other sites

i would start by looking at the cheapest part first, strut bearings. these may have seized or are just getting a bit worn/old.

O.k cheers for that :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now