Jump to content


No Heat But It's Not The Control Valve

  • Please log in to reply
2 replies to this topic

#1 Nick B

Nick B


  • New Member
  • Pip
  • 1 posts
  • Ford Model: KA
  • Location: Cheshire

Posted 12 March 2010 - 08:50 PM


My daughter's heater started giving out as much heat as birthday cake candle. After some research and advice concluded it was the heater control valve as inlet pipes were getting hot outlet cold. Changed valve still the same, so suspect either an airlock or heater control knob not activating the valve.

Before I take the valve off again to check its operation can anyone advise if my assumptions are correct, and the best way to resolve any problem.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads



    Authorised Trader

  • New Member
  • PipPipPipPip
  • 448 posts
  • Ford Model: mondeo

Posted 13 March 2010 - 11:18 AM

try back flushing the matrix to see if theres a blockage....remove the 2 pipes, make sure heater selected to hot then get a hose pipe and flush in reverse i.e the pipe thats cold put the hose in that and the wate'should' come out the other pipe on the other side.

#3 Ford Own Rs Demons

Ford Own Rs Demons


  • New Member
  • PipPip
  • 27 posts
  • Ford Model: Cubboard is bear

Posted 20 March 2010 - 10:51 PM

Matrix ditto

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users