Jump to content


Photo
- - - - -

1.4 Tdci Power Loss


  • Please log in to reply
No replies to this topic

#1 bobd

bobd

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Fiesta 1.4 tdci
  • Location: Essex

Posted 17 March 2010 - 05:43 PM

My 52 plate 1.4 tdci is suffering from a major loss of power. It struggles to accelerate and sometimes struggles to get past 30. If you can get it past this and keep the revs up there seems to be a bit more power. It’s been back to the main dealers several times without success. They claim to have checked everything and could find nothing wrong, they do however acknowledge there’s a fault. They’ve changed the ERG valve despite saying it wasn’t at fault, still no better. They claim to have check the turbo, the fuel pressure and the MAF sensor all of which they think is OK. They claim the computer isn’t showing any faults. After the last visit an EAC message comes up intermittently. We’ve already spent over £400 without a fix and their latest suggestion, in conjunction with Ford Technical, is to replace the Engine Management Computer at a cost of £1200!!!!!! But they can’t guarantee a fix.

HELP

Does anyone have any suggestions on this apart from setting fire to it?

Thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users