• Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear

Sign in to follow this  
Followers 0

Crank Sensor And Ecu

1 post in this topic

hi guys

im new to the forum, basicly bought my ford focus 2000 1.6i zetec last week ran great then couple of days having the car it developed a missfire and ran really lumpy i changed the ht leads and coil pack and got new plugs and fuel filter even changed the lambda sensor on the exaust still ran exactly the same so decided to take it on the motorway to see if it would clear if i gave it a bit of a run then after cuming off the motorway i was driving home an the car just cut out and would not start so i got toad home and got a mobile mechanic out to it and they plugged the diagnostic machine in and it came up with nothing then he checked if there was a spark and there wasnt so he said that it could be crank sensor failing that the ECU . Any ideas any comments appreciated as im new to injection engines. and also is it possible to just go to a scrap yard and get an ecu of an exact same model and try that ?

thanks .

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0