Jump to content


Photo

3000 Radio Won't Switch On


  • Please log in to reply
1 reply to this topic

#1 jp1234

jp1234

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Fiesta

Posted 22 March 2010 - 06:32 PM

Hi All,

I've recently bought an older Fiesta Mk4 1.3 LX (1997 model) as a second car. All seems well except the stereo won't switch on.

From looking at the handbook I believe this is a 3000 model radio/cassette

With the car lights on the backlight comes on, and if the fascia panel is removed the light behind it flashes so the unit seems to be getting power but it doesn't switch on. Pressing the power button does nothing and inserting a tape likewise doesn't bring it to life.

I've managed to remove the head unit and the cabling appears to all be connected ok.

I've had a search of the forum and on the web but not found anything too much on this - any ideas greatly appreciated!

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,559 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 22 March 2010 - 07:50 PM

it could be that it is getting power from the perminant live but not from the ignition live, check all the power supply cables for power with a meter, the following site may help identify the wires.
http://www.tehnomaga...g-Connector.htm


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users