Jump to content


Show
Photo

Every Single Year!


  • Please log in to reply
2 replies to this topic

#1 bradwebb

bradwebb

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Focus 1.6 Zetec mk1

Posted 27 March 2010 - 01:35 PM

Hi Guys, New to the forum :rolleyes:

Basically, my dads 2001 1.6 Zetec Focus engine management light came on 4 years ago. He took it to a garage which diagnosed the fault as catalytic converter and replaced it.
4 weeks after the light came back on, but my dad stupidly ignored it
Every year since, my dad has paid 300-400 for a new catalytic converter for the annual mot (light still stays on)
He has just paid for his 4th which is a joke
Any ideas what could be the problem

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 27 March 2010 - 02:08 PM

sounds like you could have a faulty oxygen sensor, try and get the codes from the ecu.

#3 bottletree

bottletree

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 219 posts
  • Name: Shane
  • Ford Model: C-max 2.0litre. Ghia EST. 2005
  • Year: 2005
  • Location: Yorkshire

Posted 27 March 2010 - 03:16 PM

Could also be something as simple as static on a sensor. Which means there is no problem at all.400 a year to replace the cat. Surely if its a part fault then the warranty should cover it?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users