Jump to content


Photo

Glow plug & wiring issues


  • Please log in to reply
2 replies to this topic

#1 Gelfin

Gelfin

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: 1.8 TD 2000 model

Posted 03 August 2008 - 07:13 AM

Hi there I'm a new Mondeo owner having bought the car three months back. I have just had to replace the starter on my Mondeo and the Mech's said that I've got glow-plug issues and should see an electrician.
I was hoping that I could find some help here, since I don't know the problem areas of my car yet, and I'd love to know if there are any common problems that occur with regards the glow-plugs and power getting to them. It has been suggested that it could be an earthing problem, but is there anything else that I should look out for or that can help the diagnosis be less expensive for me.
Any help would be much appreciated,
G

Have something to contribute?

Sign in or register to start a topic...

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,456 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 03 August 2008 - 09:03 AM

first check that you have got battery voltage at the glow plugs if not it could be the 80amp fuse this has been known to crack so check carefully if the fuse is ok suspect the controller

#3 Gelfin

Gelfin

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: 1.8 TD 2000 model

Posted 05 August 2008 - 08:16 AM

Thanks, I'll check.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users