AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Daisyjo88

Engine Warning Light

4 posts in this topic

Hi guys, I need some advice about my Ford KA luxury.

A few months ago I had a problem with my car, which was my "clutch slipping." When my clutch started to slip it smelt bad and my engine warning light (in just a yellow) came on. So I left my car for a couple of days (at this time btw I didnt know this was my clutch.) So a few days later I took it up my road and the car broke down on me when it broke down the engine light started to flash and my car stunk of that clutch smell! I managed to drive it home in first gear haha. :P (At this point my engine light wasnt on.)

Luckily I managed to get my car fixed at a very good price, I also got my suspension fixed aswell!

And ever since then its been a really nice drive!

But... this weekend I drove down to Portsmouth from Essex to go to the I.O.W and the car was fine. Got the car off the boat and the engine light was on but driving the car felt fine. No noises or smells. I left the car for a day or two, then i switched the car back on, no warning light.... I drove the car back to the boat. And when I took the car off the boat the light was on in the yellow again, so I drove it all the way home without any problems, drove like normal.

I put the car on one night after I drove it and the light was still on.. do you think this is a major problem? and how can I get it checked out without having to pay loads as ive just paid out for it?

Im sorry this story is so long :blink:I need all the advice I can get!

thank you B)

Share this post


Link to post
Share on other sites
 

Sounds like O2 sensor. Around £40-£60 I think.

Don't quote me on this though!

Share this post


Link to post
Share on other sites

is the car rough on startup? does it misfire occasionally on cold mornings? chances are its your 02 sensor, they are dead easy to replace on a ka, but the part itself cost me £75, and then due to the unique way in which the ford electrical system works, you will have to plug in a computer to reset the dash light, i got this done for free at my garage though

a way you can also test for this is to run a self diagnostic on your car (only applies if you have a digital tachometer) get in the car and close the door, put the key in the ignition but dont turn yet, press and hold the mileometer reset button, now turn the ignition on, but do not start the car, keep holding for about 5 seconds and the dials will do a full sweep, release the button, you are now in diagnostics mode

press the button 5 more times and a code should appear, a letter followed by 4 numbers, make a note of that code

turn the ignition off to exit diagnostic mode

go to this website:

http://www.autodiagnos.com/fileadmin/assets/en/downloads/pdf/technical_bulletins/ford/ford_dtc.pdf

check out the code and see what it relates to

i just saved you £40 lol that is what the last garage charged me to run a diagnostics machine on the car

Share this post


Link to post
Share on other sites

Thanks guys. Very helpful! I will get this checked out!! It's so strange how it came on both times as soon as I drove it off the boat :-S strange car!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0