• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
bry50n

dash

2 posts in this topic

i have just bought a mondeo 20 tdci last week .when you are driving the speedo and rev counter stops working along with the heated rear and front sceen and the oil light comes on .but when you turn the engine off for a couple of mins and start it up again they all start working . does anyone have any idea what it could be

Share this post


Link to post
Share on other sites
 

a loose conection in your wiring loom behind your dash or a !Removed! fuse box connection start simple before making some thing a big deal good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0