Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


simonkit

Zetec 1.4 - coil pack - is this it ?

7 posts in this topic

Have problems with rough idling & a lit engine management light. I've changed the plugs & ignition leads but the problem remains & the guy at Ford told me if leads/plugs don't work that its the

"Coil pack" - Ford want £100 but I've found this, part number is identical to the one of the car...

is this what the Dealer meant by "Coil Pack" or is there something else to it ?

http://www.cranksensors.net/detailspage.as...earchStr=PC6280

Any help much appreciated

simon

Share this post


Link to post
Share on other sites
 

Have problems with rough idling & a lit engine management light. I've changed the plugs & ignition leads but the problem remains & the guy at Ford told me if leads/plugs don't work that its the

"Coil pack" - Ford want £100 but I've found this, part number is identical to the one of the car...

is this what the Dealer meant by "Coil Pack" or is there something else to it ?

http://www.cranksensors.net/detailspage.as...earchStr=PC6280

Any help much appreciated

simon

Hi

That is the coil pack.

Good luck!

Share this post


Link to post
Share on other sites
Hi

That is the coil pack.

Good luck!

Thanks for the reply....

problems solved...fitted new coil pack + ignition leads + spark plugs, disconnected battery for 30minutes & engine warning light fault cleared too !!!

Just on the coil pack don't get the Ford one..£110, I paid £40 from a local motor spares shop

simon

Share this post


Link to post
Share on other sites

Hi, new to this forum but like what i see,

my mate has a fiesta (1.4 zetec 2002) and one day it decided to die, i checked it out for him and it all pointed to the coil pack being dead, so as a matter of course new HT's new sparks and new coil all fitted nice and easy, now car will not fire, turns fine but refuses to burst into life.

I have checked leads are good, check sparks and spark guage, all good, all coil pack outleys fire fine, fuel seems to hit the rails fine, only thing i can think of is ecu is telling injectors not to fire since instlling the coil pack.

I noticed you had 30mins of batt discon, is this to reset the ecu and therefore re-energise the injectors???

checked feul pump & filter and the all gd so this is my last option i can think of, o and lambda and crank sensors are all gd.

thanks in advance.

Share this post


Link to post
Share on other sites
Hi, new to this forum but like what i see,

my mate has a fiesta (1.4 zetec 2002) and one day it decided to die, i checked it out for him and it all pointed to the coil pack being dead, so as a matter of course new HT's new sparks and new coil all fitted nice and easy, now car will not fire, turns fine but refuses to burst into life.

I have checked leads are good, check sparks and spark guage, all good, all coil pack outleys fire fine, fuel seems to hit the rails fine, only thing i can think of is ecu is telling injectors not to fire since instlling the coil pack.

I noticed you had 30mins of batt discon, is this to reset the ecu and therefore re-energise the injectors???

checked feul pump & filter and the all gd so this is my last option i can think of, o and lambda and crank sensors are all gd.

thanks in advance.

Having posted that I'd sorted the problem I'm now not 100% sure I have....

To recap on the problem..

Fiesta 1.4 2004

It suddenly started run rough & engine warning light came on, called RAC who said it showed a fault on CYL 4. Turned out to be coil failure so I replaced coil/spark plugs & ignition leads & whilst it's much better it now seems slightly hesitant during acceleration sometimes..

my thoughts are maybe the fuel filter or the MAF / Lamba sensor have been affected by the coil failing ?

All advice appreciated

simon

Share this post


Link to post
Share on other sites

Hi, new to this forum but like what i see,

my mate has a fiesta (1.4 zetec 2002) and one day it decided to die, i checked it out for him and it all pointed to the coil pack being dead, so as a matter of course new HT's new sparks and new coil all fitted nice and easy, now car will not fire, turns fine but refuses to burst into life.

I have checked leads are good, check sparks and spark guage, all good, all coil pack outleys fire fine, fuel seems to hit the rails fine, only thing i can think of is ecu is telling injectors not to fire since instlling the coil pack.

I noticed you had 30mins of batt discon, is this to reset the ecu and therefore re-energise the injectors???

checked feul pump & filter and the all gd so this is my last option i can think of, o and lambda and crank sensors are all gd.

thanks in advance.

Share this post


Link to post
Share on other sites

Change plugs but change gap to1 mm not the standard 1.3 mm seems over time the plugs set at 1.3 mm can cause coil failure...you may need to change coil as well....secret given to me by ford mechanic... Worked for me ..good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now