Jump to content


Photo

Radio Problems


  • Please log in to reply
4 replies to this topic

#1 Helmil13

Helmil13

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Galaxy

Posted 09 April 2010 - 03:23 PM

The radio in my friends R reg Galaxy has stopped working, there seems to be no power going to the radio.

I've checked the fuses under the steering column and the one in the back of the stereo and none of them have blown. All the leads in the back of the stereo are in fully but that doesn't seem to be the problem. It is the original factory fitted stereo which hasn't had any problems before. Everything else in the dashboard is working fine.

Does anyone have any ideas as to how to fix this? Please help!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 09 April 2010 - 07:11 PM

if you can check that you have voltage at the radio fuse with a test meter.

#3 popeye007

popeye007

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: russell
  • Ford Model: galaxy
  • Year: 2007
  • Location: Lancashire

Posted 21 July 2014 - 08:40 AM

radio

#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,754 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 22 July 2014 - 02:12 PM

radio

Im sorry? what do you mean?



#5 gregers

gregers

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 728 posts
  • Name: greg
  • Ford Model: smax titainium
  • Year: 2008
  • Location: Sussex

Posted 22 July 2014 - 09:06 PM

ga ga. :rolleyes:




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users