Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Sign in to follow this  
Followers 0
fontaine

FOCUS PROBLEMS

5 posts in this topic

hi

ive just bought a focus estate 1999

i am happy with it but have a few small problems

whilst braking the brake lights come on ok but the front lights also come on, but then the front lights go off when i take my foot off the pedal this is while driving in the day obviously makes no difference at night, also when this happens in the day the instrument back lighting also comes on whilst pressing brake pedal

does anyone know what causes this

also when i switch engine on the needless on instrument cluster do a full sweep and then return to normal

also when engine i s cold it idles fast because of the auto choke but when car is at operating temperature it idles when you are statinary at about 750 rpm but is not smooth at idling but is fine when you accelerate

any ideas? th

i like the car and was astonished when i first drove it at the acceleration for a 1.6

does anyone know where to get a cheap ford cd player for my focus

Share this post


Link to post
Share on other sites
 

the light problem sometimes occures when a brake light filament is broke and shorting on the sidelight in the brake bulb so try replacment brake bulbs the idal problem could be the idle controlle valve requires cleaning or the speed sensor playing up

Share this post


Link to post
Share on other sites
the light problem sometimes occures when a brake light filament is broke and shorting on the sidelight in the brake bulb so try replacment brake bulbs the idal problem could be the idle controlle valve requires cleaning or the speed sensor playing up

cheers mate your diagnosis with the light problem was spot on

problem now fixed

also the dial and idling problem was due to a bad earth contact

thanks again

Share this post


Link to post
Share on other sites

hi fontaine, could I just ask where this bad contact was? It may help with a problem i have with the dash

cheers, john

Share this post


Link to post
Share on other sites
hi fontaine, could I just ask where this bad contact was? It may help with a problem i have with the dash

cheers, john

hi john

the bad contact was onthe battery

i took off the battery cover and noticed that the connections on the battery had some corrossio on the termonals

i cleaned these off with a wire brush, both battery terminals and the wies to the terminals and reconnected and coated the terminals in petroleum jelly

works fine now

some say the needle sweep on startup is due to a knackered battery, but in my case it was simply a matter of cleaning it up to factory standard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0