Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Sign in to follow this  
Followers 0
marksell

Ford Puma 1.7 Temp Gauge & Coolant Fan Not Working

2 posts in this topic

I have a ford puma 1998 1.7

the temp gauge on the dash does not work or recognise any heat at all. whenyou turn the ignition on it moves from off the bottom, to the bottom of the gauge (hope you know what i mean there) but it never movesd from that point, meaning it is not recognising any heat right?

the coolant fan does not 'kick' in either when it is getting hot (temp gauge still not moved anyway)

Does anyone know what the problem may be??

it seems to run ok without a problem and i have had the temp switch changed which has done precisiely nothing!

any help or ideas would be very grateful!

Share this post


Link to post
Share on other sites
 

when you say the temp switch do you mean the sender unit on the thermostat housing? as this is normally the problem with the symptoms your getting.it could be a wiring fault from the sender also check the fuses for the fan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0