Jump to content


Photo

Galaxy 1995 2 Litre Emission Fail


  • Please log in to reply
2 replies to this topic

#1 narbar

narbar

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: galaxy

Posted 12 May 2010 - 07:18 PM

Hi, i have a 1995 ford galaxy with the 2 litre engine, its failed its mot on the emmisions and im not sure why. I think this may have something to do with it, the cars temperature never goes very high at all and always stays low and the cars heater blowers never seem to be very hot. I was just wondering if there was anything that would cause these and also effect the emmisions? What do you guys think it could be? thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,794 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 12 May 2010 - 07:49 PM

Hi, i have a 1995 ford galaxy with the 2 litre engine, its failed its mot on the emmisions and im not sure why. I think this may have something to do with it, the cars temperature never goes very high at all and always stays low and the cars heater blowers never seem to be very hot. I was just wondering if there was anything that would cause these and also effect the emmisions? What do you guys think it could be? thanks


have you got a print out of the emmisions test?

#3 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,551 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 12 May 2010 - 08:47 PM

could be thermostat playing up.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users