• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Sign in to follow this  
Followers 0
blue oval

ESCORT ZETEC PROBLEMS

5 posts in this topic

hi all i need some help, i have a ford escort on a 96 on a p-plate zetec-e done just over 80k and over the past few months it has developed a problem, the problem is that wether revving it on the spot or when driving in any gear it gets to about 3500 revs and feels guttless as if it is misfiring or the timing is out, it used to pink when picking up from low revs which made me think that the timing is out(apparently this engine keeps the timing in check itself??) but this seems to have gone away and this other problem in its place

any help/advice would be appreciated

Share this post


Link to post
Share on other sites
 

get the timing checked to make sure it hasn't slipped a tooth as its getting close to cambelt renewall time,it could also be a high voltage breakdown (arching between plug connector and insulator)check for black marks to indicate any burning

Share this post


Link to post
Share on other sites
get the timing checked to make sure it hasn't slipped a tooth as its getting close to cambelt renewall time,it could also be a high voltage breakdown (arching between plug connector and insulator)check for black marks to indicate any burning

Thanks for that i done the cambelt myself last time but f**k doing it again will let a garage do it this time! do you suggest maybe replacing the ht leads?? and plugs or something else? again regards for any info

Share this post


Link to post
Share on other sites

when was the last cambelt change done if it wasn't tightened correctley it could easily jump a tooth, could you wip the covers of to check the timing marks

Share this post


Link to post
Share on other sites
when was the last cambelt change done if it wasn't tightened correctley it could easily jump a tooth, could you wip the covers of to check the timing marks

yeah i will then do you think that it could be the ht leads/plugs if they line up ? there is no smoke when it gets up to the area of the rev range that has the problems so hopefully the timing will be slightly out, thanks for your advice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0