Jump to content


Show
Photo

Advise Wanted On Tdci


  • Please log in to reply
1 reply to this topic

#1 mk3

mk3

    Member

  • New Member
  • PipPip
  • 17 posts
  • Ford Model: mondeo mk 3 tdci 130bhp

Posted 21 May 2010 - 09:41 AM

Hi , ive had several problems with my 02 mk3 mondeo tdci, ive had the cam shaft sensor, crank sensor , glow plugs and manifold gasket done after i broke down, its also been on 3/4 diagnostic machines but nothing as shown as being a problem.
when i start it up in a morning it runs lumpy with a growling tappit noise, its like having a choke on but as soon as its warm it runs fine , not lumpy or growing, my garage rekons its possibly injectors ,does anyone agree with this ?, if so if its not showing on a diagnostic machine what test should i have done to see if it is injectors.
Then do i go for refurbed injectors , any advice welcome...thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,464 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 21 May 2010 - 02:44 PM

the only way to test injectors is to have them removed and the spray patten and flow rate observed, see if there is a delphi agent close to your area as they are the experts.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users