Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
rosstalbot11

Battery Light And Oil Light Comes On Fiesta Cuts Out

2 posts in this topic

hi i have a mark 4 fiesta endura e engine 1.3 and some times when im droping speed the battery and oil comes on it doesnt always cut the engine out. but it does sometimes i just wounderd what could be corsing this problem.

Share this post


Link to post
Share on other sites
 

Hi, seems that the idle speed control valve is a common cause of this problem. Sometimes cleaning it can get you out of trouble, but it didn't work for me, I ended up getting one from a breakers. Luckily it was a good one and it cured my problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0