Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Zemich

Heated Front Screen Only Works In One Side

3 posts in this topic

Hi everyone

I've just bought a Ford Focus 1,6 TDCi from 2007.

Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.

They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.

It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.

But my question is, where is it connected?

Don't wanna go back to the dealer unless it is really necessary.

Hope some of you can help. :)

Share this post


Link to post
Share on other sites
 

Hi everyone

I've just bought a Ford Focus 1,6 TDCi from 2007.

Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.

They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.

It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.

But my question is, where is it connected?

Don't wanna go back to the dealer unless it is really necessary.

Hope some of you can help. :)

Hi,

Remaove both scuddle panels and there will be a wire at the bottome of the screen, that wire needs to br rerooted when fitting the screen to prevent this happening. Check all coneections are in, if so it could be a faulty screen. Is it a ford screen that was fitted? If so it will be warranty. But it sounds like they have forgot to reroot the connections! take it back to the dealer and they have to do it free of charge.

Share this post


Link to post
Share on other sites

Hi everyone

I've just bought a Ford Focus 1,6 TDCi from 2007.

Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.

They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.

It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.

But my question is, where is it connected?

Don't wanna go back to the dealer unless it is really necessary.

Hope some of you can help. :)

Mine was the same. Garage sent a guy out to fit a new windscreen. What had happened was the wiper arm linkage had torn the connector off on the drivers side. It needs to be routed above the linkage, which when mine had its last windscreen fitted wasn't!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0