Jump to content


Photo

Surging Problem And Strange Noise


  • Please log in to reply
9 replies to this topic

#1 sparky19620

sparky19620

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: mondoe 130bhp tdci

Posted 31 May 2010 - 07:10 AM

hi guy's
i took the car for a drive on friday and at 2500 revs i started to her what sounds like a rush of air from where i cannot pin point.its on the drivers side and only starts at 2500 revs and is there in every gear by the way.have driven to work this morning and noticed it was surging a little at around 75 -80 mph.i also noticed a bit of smoke from rear window that have never noticed before.if i stay below 2500 revs all seems ok..any ideas..?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 31 May 2010 - 01:58 PM

it could be the intercooler pipe from the egr valve(big pipe on the bottom)that has a split in it, this would give you the air escaping sound and black smoke.its a common fault on the tdci.

#3 sparky19620

sparky19620

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: mondoe 130bhp tdci

Posted 31 May 2010 - 03:21 PM

thanks for that found the hose split..easy enough to change to..cleaned egr as was just slightly dirty...just curious why do some block off the egr and what do they get by doing it

#4 tdci stevie

tdci stevie

    Settling In Well

  • New Member
  • PipPipPip
  • 79 posts
  • Ford Model: mk3 mondeo tdci ghia 130

Posted 01 June 2010 - 08:46 AM

thanks for that found the hose split..easy enough to change to..cleaned egr as was just slightly dirty...just curious why do some block off the egr and what do they get by doing it

Better performance have done it on my 04 TDCi 130, and its more responsive and less smokey when you floor it, i also had the split pipe must be a common fault on these engines, 55 plus v.a.t !Removed! expensive for a rubber pipe

#5 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 01 June 2010 - 12:31 PM

you can block an egr on a eoro 3 engine with no problems, but on the euro 4 engine it will put the eml light on after around 100 miles,if your egr has electrical connections on it,its a euro 4.

#6 sparky19620

sparky19620

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: mondoe 130bhp tdci

Posted 01 June 2010 - 05:33 PM

just checked and no electrical connection on the egr,do i have to have anything done after blanking egr off...am new to all this...but learning quickly

#7 tdci stevie

tdci stevie

    Settling In Well

  • New Member
  • PipPipPip
  • 79 posts
  • Ford Model: mk3 mondeo tdci ghia 130

Posted 01 June 2010 - 05:41 PM

just checked and no electrical connection on the egr,do i have to have anything done after blanking egr off...am new to all this...but learning quickly

No just blank it off and stick a ball bearing or plastic bead in the small vaccum pipe that goes in top of EGR and your away mate

#8 sparky19620

sparky19620

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: mondoe 130bhp tdci

Posted 01 June 2010 - 06:19 PM

cheers mate will give it a go and see what happens

#9 willsh

willsh

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: mondeo tdci 130

Posted 04 June 2010 - 05:12 PM

so if you have the connecter and plug on your egr you cant blank it off :(

#10 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 04 June 2010 - 10:01 PM

as said before you can blank it off but it will put eml light on at around 100 miles later due to 'egr lack of air flow'

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users