Jump to content


Photo

Surging Duratorq Diesel


  • Please log in to reply
6 replies to this topic

#1 serious3

serious3

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: mondeo estate 2.0td

Posted 31 May 2010 - 09:58 PM

newbie here with a new to me 2001my 2.0 td (duratorq)TDDI love the thing to bits but its got a slight problem thats niggling at me.

when you hold a steady throttle in any gear it "surges/power fades in and out" if you are accelerating/slowing down it is nice and smooth. its just serviced at 93,000 and has full ford history to 83,000 miles. is it just a thing that the duratorq's do or is it a simple thing to get fixed?? thanks vince

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 serious3

serious3

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: mondeo estate 2.0td

Posted 08 June 2010 - 08:50 PM

just to update this subject its now started to hunt the revs when its idling. has anyone any idea what is causing the surging and now the hunting?

#3 Mondeoman

Mondeoman

    Settling In Well

  • New Member
  • PipPipPip
  • 75 posts
  • Ford Model: Mondeo Titanium X 2.2 TDCI

Posted 09 June 2010 - 01:57 PM

The info i got from this very forum is that it's a Duratorq quirk.. Mine only does it when my temp display is reading below 10 degrees,,,it drives perfectly when doing it, and is fine after a few minutes...Hope this helps....Bill

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,543 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 09 June 2010 - 07:15 PM

has the egr valve ever been cleaned?

#5 Mondeoman

Mondeoman

    Settling In Well

  • New Member
  • PipPipPip
  • 75 posts
  • Ford Model: Mondeo Titanium X 2.2 TDCI

Posted 10 June 2010 - 06:09 AM

Not to my knowledge. Is it worth doing ? Wouldn't it do it all the time regardless of temperature though ?

#6 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,543 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 10 June 2010 - 03:30 PM

if its never been done i would say yes, as a clogged egr or a split turbo hose often gives a surging problem,but only doing it below 10 deg is a puzzler.

#7 hondahornet

hondahornet

    Newbie

  • Members via FB
  • Pip
  • 1 posts
  • Name: mark
  • Ford Model: mondeo tddi
  • Year: 2002
  • Location: Lancashire

Posted 27 November 2013 - 07:43 PM

I have a tddi 02 87000 miles and I'm having the same problem blanked egr full service new throttle pedal and no change also some times when I start car hot or cold it makes a different noise if I let go of key when it is making this noise it wil run at 500rpm and sound like s--t then conk out second turn of key and it's fine.. when starting in a morning it sometimes revs up and down slightly

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users