AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
matle

Mystery Engine Problem 02 Focus

2 posts in this topic

My Ford Focus (1.6, 02 reg, Ghia) has some sort of engine problem. Symptoms:

1) Orange warning light (with picture of engine) on is lit up, then when I go up to higher revs (circa 2600+) for a reasonable length of time it settles into a steady flash. If i am going along the motorway it is flashing.

2) At low revs (sub 2500) it is sluggish and juddery as though it is really struggling, as far as I can tell this seems to be true of all the gears.

3) There are no visible leaks, the oil & water is at the required level. I have no problem starting it.

Anyone got any ideas??

From some prolonged googling it seems that it might be emissions related? But that wouldnt explain the 'sluggishness' at low revs...?

Share this post


Link to post
Share on other sites
 

the engine mag light lights up to show a problem with the engine,this is usually sensor related,you will need to get the fault codes read from the ecu to point you towards what the problem is,any local garage could do this for a reasonable cost.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0