Jump to content


Photo

Zetec 1.8I 16-V Problems


  • Please log in to reply
2 replies to this topic

#1 Ari

Ari

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Escort 1.8i 16-V

Posted 05 June 2010 - 02:27 PM

In Ford Escort 1.8i 16-v year model 1994, there came up a situation where 2 warning lights begun to light up, the Oil light and the Battery Light. It happened while the car was being turned right and while those lights were litting up, so the throttle was not responding at all. This all lasted maybe some seconds and then the function of the car was all right again.

What might be the problem? Is it related to a malfunction of MAF or what could possibly cause that problem and what kind of remedy to find to the situation.

All the replies would be appreciated!

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 regy_boy

regy_boy

    Member

  • New Member
  • PipPip
  • 18 posts
  • Ford Model: Escort Gti

Posted 06 June 2010 - 12:32 PM

hi has your steering gone really hard to turn if it has your fan belt has probably snapped and will need replacing hope that helps

#3 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 06 June 2010 - 01:09 PM

Hi

Have you checked the oil level?

And check the alternator to make sure its putting the correct charge into the battery

Then as said above, check all belts are present and correct

When you say the car dosn't respond, exactly what symptoms do you have and how does it behave?

And welcome to FOC


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users