Jump to content


Photo

Brakeing Or Steering Problem


  • Please log in to reply
3 replies to this topic

#1 pumba999

pumba999

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: escort mk6

Posted 07 June 2010 - 03:17 PM

Hello all.
If anyone can offer an accurate solution, I will be very grateful.
Ok, Ford Escort 1.4, N reg. On braking at 40 or above, the car pulls noticeably to the right; ease off the brake and it corrects itself. Was told it would be the brakes, which i have replaced without improvement. Had car down to locale garage to check the brakes on his brake machine and they are ok. Was told by him that the rack was stiff on one lock which we have replaced and still the same fault. We have had the rear bushes on the back axle replaced not so long ago. Then the problems with the front started we noticed that it had ware down the inside part of the tyres to the steel which we replaced and got the tracking done at the same time Tyre pressures are correct, Suspension Arms have been replaced last year for its test . Can anyone advise, please?
Thank you.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 07 June 2010 - 04:26 PM

I would say lower arms.

Did you replace them with genuine Ford arms?
Has it been lowered?
Has it got aftermarket wheels fitted?
Are tyre sizes the same?

#3 pumba999

pumba999

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: escort mk6

Posted 07 June 2010 - 05:35 PM

I would say lower arms.

Did you replace them with genuine Ford arms? yes
Has it been lowered? no
Has it got aftermarket wheels fitted? no/ford
Are tyre sizes the same? all tyres are 185/60 r14
been all right till fixed bushes on back axle as they were worn out and you could move axle tow and fro,



#4 lublin

lublin

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 101 posts
  • Ford Model: Escort Estate 1.6 16v . Built 14/11/95.

Posted 13 June 2010 - 03:31 PM

Did you have the tracking redone after the steering rack was replaced?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users