Jump to content


Show
Photo
- - - - -

2003 Fiesta Black seat tilt


  • Please log in to reply
5 replies to this topic

#1 Matt64

Matt64

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Fiesta Black
  • Location:

Posted 30 August 2008 - 07:44 PM

Hi, newbie here. I've just bought a 53 plate Fiesta Black. I'm tickled pink with it.
The drivers seat tilt mechanism to allow access to the rear seats isn't working. Does anyone know how to fix it?
Thanks.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Matt64

Matt64

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Fiesta Black
  • Location:

Posted 19 September 2008 - 06:48 PM

Bump

#3 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 September 2008 - 10:16 PM

you can try to push a screwdriver underneath (between the fabric and the plastic)either side of the lever at the top of the seat then plastic lever can be pulled from the top of the seat. If your lucky the lever has broken ,if not the plastic part which is attached to the cables is probably broken. I think this and the cable are all one piece,and you'll have to replace the cable mechanism. The lever on the top is about 14 from Fords.

#4 Rikos

Rikos

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 857 posts
  • Ford Model: Fiesta 1.4 LX

Posted 20 September 2008 - 10:55 AM

I'm tickled pink with it.


What does this mean?

Did you try the screwdriver idea mate how did you get on?

#5 Dannystewart

Dannystewart

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: mk6 fiesta black

Posted 20 September 2008 - 11:01 AM

fiesta black !! high 5 dude!! is there alot of free play or is ther tension when you pull it?? maybe the cable has gone ????

#6 Matt64

Matt64

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Fiesta Black
  • Location:

Posted 21 September 2008 - 06:15 PM

When I lift the lever there is no resistance. When lever is up I can see end of cable. Looks like a piece of the plastic on the lever is broken.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users