Jump to content


Speedo Failure

  • Please log in to reply
2 replies to this topic

#1 adam.s1991



  • New Member
  • Pip
  • 1 posts
  • Ford Model: Focus
  • Location: Essex

Posted 22 June 2010 - 12:00 AM

This happens quiet regulary, my speedo will cut out and sometimes switch between 0mph and the speed I'm actually doin, short after the traction will turn off and i won't be able to turn it down. Another this is while this is happening my car now and again will go really judery, doesn't feel nice at all. Also the music goes down???? Would appreciate help

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 C-Max Boy 1983

C-Max Boy 1983

    Area Rep: South Scotland

  • New Member
  • PipPipPipPip
  • 218 posts
  • Ford Model: C-Max Zetec 1.6 TDCI

Posted 22 June 2010 - 06:38 AM

Hi There,

This is a common problem with the focus, your problem is the VSS (Vehicle Speed Sensor) is on it's way out, my advice is to get to Ford as soon as and get this replaced.

Hope this is of help.

#3 SkaterStan



  • New Member
  • PipPip
  • 17 posts
  • Ford Model: Focus 1.4 Zetec

Posted 30 July 2010 - 03:29 PM

I second that. It is most definitely your Vehicle Speed Sensor. I had a lot of the same problems and changed the sensor last weekend and it's all been fine since. A new sensor cost me about 36 and you'll need the retaining pin also (2). Mine was a massive effort to get out, guess that's what 100,000 miles does to it! It's a simple procedure, just need a lot of patience!

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users