• Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


Sign in to follow this  
Followers 0
mothergoose

Fiesta problems

3 posts in this topic

I've got a Fiesta LX 1250 '04, I had it in the garage 2 weeks ago because the engine warning light was on and it was running very rough, they said it was misfiring on one of the cylinders, they put new plugs in and it's been fine, untill today that is, it felt as if it had no power and might stall, it wasn't as bad as before and the light didn't come on this time.

The thing is after the last time, I bought an RAC fault code reader, it's not showing any codes, but has a freeze frame logged with code P0130, the software that came with the code reader says that it's an 'O2 sensor circuit malfunction, bank 1 sensor 1'

Does anyone know exactly what this means? Any help at all will be appreciated.

I've only had the dam car 2 months :angry:

Share this post


Link to post
Share on other sites
 

I've got a Fiesta LX 1250 '04, I had it in the garage 2 weeks ago because the engine warning light was on and it was running very rough, they said it was misfiring on one of the cylinders, they put new plugs in and it's been fine, untill today that is, it felt as if it had no power and might stall, it wasn't as bad as before and the light didn't come on this time.

The thing is after the last time, I bought an RAC fault code reader, it's not showing any codes, but has a freeze frame logged with code P0130, the software that came with the code reader says that it's an 'O2 sensor circuit malfunction, bank 1 sensor 1'

Does anyone know exactly what this means? Any help at all will be appreciated.

I've only had the dam car 2 months :angry:

This is the sensor which is at the front of the engine which is inserted into the exhaust manifold.

more info from > http://www.rac.co.uk/web/forum/showthread.php?t=846

Share this post


Link to post
Share on other sites
I've got a Fiesta LX 1250 '04, I had it in the garage 2 weeks ago because the engine warning light was on and it was running very rough, they said it was misfiring on one of the cylinders, they put new plugs in and it's been fine, untill today that is, it felt as if it had no power and might stall, it wasn't as bad as before and the light didn't come on this time.

The thing is after the last time, I bought an RAC fault code reader, it's not showing any codes, but has a freeze frame logged with code P0130, the software that came with the code reader says that it's an 'O2 sensor circuit malfunction, bank 1 sensor 1'

Does anyone know exactly what this means? Any help at all will be appreciated.

I've only had the dam car 2 months :angry:

Sounds like the Lambda sensor to me, I'm a Alfa Romeo mechanic and half the cars that are running rough usually have faulty Lambda sensors. Not too pricey and quick and easy to replace. Good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0