Jump to content


Photo

S2 Rs Runnin Problems


  • Please log in to reply
1 reply to this topic

#1 D4NNY-B0Y

D4NNY-B0Y

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Escort rs turbo
  • Location: Kent

Posted 27 June 2010 - 06:07 PM

Alright, im new to this site, i currently own a series 2 rs turbo, but im having a few issues at the moment and wonder if i could have some advice,
when drivin once warmed up the engine cuts out? Also im getting alot of backfire n no boost what so ever! But it only happens everynow and then, but its not smoking (it does when backfire), ive bin told the coil could be on its last legs? have just replace spark plugs and doene a service to help to see if it would solve the problem but made no difference.

Im jus really puzzled lol

Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,559 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 28 June 2010 - 03:28 PM

if i remember there is a cold start valve on the back of the manifold,this may be sticking causing overfueling when warm, to check unplug the valve and try a test drive.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users