Jump to content


Show
Photo

St 200 Electric Problems


  • Please log in to reply
1 reply to this topic

#1 race0360

race0360

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: focus 2.0ltr
  • Location: West Midlands

Posted 01 July 2010 - 09:58 PM

I Have a ST200 Year 2000. At present I have major problems with electrics. First 3 garages have told me that the dianostic plug is not working. I have the handbrake warning light on constant. Brake level is full and handbrake switch ok. When you apply handbrake the warning light glows brighter. Some one has said it could be the float stuck in the bottom of the master cylinder. Disconnected wire from master cylinder stills stays on.

Also ABS and traction control not working. Warning light on dash comes on when you replace bulb but blows the bulb after about 30 mins, slowly gets dimmer and dimmer.Could this be the the box of electronic tricks on the back of ABS unit.

With out the dianostic plug working I am at a loss. I have removed dash and traced wires but none and broken or chaff through and all fuses have been replaced.

Can anybody point me in the right direction with out paying for an Auto electrian.

Thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 02 July 2010 - 03:04 PM

have you checked the abs sensors and rings for any signs of damage or rust?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users