Jump to content


Hi To All Fellow Members

  • Please log in to reply
3 replies to this topic

#1 ddsk



  • New Member
  • Pip
  • 5 posts
  • Ford Model: CMAX 1.8 TDCI 2005

Posted 06 July 2010 - 04:52 PM

I have had many different fords over the years ,I am currently driving CMAX 1.8TDCI 2005 (55) PANTHER BLACK. I have owned this car coming onto 3yrs now.
The car as always run fine until i get it back from service, last time after 1 yr of ownership never an iccup straight after service power failer ..EGR.. got it done quick under warranty.. another year on not a iccup ,straight after service and software update big drop in MPG ? ....I Wonder sometimes ....FORD .
anyway just going to fit new discs and pads all round myself maybe that way it will keep running fine.........SO Hello all i,m sure like many of you i will have much more to post..

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Gazjs


    Area Rep: Central and North Scotland (Detailing Obsessive)

  • New Member
  • PipPipPipPipPip
  • 2,873 posts
  • Ford Model: Fiesta Mk 6 Facelift
  • Location:

Posted 06 July 2010 - 05:13 PM

Welcome to the forums :D

#3 C-Max Boy 1983

C-Max Boy 1983

    Area Rep: South Scotland

  • New Member
  • PipPipPipPip
  • 218 posts
  • Ford Model: C-Max Zetec 1.6 TDCI

Posted 06 July 2010 - 05:27 PM

Welcome to the Ford Owners Club from a fellow C-Max Owner.


#4 Steve



  • Admin
  • 4,964 posts
  • Ford Model: Kugy
  • Year: 2016
  • Location: Dorset

Posted 06 July 2010 - 08:54 PM

Welcome mate

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users