Jump to content


Photo

Squeaking engine


  • Please log in to reply
5 replies to this topic

#1 cardi

cardi

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: Escort Diesel
  • Location:

Posted 06 September 2008 - 04:39 PM

I have this steady squeaking coming from the engine compartment. It is regular so must relate to engine rotation. I suspect tensioner pulley but with this weather I haven't had a chance to look, remove belt etc. Water pump maybe. Anybody had similar experience. Engine is Endura diesel turbo.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,551 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 06 September 2008 - 08:49 PM

most likley a tensioner,water pump bearing or the belt itself

#3 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 07 September 2008 - 12:20 AM

Be weary of the fuel pump, they are know to go and squeak. Just took my TD lump out today. But as said, could be the tensioner.

#4 cardi

cardi

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: Escort Diesel
  • Location:

Posted 07 September 2008 - 09:27 PM

Be weary of the fuel pump, they are know to go and squeak. Just took my TD lump out today. But as said, could be the tensioner.


Is that the lift pump? I hope you don't mean the injector pump.
The thing is that I am off to south Italy next week and want to get the vehicle sorted. I have a low mileage Fiesta for scrapping with a good non turbo engine. Does anyone know if there is much difference from the turbo? I wll probably pull offf all the bits to take as spares.

#5 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 07 September 2008 - 09:32 PM

No the injector pump. There is a difference between the 2 pumps on the engines and i have heard the internals are slightly different but i'm not 100%.
In america they run these TD engines with bigger turbo's and up the boost to 100 psi and they run on standad internals at 10 sec quarters!!!!!!

#6 cardi

cardi

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: Escort Diesel
  • Location:

Posted 10 September 2008 - 09:05 PM

It looks like it was the belt. I took it off and there was no squeak so turned it around and it's OK. Thanks for the ideas.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users