Jump to content


Photo

Is My Turbo Definately Knackered


  • Please log in to reply
3 replies to this topic

#1 RichB

RichB

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Mondeo 2.0 TDCi 115 (2005 05)

Posted 11 July 2010 - 01:50 PM

Hello,

Quick question here for hopefully a quick easy answer before I part with my hard earned cash lol.

In the following 2 scenarios, the Glowplug Light Flashes and I lose power:
1.) When restarting the car from warm
2.) When driving and the car has warmed up (sometimes after 2 minutes & sometimes after 10)

I have had fault codes read at an independant ford specialist where it flags up as P132B (Turbocharger / Supercharger boost control A performance). They have said the stupid Electric Actuator is knackered which is common.

The AA have been out to it and have gotten fault code P1331 (Turbo/Super Charger Boost High Side Control Circuit ) - The AA guy was very good to be honest and looked at everything before saying he felt it was the actuator.

I have unattached the Arm that comes from the actuator and operates the waste gate. When I operate it manually its not sticking what so ever. The Actuator just doest want to move it once warm.

---- Works fine from a cold start though ???

What I need to understand is the following.........

1.) Is it definately the actuator knackered and needing a whole new turb0 assembly

2.) Could something else be at fault and causing the car to run into limp mode? ***I JUST FIGURE THAT IF THE CAR NEEDS TO GO TO LIMP MODE THEN ITS LIKELY IT WOULD JUST CUT THE TURBO OUT***

Just heard people say theyve had this issue and its been Injectors etc etc


Many thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,551 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 11 July 2010 - 04:03 PM

code P132B is usually thrown up by sticking vanes in the turbo,i would try cleaning the vanes first as this will only cost time and a bit of cleaner, the link may help.
http://www.fordmondeo.org/forum/showtopic.php?tid/787922/post/1584320/hl//fromsearch/1/

#3 shev

shev

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: mondeo mk3

Posted 26 July 2010 - 05:21 PM

Hello,

Quick question here for hopefully a quick easy answer before I part with my hard earned cash lol.

In the following 2 scenarios, the Glowplug Light Flashes and I lose power:
1.) When restarting the car from warm
2.) When driving and the car has warmed up (sometimes after 2 minutes & sometimes after 10)

I have had fault codes read at an independant ford specialist where it flags up as P132B (Turbocharger / Supercharger boost control A performance). They have said the stupid Electric Actuator is knackered which is common.

The AA have been out to it and have gotten fault code P1331 (Turbo/Super Charger Boost High Side Control Circuit ) - The AA guy was very good to be honest and looked at everything before saying he felt it was the actuator.

I have unattached the Arm that comes from the actuator and operates the waste gate. When I operate it manually its not sticking what so ever. The Actuator just doest want to move it once warm.

---- Works fine from a cold start though ???

What I need to understand is the following.........

1.) Is it definately the actuator knackered and needing a whole new turb0 assembly

2.) Could something else be at fault and causing the car to run into limp mode? ***I JUST FIGURE THAT IF THE CAR NEEDS TO GO TO LIMP MODE THEN ITS LIKELY IT WOULD JUST CUT THE TURBO OUT***

Just heard people say theyve had this issue and its been Injectors etc etc


Many thanks



#4 shev

shev

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: mondeo mk3

Posted 26 July 2010 - 05:32 PM

hi ive got axactly the same problem with my 04 mondeo 2.0 tdci zetec that you posted on here. fairly new to these forums. but fed getting the run around with wots up with the car from garages. so just woundering wot was the final out come with your motor? would appreciate your help.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users