Jump to content


Photo

focus engine managment trouble


  • Please log in to reply
1 reply to this topic

#1 wadi

wadi

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: focus
  • Location:

Posted 07 September 2008 - 11:06 AM

hi there new to the site, very good from what ive seen i have a ford focus 1.4 16v y reg 2001 and the engine managment light has come on i have read the trouble code on my mates scanner, p0420 cat bank 1 below threshold? will this need a new lambda sensor in the exhaust or a wiring fault? is this 2 sensors on this car 1 before cat and one after? what do you ford guys recon out there? any help much appriciated cheers!!!!!!!!!!!!!!!!!!!!!!

Have something to contribute?

Sign in or register to start a topic...

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 07 September 2008 - 02:12 PM

it might just be the sensor before the cat thats playing up, with all the wet weather we have had first check that the seal is tight and not letting in any water witch would throw the code it could also be any of the following
Damaged HO2S
Malfunctioning ECT
High fuel pressure
Damaged exhaust manifold
Damaged catalytic converter
Oil contamination
Cylinder misfiring
Downstream HO2S wires improperly connected
Damaged exhaust system pipe
Damaged muffler/tailpipe assembly
Retarded spark timing ng


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users